Jump to content
  • 8
Earnestinence

[Tutorial] Video Edition - How to Setup rAthena and run Ragnarok Updated 2018-7-28

Question

141 answers to this question

Recommended Posts

  • 0

Just as a quick note, np++ isn't a requirement. You should also be teaching people how to use the import directories instead of editing files directly within conf/ as this causes the most issues when updating. 

Using wamp for a local server is also overkill with automatic installation of apache and php, as you only need MySQL you'll be better off installing MySQL Community Server and the Workbench tool.

We don't use svn, so TortoiseSVN is the wrong tool.

I'll remove this post once you've fixed your guide.

  • Upvote 2
  • Love 1
Link to comment
Share on other sites

  • 0

Other note, when compiling rA Emulator I usually make "Clean Solution" before doing "Build Solution". it's an old way that I used in eAthena before.

  • Upvote 1
Link to comment
Share on other sites

  • 0
5 hours ago, Akkarin said:

Just as a quick note, np++ isn't a requirement. You should also be teaching people how to use the import directories instead of editing files directly within conf/ as this causes the most issues when updating. 

Using wamp for a local server is also overkill with automatic installation of apache and php, as you only need MySQL you'll be better off installing MySQL Community Server and the Workbench tool.

We don't use svn, so TortoiseSVN is the wrong tool.

I'll remove this post once you've fixed your guide.

 

4 hours ago, Kaze said:

Other note, when compiling rA Emulator I usually make "Clean Solution" before doing "Build Solution". it's an old way that I used in eAthena before.

Thanks both for the notes, i'll update everything including the video now, and sorry for my mistakes 

  • Upvote 1
  • Love 1
Link to comment
Share on other sites

  • 0
1 hour ago, daShiru said:

Question how do i make this Test Server Online. My cousin wants to connect so he can help me

Host it on your PC there's some guides out there in the forums .. so use the search feature 

 

or buy a host .. 

Edited by Ciel Phantomhive
added another way!
Link to comment
Share on other sites

  • 0

Thank you for this guide. I've got one question: How are you able to compile using Visual Studio 2017? Which tool set is required that you have that I don't? Visual Studio 2017 doesn't support C++ v120 which is the tool set that is required afaik.

Edited by Anqayas
Link to comment
Share on other sites

  • 0
23 minutes ago, Anqayas said:

Thank you for this guide. I've got one question: How are you able to compile using Visual Studio 2017? Which tool set is required that you have that I don't? Visual Studio 2017 doesn't support C++ v120 which is the tool set that is required afaik.

https://github.com/rathena/rathena/wiki/Install-on-Windows

Link to comment
Share on other sites

  • 0
19 hours ago, sader1992 said:

I figured it out. I needed to right click on the solution and choose Retarget Solution first, then Clean Solution and finally Build Solution.

Edited by Anqayas
Link to comment
Share on other sites

  • 0
On 9/30/2017 at 12:59 AM, Jholz27 said:

can you help me with this? i followed all the steps but this happened

Untitled.png

use the same password as your database's login password create user account username: ragnarok password: ragnarok  watch the first video ( Step 1 & 2 ) at: 07:05

  • MVP 1
Link to comment
Share on other sites

  • 0

Hi!

Firstly thanks for such a detailed guide!

But I'm currently face with some issues with the server. It cant access and login into the SQL.

I tried changing the 127.0.0.1 to localhost and disabled my firewall can't get it to work.

 

 

1.PNG

2.PNG

Link to comment
Share on other sites

  • 0
On 10/5/2017 at 5:12 PM, endlessfaith said:

Hi!

Firstly thanks for such a detailed guide!

But I'm currently face with some issues with the server. It cant access and login into the SQL.

I tried changing the 127.0.0.1 to localhost and disabled my firewall can't get it to work.

 

 

1.PNG

2.PNG

please make sure to check you'r database login info! 

just set it to ragnarok for both username and password !! 

Link to comment
Share on other sites

  • 0

It's my first time using rAthena and making my own server
I was following the guide who has on GiftHub but was not understanding much. So I researched and found your video
I did everything exactly like you did, but this happens when i build solution (sorry for the PT-BR in Visual Studio)

image.thumb.png.c2f0af2c831f49b04308ed912f6e6f8c.png

  • Upvote 1
Link to comment
Share on other sites

  • 0
On 1/5/2018 at 10:13 AM, Hitsukay said:

It's my first time using rAthena and making my own server
I was following the guide who has on GiftHub but was not understanding much. So I researched and found your video
I did everything exactly like you did, but this happens when i build solution (sorry for the PT-BR in Visual Studio)

image.thumb.png.c2f0af2c831f49b04308ed912f6e6f8c.png

Download the latest, then try to built it again

https://github.com/rathena/rathena/archive/master.zip

or you could use this

 

Edited by BURAOT
Link to comment
Share on other sites

  • 0
On 12/27/2017 at 7:48 PM, Ciel Phantomhive said:

please make sure to check you'r database login info! 

just set it to ragnarok for both username and password !! 

I found the problem, your video and your commend are different causing some people confuse.

- At your 1st video, time 4:44 and 8:57, the log database name is "rathena_logs", but your commend is "rathena_log".

We just need to make sure the log_db_db inside \rathena\conf\import-tmpl and MYSQL schema name are same.

Capture.PNG.ccd72294bcb2789b7db1c4fbe514043e.PNG

 

Edited by mooncbz
  • Upvote 1
  • Like 1
Link to comment
Share on other sites

  • 0

can teach me how to setting mysql in 6.43minutes..that videos show mysql already installed but i not yet install n setting it..pls teach me where to download n how to setting it pls

 

in minutes 9.34..why my main.sql didnt appear many file?..help me pls

login.jpg

Link to comment
Share on other sites

  • 0

Everything is working fine, except that, when I try openning my diffed client, the game doesn't open. When I ctrl+shift+esc, the process is there, running on the background and consuming 30% of my CPU. Still, the screen doesn't appear. Can anyone help me? Thanks!

 

Edit: Figured it out. I probably skiped the setup step, so the game was running, but not through my GPU.

Edited by joao
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy.