• 4
Earnestinence

[Tutorial] Video Edition - How to Setup rAthena and run Ragnarok Updated 2018-7-28

Question

Recommended Posts

  • 0

Do i have to change some code in "packets.hpp" at "rAthena\src\config" before compiling server ?

Spoiler
#define PACKETVER 20180620

to

#define PACKETVER 20151104

and disable "PACKET_OBFUSCATION" by adding "//" infront of it ?

Spoiler
#define PACKET_OBFUSCATION

to

//#define PACKET_OBFUSCATION

and do i have to select "Disable Packet Encryption"

(https://i.imgur.com/ZPe60QN.jpg) 

in Nemo patcher before patch ?

Edited by straycatchy

Share this post


Link to post
Share on other sites
  • 0

Hey Earnestinence, 

yoou still there???

 

On 10/25/2018 at 4:43 AM, d3athrave said:

Somehow i managed to solve my problem.

 

Try to go to your rathena/src/custom/defines_pre.hpp and open it with notepad.

and just under this two lines:

#ifndef CONFIG_CUSTOM_DEFINES_PRE_HPP
#define CONFIG_CUSTOM_DEFINES_PRE_HPP

add:

#define PACKETVER YYYYMMDD <------ your client

 

then recompile. This solved my problem.

Hi, 

Could you please help what you mean by 

 

#define PACKETVER YYYYMMDD <------ your client ???

 

lets say my client's name is 2015-11-04aRagexe_patched.

So, its gonna be 
#define PACKETVER 20151104 ???

 

Hi Everyone, 

 

Please help as my SQL doesnt have the sys as per video. 

image.png.3c8e56d6ef8e83887fb9ed3c3c092fcd.png

Share this post


Link to post
Share on other sites
  • 0

Hi, I have serch for info to make a Client .exe file but I cann't find anything!! Can someone patch me an exe file? I yust need the same exe but with this options marked on NEMO:

-Use Custom Aura Sprites

-Use Custom Aura Limits

           On this custom aura limits, I dont really know how it works, but I want it to show 99 aura at 99 and 3rd Job aura at 120

If some one could help me out with the patched client or the unpatched client but explaining me how to do this I'll be happy!! I all ready read lots of guides, but if you know one that explanes how to make the unpatch file that would be awsome too!!!

 

Thx for your time reading!

Cheers!!

Share this post


Link to post
Share on other sites
  • 0
On 10/25/2018 at 3:12 AM, d3athrave said:

I have tried to search you on discord but sadly i cant find you.

 

My problem with this guide is that i cannot proceed to character creation. Can you help me with this? Thanks.

What client are you using?

 

On 11/9/2018 at 5:23 PM, eden said:

Hey Earnestinence, 

yoou still there???

 

Hi, 

Could you please help what you mean by 

 

#define PACKETVER YYYYMMDD <------ your client ???

 

lets say my client's name is 2015-11-04aRagexe_patched.

So, its gonna be 
#define PACKETVER 20151104 ???

 

Hi Everyone, 

 

Please help as my SQL doesnt have the sys as per video. 

image.png.3c8e56d6ef8e83887fb9ed3c3c092fcd.png

3
Quote

lets say my client's name is 2015-11-04aRagexe_patched.

So, its gonna be 
#define PACKETVER 20151104 ???

Yes. that is correct! 

- sys database is not important for the tutorial.

 

On 11/13/2018 at 6:41 PM, AsynjuRO said:

Hi, I have serch for info to make a Client .exe file but I cann't find anything!! Can someone patch me an exe file? I yust need the same exe but with this options marked on NEMO:

-Use Custom Aura Sprites

-Use Custom Aura Limits

           On this custom aura limits, I dont really know how it works, but I want it to show 99 aura at 99 and 3rd Job aura at 120

If some one could help me out with the patched client or the unpatched client but explaining me how to do this I'll be happy!! I all ready read lots of guides, but if you know one that explanes how to make the unpatch file that would be awsome too!!!

 

Thx for your time reading!

Cheers!!

You can create the .exe application file by nemo. All you need is the unpacked client file. 

Quote
3

Regarding the aura, please search for it in the forums and the wiki. 

 

On 10/28/2018 at 6:13 PM, AidiRO said:

how to choose renewal or pre renewal?

You can find that on the wiki, or the forums. it's easy 

 

On 10/20/2018 at 8:14 AM, beanbean02 said:

I followed all your guide but.. Always FAILED TO CONNECT WHY?

Hi there,

this is probably late, but is there any error on logs? and what client are you using?

Share this post


Link to post
Share on other sites
  • 0

does this still work seem to be having problems with compiling Error C1083. I downloaded it with Github Dekstop

Share this post


Link to post
Share on other sites
  • 0

Hello! I am starting to experiment to make a pre renewal server and I ran into an issue with your guide... 

On 7/12/2017 at 1:20 AM, Earnestinence said:

I noticed that in your guide we have to modify the clientinfo.xml but the prerenewal data folder doesn't have the clientinfo.xml, only the renewal one does.

How can I solve this problem?

 

Share this post


Link to post
Share on other sites
  • 0
On 1/4/2018 at 6:13 PM, Hitsukay said:

It's my first time using rAthena and making my own server
I was following the guide who has on GiftHub but was not understanding much. So I researched and found your video
I did everything exactly like you did, but this happens when i build solution (sorry for the PT-BR in Visual Studio)

image.thumb.png.c2f0af2c831f49b04308ed912f6e6f8c.png

image.thumb.png.9d0afd086228bdfe6c843309cce69c5f.png

I had the same problem, what helped me was adding this. I hope this helps someone :3.

Share this post


Link to post
Share on other sites
  • 0
On 1/15/2019 at 6:18 AM, akki24 said:

Hello! I am starting to experiment to make a pre renewal server and I ran into an issue with your guide... 

I noticed that in your guide we have to modify the clientinfo.xml but the prerenewal data folder doesn't have the clientinfo.xml, only the renewal one does.

How can I solve this problem?

 

Create one or just use this

 

<?xml version="1.0" encoding="euc-kr" ?>
<clientinfo>
	<desc>Ragnarok Client Information</desc>
	<servicetype>korea</servicetype>
	<servertype>primary</servertype>
	<connection>
		<display>Local</display>
      		<address>127.0.0.1</address>
      		<port>6900</port>
      		<langtype>1</langtype>
		<registrationweb>www.ragnarok.com</registrationweb>
		<aid>
		<admin>2000000</admin>
		</aid>
		<loading>
			<image>loading00.jpg</image>
			<image>loading01.jpg</image>
			<image>loading02.jpg</image>
			<image>loading03.jpg</image>
			<image>loading04.jpg</image>
			<image>loading05.jpg</image>
			<image>loading06.jpg</image>
		</loading>
   	</connection>
</clientinfo>

 

 

Share this post


Link to post
Share on other sites
  • 0

is there a way I can add special skill to all classes? e.g. AB has skills that summons mobs from biolab to aid in battle? TIA for answering

Share this post


Link to post
Share on other sites
  • 0

Thank for the tutorial, im traying to make Online server on my own house! Thanks!

Hey, when re-compile char_server.conf and map, on import folder dont change de configuration. What can we do?Hey, when re-compile char_server.conf and map, on import folder dont change de configuration. What can we do?

Share this post


Link to post
Share on other sites
  • 0

Much respect and appreciation for the guide and easy to follow video configurations. This helped tremendously for beginner such as myself. Only one small suggestion, it would be useful to note where to obtain the 2015-11-04aRagexe.exe client which is one of the more stable client versions.

Share this post


Link to post
Share on other sites
  • 0

I followed this guide to a T and for some reason the char server isn't connecting? The passwords match on MySQL Workbench, so I'm not sure what I could be doing wrong.

Thanks for your time!

cmd_2019-04-21_20-39-33.png

Share this post


Link to post
Share on other sites
  • 0
12 hours ago, Razza said:

I followed this guide to a T and for some reason the char server isn't connecting? The passwords match on MySQL Workbench, so I'm not sure what I could be doing wrong.

Thanks for your time!

cmd_2019-04-21_20-39-33.png

Check your mysql password, and inter.conf file in ipmort folder 

Share this post


Link to post
Share on other sites
  • 0

I went ahead and restarted from the beginning and got it working. Thank you for taking the time to answer and for the guide itself.

  • Love 1

Share this post


Link to post
Share on other sites
  • 0

Hey guys,

I am having the same issue, I have followed the tutorial to a T but run into this error as well,
image.thumb.png.96cc4dccfdeeddcf300790fcb32a1226.png

Does anyone know how to fix this? I have checked the files I have edited and they are all set as userid: username passwd: password and I have also changed s1 and p1 in the login table to username and password

I have not touched s1 or p1 anywhere else as this guide did not direct me to. Any help would be greatly appreciated 

Thanks!

Share this post


Link to post
Share on other sites
  • 0

help me !

I followed the tutorial step by step, however I have a problem.

see:

image.png.509bc0f746f800971eeab279402a9f1f.png

 

thx

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)
14 hours ago, Kyoshira said:

help me !

I followed the tutorial step by step, however I have a problem.

see:

[Error]: parse_char: Received unknown packet 0x64 from ip 'xx.xx.xx.xx'! Desconnecting!

thx

Greetings,
First, don't show your IP for any reason. Secondly, what led to this error? what client are you using?

Edited by Earnestinence

Share this post


Link to post
Share on other sites
  • 0
On 5/14/2019 at 10:49 AM, Earnestinence said:

Greetings,
First, don't show your IP for any reason. Secondly, what led to this error? what client are you using?

 The problem was my server ports.

,

thx

  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0

Hi, thank you for the awesome tutorial, I learned a lot! 

I had an issue that i found no one else having. If its not too much trouble, i could use some help.

After a sucessful compile/build, following the steps of the tutorial, I started the "runserver.bat". Everything worked fine for 15 seconds, no message of error whatsoever. 

Suddenly the server print a message about restarting, everything closes automatically and the "runserver.bat" file vanishes. I cant open the server no more.

The client configuration went well, but once im inside ragnarok and I try to log in it says "failed to connect to the server".

Unfortunately, there is no message of error, or anything to show to help my search.

 

Any ideas of what could it be?

 

Thanks anyway! 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...