MathReaper

[PACKETVER 20180620] Client Release 2018-06-20eRagexeRE

Recommended Posts

On 10/14/2018 at 3:48 AM, iubantot said:

may i know what translation are you using?

Im using Zackdreaver + my own itemInfo.

On 10/14/2018 at 4:46 AM, Slyx said:

Hi @MathReaper

i experience the same problem as @fictionx does. Client crash when selecting new character. I am using latest kRO from here and it is updated:

Diffed with only recommended selections but nothing changed.weird.

My suggestion is: this clients have a way too big file to load when you go to the Character Selection, so, sometimes it can crash.

Share this post


Link to post
Share on other sites

Do you have other link for kro latest client?

Share this post


Link to post
Share on other sites
5 minutes ago, Slyx said:

Do you have other link for kro latest client?

I'm actually using a old one, that I updated using Ai4rei patcher.

 

Share this post


Link to post
Share on other sites

Whenever I change the langtype to 1 it won't load. I'm using the most recent data folder but everytime I change the langtype I get the error nil value.

UPDATE: Fix with this:

On 8/26/2018 at 8:56 AM, TheDerpySupport said:

With 2018 Clients you can do one of two things to support langtype 1;

1. In your `luafiles514/lua files/` folder there is a folder called "Service_Korea" and within it a file called "ExternalSettings_KR"; Rename the folder to "service_usa" and the file to "externalsettings_usa"

2. With NEMO diff your client to use the "Always read Korean External Settings"

 

This is not true so please do not spread false information

 

Edited by redhotzip
found fix
  • Upvote 2

Share this post


Link to post
Share on other sites
On 10/13/2018 at 2:23 PM, MathReaper said:

Everything ok with your sclientinfo.

Make sure that you have only that sclientinfo in all your files (GRF/DATA FOLDER) and don't enable any other NEMO's patch if isn't recommended and make a test.

thx for info, i already have found the solution for it. its server side issue, updated to latest rAthena packetver. now its working as charm

screenAuroraRO007.jpg

Share this post


Link to post
Share on other sites

anyone know how to translate the quest info?

image.png.3dc91c717de1e17a36b45a16fd3fb93b.png

 

@edit:

NVM, i just changed the OngoingQuestInfoList.lub with another one.

Edited by fictionx
solved

Share this post


Link to post
Share on other sites

 

On 10/13/2018 at 8:01 AM, MathReaper said:

I've patched one for you using 4144 Nemo's fork.

All recommended patches are enabled and I've enabled the "Disable Packet Encryption" by myself, so make sure your server have packet obfuscation disabled on Config/packets.hpp.

2018-06-20eRagexeRE Patched

sir are u  use nemo patch from this link ?? 

https://gitlab.com/4144/Nemo

 

because i use nemo patch from this link 

few profile cant apply 

Share this post


Link to post
Share on other sites
On 10/16/2018 at 10:11 AM, musica2 said:

thx for info, i already have found the solution for it. its server side issue, updated to latest rAthena packetver. now its working as charm

screenAuroraRO007.jpg

Which file u edit for change rathena packetver?

On 10/16/2018 at 11:36 AM, Gamezstar said:

 

sir are u  use nemo patch from this link ?? 

https://gitlab.com/4144/Nemo

 

because i use nemo patch from this link 

few profile cant apply 

Secret nemo is not support 2018 client, use 4144 Nemo.

Share this post


Link to post
Share on other sites
8 hours ago, GMxMomi said:

Which file u edit for change rathena packetver?

in src/config/packets.hpp u may use this script:-

#ifndef PACKETVER
    /// Do NOT edit this line! To set your client version, please do this instead:
    /// In Windows: Add this line in your src\custom\defines_pre.hpp file: #define PACKETVER YYYYMMDD
    /// In Linux: The same as above or run the following command: ./configure --enable-packetver=YYYYMMDD
    #define PACKETVER 20180620
#endif

 

or u can use latest update from rathena git.

packets.hpp

Share this post


Link to post
Share on other sites
On 10/16/2018 at 10:39 PM, musica2 said:

in src/config/packets.hpp u may use this script:-

#ifndef PACKETVER
    /// Do NOT edit this line! To set your client version, please do this instead:
    /// In Windows: Add this line in your src\custom\defines_pre.hpp file: #define PACKETVER YYYYMMDD
    /// In Linux: The same as above or run the following command: ./configure --enable-packetver=YYYYMMDD
    #define PACKETVER 20180620
#endif

 

or u can use latest update from rathena git.

packets.hpp

Thanks

Share this post


Link to post
Share on other sites
On 10/13/2018 at 6:58 AM, MathReaper said:

 

  Hide contents

9iIgWBu.png

 

I'm curious, how do you disable the doram option?

Share this post


Link to post
Share on other sites
On 10/16/2018 at 10:45 AM, fictionx said:

anyone know how to translate the quest info?

image.png.3dc91c717de1e17a36b45a16fd3fb93b.png

 

@edit:

NVM, i just changed the OngoingQuestInfoList.lub with another one.

@edit:

i already replace with the translation files...hehehe

 

Edited by skymia

Share this post


Link to post
Share on other sites
56 minutes ago, JaranSwitch0101 said:

@MathReaper Help...I can't open skill tree when login with this ragexe 

 

😃

  • Like 1

Share this post


Link to post
Share on other sites

Hello everyone,

I tried to use this new client, i set the same nemo configuration but when i start the client, i have an error

Quote

ERROR
CTwitterDataMgr::CreateInstance()

And after that my client crash. Anyone have an idea ? 

Share this post


Link to post
Share on other sites

Can you help me may be you have some clue


Updated: I already found the solution
You guys need to disable Doram function if you're using latest KRO (texture chaged)

Edited by z3niths

Share this post


Link to post
Share on other sites

I have a problem in langtype 1

langtype 0 is korean and langtype 1 is a symbol

itemInfo.lua and itemInfo.lub already added to system folder

but  the problem still here

please help

Spoiler

image.thumb.png.5273afd052f25b7f853621506a291498.png

 

Share this post


Link to post
Share on other sites
18 hours ago, AidiRO said:

I have a problem in langtype 1

langtype 0 is korean and langtype 1 is a symbol

itemInfo.lua and itemInfo.lub already added to system folder

but  the problem still here

please help

  Hide contents

image.thumb.png.5273afd052f25b7f853621506a291498.png

 

You need to diff the ragexe with the option "Load Custom lua file instead of iteminfo*.lub (Recommended)" activated and make the corrct path like "System/itemInfo.lua" at the option request.

Edited by CyberDevil

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...