Jump to content
  • 0
Jade

HELP - stat bonus bug

Question

sorry, i really don't know if it is the right section for this, I don't know where to start regarding this problem.
the bug is that it give an overflowing stats so sudden in any job, (when they're using skill? or what) +9k+ on some stats, somethimes +500+, or a negative 2k stats.bug6.png.14aa338939dbfcfaf9cf1f0d718b8b42.pngbug5.png.d22f307c2a5bc995e65ed86fcefb8b5f.pngbug4.png.8292ff876dedc0f6dfa7d6d623b229cd.pngbug3.png.46bdd49a1ef98e47da9a713ab7206d74.png

bug2.png.20daea25d776ad3c64343c15e31a44c7.pngbug.png.8bb2275671ef0e85e20b84326e983844.pngbug7.jpg.181417f58d310ce535db290d36d0361d.jpg

can someone help me with this?
is it on source? status? or what / where would it be?
i'll give the necessary file that you need for you to check...

Edited by Jade
Link to comment
Share on other sites

16 answers to this question

Recommended Posts

  • 0
1 minute ago, crazyarashi said:

check the item script in item_db :))

some of the picture i sent don't have any item equipped on

Link to comment
Share on other sites

  • 0
2 minutes ago, crazyarashi said:

this isn't possible if you're using the current rathena, unless someone mess up with your src.

where will this be in source? do i have to drop my src files here, for you to see

Edited by Jade
Link to comment
Share on other sites

  • 0

at first they thought that it's a negative buffs on gefenia monster or mvp monster
then
it occurs so sudden on town...
when they uses a skill or changed equip

Link to comment
Share on other sites

  • 0
  • check if you have any npc script that give bonus statuses
  • check if your src are edited
  • check if your item_db are edited
  • check if your job_db2.txt are edited
Link to comment
Share on other sites

  • 0
On 7/3/2018 at 4:15 PM, Emistry said:
  • check if you have any npc script that give bonus statuses
  • check if your src are edited
  • check if your item_db are edited
  • check if your job_db2.txt are edited

for job_db2.txt if your server is at job 120?
do i have to add also on that files? with only 70 jobs? just 0,0,0,0,0, and so on just to complete the 120 reading?.. ?

 

the skill icon got a negative timer? how's that??

update: i thought it was on the healer part he's the script of my healer
sometimes whenever i click the healer, (got the agi and bless icon with the timer 4mins) then after i click it again, the timer wont refresh to 4mins, then thats when the bug starts, after the 4mins timer it goes negative, then the stats are now bug.

//===== rAthena Script =======================================
//= Healer
//===== By: ==================================================
//= Euphy
//===== Current Version: =====================================
//= 1.1
//===== Compatible With: =====================================
//= rAthena Project
//===== Description: =========================================
//= Basic healer script.
//===== Additional Comments: =================================
//= 1.0 Initial script.
//= 1.1 Aligned coordinates with @go.
//============================================================

-	script	Healer	-1,{

	[email protected] = 0;	// Zeny required for heal
	[email protected] = 1;	// Also buff players? (1: yes / 0: no)
	[email protected] = 10;	// Heal delay, in seconds

	if (@HD > gettimetick(2))
		end;
	if ([email protected]) {
		message strcharinfo(0), "Healing costs " + callfunc("F_InsertComma",[email protected]) + " Zeny.";
		if (Zeny < [email protected])
			end;
		if (select("^0055FFHeal^000000:^777777Cancel^000000") == 2)
			end;
		Zeny -= [email protected];
	}
	specialeffect2 EF_HEAL2;
	percentheal 100,100;
	atcommand "@identifyall";
	if ([email protected]) {
		specialeffect2 EF_INCAGILITY;
		sc_start SC_INCREASEAGI,240000,10;
		specialeffect2 EF_BLESSING;
		sc_start SC_BLESSING,240000,10;
		sc_end SC_BROKENARMOR;
		sc_end SC_BROKENWEAPON;
	}
	repairall;
	if ([email protected])
		@HD = gettimetick(2) + [email protected];
	end;
}
ayothaya,207,169,6	duplicate(Healer)	Healer#ayo	677


then i used my char skills (true sight for example) so the icon with 30secs timer goes on, and then when i click again, the timer wont reset to 30secs. it continues to tick then goes negative

UPDATE: got this error
[Error]: delete_timer error : function mismatch (nil)(unknown timer function) != 0x501ab0(status_change_timer)

Edited by Jade
Link to comment
Share on other sites

  • 0

I'm currently having this bugs, it triggers every 5minutes before war of emperium ends, any solution on this? I try fixing this by restarting the server and nuke everyplayer that has bug stats. I have a feeling about the guild skills bonus stats? I still have no idea. Thanks for any help.

Link to comment
Share on other sites

  • 0

Currently, experiencing this with the latest rev, at first everything is okay, I didn't edit anything. It bugs the Delays and Stats? 🙂 

Did you fix it sir @Vy Low?

Edited by Ukiram
Link to comment
Share on other sites

  • 0
16 hours ago, Ukiram said:

Currently, experiencing this with the latest rev, at first everything is okay, I didn't edit anything. It bugs the Delays and Stats? 🙂 

Did you fix it sir @Vy Low?

no fixed yet applied

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy.