anacondaq

Ragnarok Online complete offline server & client pack 2019 | Make your RO server in less than 5 minutes

Recommended Posts

i just followed the 2mins step 

when i runserver.bat

this errors appears cant 

 

image.thumb.png.9f6984b0203a4c3e14cf00df61901c4a.png

Share this post


Link to post
Share on other sites
4 hours ago, sonatta09 said:

i just followed the 2mins step 

when i runserver.bat

this errors appears cant 

Your open server is offline. Make sure your Open Server running and you see green flag.

Share this post


Link to post
Share on other sites

can i have your list for 2018 client that. i just want to change something on nemo? or can you send me the profile

Share this post


Link to post
Share on other sites
9 minutes ago, tenziekhai said:

can i have your list for 2018 client that. i just want to change something on nemo? or can you send me the profile

the profile and all patches inside exe/ folder in NEMO folder in your misc files (05 folder).

 

Share this post


Link to post
Share on other sites

do you know exactly how can i change the font size? coz its too small. cant figure it out pls help me. a

Share this post


Link to post
Share on other sites
3 hours ago, tenziekhai said:

do you know exactly how can i change the font size? coz its too small. cant figure it out pls help me. a

S60Vznz.png

Share this post


Link to post
Share on other sites

Hi @anacondaq may i request for visual studio you are using for? and it's great when there's a Vs for windows 7 32 bit. thank you so much for this.

Share this post


Link to post
Share on other sites
25 minutes ago, Quesooo said:

Hi @anacondaq may i request for visual studio you are using for? and it's great when there's a Vs for windows 7 32 bit. thank you so much for this.

I do not know about x86, because long time not using it. I stick to x64, but release builds compiled for x86 platform. What about VS, try VS 2017 for example.

 

  • Upvote 1

Share this post


Link to post
Share on other sites
17 hours ago, anacondaq said:

I do not know about x86, because long time not using it. I stick to x64, but release builds compiled for x86 platform. What about VS, try VS 2017 for example.

 

Thank you i found a better 1.
btw any solution for this? every time is restart my computer and rerun the server console again i always get this problem.

image.thumb.png.37ce9f563b0e94471c552084050ea877.png

 

Share this post


Link to post
Share on other sites
On 3/25/2019 at 4:36 PM, anacondaq said:

 

I really appreciate the work you have done, but the emulator provided by you is missing the script Nightmarish Jitterbug, will it not be difficult for you to add it! And if it is possible to add the Sky Fortress Invasion script as well!

 

Share this post


Link to post
Share on other sites
Spoiler
On 4/20/2019 at 11:17 AM, Quesooo said:

Thank you i found a better 1.
btw any solution for this? every time is restart my computer and rerun the server console again i always get this problem.

image.thumb.png.37ce9f563b0e94471c552084050ea877.png

You need to run the OpenServer and start it before running the emulator

Share this post


Link to post
Share on other sites
Posted (edited)

 

hello and excuse the English When I downloaded the guide and installation, as in his video, I do not get everything perfect but now it does not work and I get this error in the opens64 x64 If you help me solve it, I would appreciate it

image.png.4dad5d3a959e4524daa490c29728a3b7.png

Edited by Cyanide

Share this post


Link to post
Share on other sites
On 4/20/2019 at 6:17 AM, Quesooo said:

btw any solution for this? every time is restart my computer and rerun the server console again i always get this problem.

 

Looks like you did edit manually by yourself default config files inside /conf/import folder. Sorry, I can't help you with your issue. Try to use original version and learn how is it configured and not need to touch config files. Also, make sure that you're running OpenServer.

 

On 4/21/2019 at 9:18 PM, Tannary said:

I really appreciate the work you have done, but the emulator provided by you is missing the script Nightmarish Jitterbug, will it not be difficult for you to add it! And if it is possible to add the Sky Fortress Invasion script as well!

Hi. Add these instances by yourself. It's easy (if you can find these instances). The emulator inside the package always up to date, and have tools for people who use this package to manually upgrade emulator or client-side by themselves. Even guide and video show it.

16 hours ago, Cyanide said:

hello and excuse the English When I downloaded the guide and installation, as in his video, I do not get everything perfect but now it does not work and I get this error in the opens64 x64 If you help me solve it, I would appreciate it

 

Try to run x86 is it work for you? If still not, try to optionally install https://www.sendspace.com/file/e5lg17 (redistributables (different versions)). Might help, but I'm not sure, first time see the error. 

Share this post


Link to post
Share on other sites

thanks!So here's a simple explanation.

Share this post


Link to post
Share on other sites
Posted (edited)

😃

Update 27 April 2019:

  • upgraded emulators to actual hash: https://github.com/rathena/rathena/commit/21e7a35b729be8a9edafa6eb49e2e52060e09ff4
  • upgraded client-side to actual versions
  • upgraded and re-packed client files and also added some fixes to these grfs for common issues posted here or founded by me earlier
  • tested AI for the game client, if someone wishes to share their own good working AI for homunculus - go ahead to the topic.
  • OpenServer not updated to 5.3.0 version, because current one works just fine, and I'm lazy to upgrade it
  • Instead of old customized (repacked with 7z) client, now used LATEST official kRO client updated up to 27 April 2019 (2.7GB)
  • Minor small fixes here and there.
  • All files repacked instead of SFX to winrar archives. So please use any tool like 7zip or winrar to extract these archives
  • All files re-uploaded, new links posted already. Broken links fixed, and so on.
  • Game exe re-patched with new NEMO patches, and tested, fixed visual issues, etc things.
  • Summary: the package is stable and good for a long run. Use it. For a long time I will not update the package because of many reasons.
  • For people who wish to upgrade your current (previous) version to this one -> please go to few pages back, I already posted earlier how to do that).

 

Enjoy. /kis

Edited by anacondaq
  • Upvote 2
  • Love 1
  • MVP 1

Share this post


Link to post
Share on other sites

@anacondaq Please sir , Can I know the used patches in your client ( 2018-04-18bRagexeRE ) that located in : 02_client_side.rar/FOR_RENEWAL_EMULATOR/2018-04-18bRagexeRE_patched.exe

Because I tried more than 6 times and still client failure 

Share this post


Link to post
Share on other sites

just a problem when i go to extract the client side files the errors in the data and exe for launching the program for the server stop the full extraction process and only supplies me with a partial extraction which stops me from being able to launch the program to play on the server and the files are corrupt on all the download pages

 its the Renewal files that do not extract properly pre-re works  normally and im looking for renewal

Share this post


Link to post
Share on other sites

Hello, I got this error
maybe you can update your grf in newest update

this error appear when I try to bragi, idun & etc

Thank you

error.jpg

Share this post


Link to post
Share on other sites
On 5/3/2019 at 3:38 PM, Diana said:

Please sir , Can I know the used patches in your client

misc/nemo/exe find this folder

On 5/10/2019 at 2:52 PM, ittiphol said:

This version have Bot function ?

No

On 5/11/2019 at 5:54 AM, DragonHero said:

just a problem when i go to extract the client side files the errors in the data and exe for launching the program for the server stop the full extraction process and only supplies me with a partial extraction which stops me from being able to launch the program to play on the server and the files are corrupt on all the download pages

I can't help you with this. Re-download files again, looks like they're broken or I dunno. 

On 5/12/2019 at 2:25 PM, lChyztl said:

maybe you can update your grf in newest update

this error appear when I try to bragi, idun & etc

Hi, thank you for the report. But for some reason, I can't reproduce it. Can you make sure that you're using all files from the package? 

10 hours ago, chrismags said:

Hi, Can i kindly ask if we can and how can we add this new set of items from https://www.divine-pride.net/forum/index.php?/topic/3281-archive-kro-cash-shop-items/ Thanks! Or add The new Items to the game with DB sorry if I'm kinda newbie. Thanks for the hard work!

Use SDE (server database editor) to view all items existing in the game. 

Share this post


Link to post
Share on other sites
10 hours ago, pueblodefairy said:

those items are available

I tried summoning it and looking at the db it's not there... can you send a screenshot?

5 hours ago, anacondaq said:

Use SDE (server database editor) to view all items existing in the game. 

I used SDE but it doesn't show in the editor like item 19296 https://www.divine-pride.net/database/item/19296 any ideas how can i update it? 

I checked the re- db and https://raw.githubusercontent.com/rathena/rathena/master/db/re/item_db.txt but its not listed there. Thanks!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...