anacondaq

Ragnarok Online complete offline server & client pack 2019 | Make your RO server in less than 5 minutes

Recommended Posts

First of all,

Thank you for providing me with THISSS SUPEERRBB EASY INSTALLATION RAGNAROK OFFLINE...

soo glad there is someone care enough to a newbie, thank you once again.

and,

i would like to ask,

i'm quite familiar with Ragnarok Offline, i would like to create a custom item.

so my step is:

  • edit: 01_emulator\rathena_RENEWAL\db\re\item_db.txt, i'm quite sure with the structure inside, so the structure would be fine. and yeah i use renewal server.
  • edit client side: this is where i got confuse, i tried to edit client side, which is inside rathena_RENEWAL_2019.grf. Thanks for the tools i could edit the note inside.
  • I change idnum2itemdesctable.txt, idnum2itemdisplaynametable.txt, and idnum2itemresnametable.txt.

but the result was like this:

Spoiler

1.jpg.a85d3a9389daf349b0c2f537d7721ec5.jpg

is there anything is wrong with my step?

thanks for the help...

Share this post


Link to post
Share on other sites
Spoiler
8 minutes ago, nightnight said:

First of all,

Thank you for providing me with THISSS SUPEERRBB EASY INSTALLATION RAGNAROK OFFLINE...

soo glad there is someone care enough to a newbie, thank you once again.

and,

i would like to ask,

i'mquite familiar with Ragnarok Offline, i would like to create a custom item.

so my step is:

  • edit: 01_emulator\rathena_RENEWAL\db\re\item_db.txt, i'mquite sure with the structure inside, so the structure would be fine. and yeah i use renewal server.
  • edit client side: this is where i got confuse, i tried to edit client side, which is inside rathena_RENEWAL_2019.grf. Thanks for the tools i could edit the note inside.
  • I change idnum2itemdesctable.txt, idnum2itemdisplaynametable.txt, and idnum2itemresnametable.txt.

but the result was like this:

  Reveal hidden contents

1.jpg.a85d3a9389daf349b0c2f537d7721ec5.jpg

is there anything is wrong with my step?

thanks for the help...

 

 

8 minutes ago, nightnight said:

I change idnum2itemdesctable.txt, idnum2itemdisplaynametable.txt, and idnum2itemresnametable.txt.

Wrong. The new exes after 2012-04-10Ragexe does not use these files anymore. All guides where you will see these files = not actual, and will not work with this exe.

You need to find guides about ItemInfo.lua, and accinfo.lub, accinfo.lua inside grfs (luafiles514\datainfo\)

In SDE (server database editor) you can easy edit / add new items.

GPknmnP.png

Look on the screenshot above. 

 

1. it's a place where you need drag and drop all your grfs what you have in the client, and move to the top your main grf where data is (make sure that data.grf in the last order) while RENEWAL_2019 grf first one.

2. Here you need to click on Browse button and select where is your emulator/db/pre or emulator/db/re folder is. SDE need this path for correctly load data from your .txt files from your /db folder.

3. Here you need to click on Browse Button and go to your client folder System/ folder and select there ItemInfo.lua file. Inside this file almost ALL items and their translations, also inside this file client read and know where is sprites, resources what need to display to players, what item names will be, what item descriptions, whatever.

4. Here is optional achievement DB (fully optional, and as far as I remember not working, because of yml format, which not supported by SDE)

5. Client Encoding, make sure that your client encoding is Korean 949, to make sure you always see text in Korean. this is MEGA important, because all data in grfs in Korean. And you always need to keep original encoding, otherwise your game client will not work properly. 

6. Now, when everything will be done by you click -> file save. And click on item tab, and you will see all items from your game-server data, with their sprites, with their descriptions, whatever.



Share this post


Link to post
Share on other sites
16 minutes ago, Anacondaqq said:
  Reveal hidden contents

 

 

Wrong. The new exes after 2012-04-10Ragexe does not use these files anymore. All guides where you will see these files = not actual, and will not work with this exe.

You need to find guides about ItemInfo.lua, and accinfo.lub, accinfo.lua inside grfs (luafiles514\datainfo\)

In SDE (server database editor) you can easy edit / add new items.

GPknmnP.png

Look on the screenshot above. 

 

1. it's a place where you need drag and drop all your grfs what you have in the client, and move to the top your main grf where data is (make sure that data.grf in the last order) while RENEWAL_2019 grf first one.

2. Here you need to click on Browse button and select where is your emulator/db/pre or emulator/db/re folder is. SDE need this path for correctly load data from your .txt files from your /db folder.

3. Here you need to click on Browse Button and go to your client folder System/ folder and select there ItemInfo.lua file. Inside this file almost ALL items and their translations, also inside this file client read and know where is sprites, resources what need to display to players, what item names will be, what item descriptions, whatever.

4. Here is optional achievement DB (fully optional, and as far as I remember not working, because of yml format, which not supported by SDE)

5. Client Encoding, make sure that your client encoding is Korean 949, to make sure you always see text in Korean. this is MEGA important, because all data in grfs in Korean. And you always need to keep original encoding, otherwise your game client will not work properly. 

6. Now, when everything will be done by you click -> file save. And click on item tab, and you will see all items from your game-server data, with their sprites, with their descriptions, whatever.



ohh noo... the screenshot is not come out.... 😥😥

Share this post


Link to post
Share on other sites
27 minutes ago, nightnight said:

ohhnoo... the screenshot is not come out.... 😥😥

try this.

GPknmnP.thumb.png.f8f6ce16a6418da214280769dc573402.png

Share this post


Link to post
Share on other sites
26 minutes ago, Anacondaqq said:

try this.

 

Spoiler

2.jpg.4cec309862b4161d67498be4462fa4e9.jpg

You're the best.

Guess, i will hang around here, coz this is very very new for me... thanks for teaching me.

I believe my knowledge for ragnarok offline is outdate... so sad... love this game since my highschool.

Share this post


Link to post
Share on other sites

Good day. what are the Instances available in this RO? thank you very much 🙂

 

Share this post


Link to post
Share on other sites

Good day there is no KRO files in the clean KRO client folder. where can i download it? thank you 🙂

Share this post


Link to post
Share on other sites
4 hours ago, Emory Faust said:

Good day there is no KRO files in the clean KRO client folder. where can i download it? thank you 🙂

GuvqYYr.png

 

rsSesq4.png

 

Share this post


Link to post
Share on other sites

Just want to leave a (second) big thank you here.

I'm using this since 2018 for singleplayer experience and LAN play with friends.

This package is top notch and totally hassle free.

You are doing a great job in your free time.

Kind Regards

  • Upvote 2

Share this post


Link to post
Share on other sites

Thank you very much for this compilation.

Is there a way to manually update/mod the files so that Double Attack can crit?

Share this post


Link to post
Share on other sites

i have some problem when i add Arabic word in the script it come a unknown language   Screenshot.jpg.89c984b3de285b3c6e58cd20b9b99dee.jpg i don't know what to do really

i change the   <langtype>19</langtype> to use the Arabic word in the npc yes i can Writ  Arabic in the chat but the npc no support 

the Explanation and file i use is from here 

 

 client  2018-04-18bRagexeRE

nemo can't change anything in the client i try it 

 

and this how the korea language look like this in my server Screenshot001.jpg.fa98fc376ff7729bcc335afb02944145.jpg

 

 

can you help me plz

Share this post


Link to post
Share on other sites

can i use 20180620aRagexe with this??
 

Share this post


Link to post
Share on other sites

Thank you very much for your contribution! I wanted to make a query, to enable the use of the letter Ñ and the graphic accents of Spanish, I need to enable the ASCII characters in the exe, could I upload an exe with that functionality? please

Share this post


Link to post
Share on other sites

Hello, i checked every skill and i am working on check details and post it here to notify. I found this error in Wandy / Minstrel Skill, "Sound of destruction" i was trying to fix it and post it here, but it was imposible for me. Can you help me to fix it? It is an important detail. Thanks for your help

PS. Every skill works excellent this was the first skill with problems I find. 

207058784_soundofdes2.png.e5794e206bb5a882c3e74debcf2b2091.png 682130273_soundofdes.png.7478f94bb20af16b7acf5cc70c70d9ed.png

Share this post


Link to post
Share on other sites

Hello, I have a question. I have searched for 3 hours but still no solution.
When i set <langtype> to 15 in sclientinfo.xml, the login background always black. How to fix it?

Share this post


Link to post
Share on other sites
Posted (edited)
On 3/29/2019 at 1:09 PM, padfoota said:

Is there a way to manually update/mod the files so that Double Attack can crit?

readme.txt there is a guide how manually update. Or watch the video.

On 3/31/2019 at 11:05 PM, KaBoss said:

can you help me plz 

No, sorry, I do not know how to help you.

On 4/1/2019 at 6:32 PM, Schreimind said:

Hi thanks for the guide on how to create a server offline but how can i change it to online?

Read the first topic header (first post in this topic by me) and follow each link. And you will find the answers to your question.

On 4/2/2019 at 12:09 AM, AinsLord said:

can i use 20180620aRagexe with this??

No. You need recompile the server-side for using with this. And turn off your hexed exe packet obf.

On 4/2/2019 at 11:52 PM, Jesca said:

How can I add ROPs to my account? Server Renewal

I do not understand what do you want.

On 4/6/2019 at 7:08 PM, cromilakis said:

Thank you very much for your contribution! I wanted to make a query, to enable the use of the letter Ñ and the graphic accents of Spanish, I need to enable the ASCII characters in the exe, could I upload an exe with that functionality? please

You need to change <servicetype> and <langtype> inside your clientinfo.xml inside your data/ or grf files. To values from here: https://herc.ws/wiki/Clientinfo.xml

20 hours ago, pueblodefairy said:

Can you help me to fix it? It is an important detail. Thanks for your help

 

https://github.com/rathena/rathena/issues/3479

I think this is rAthena bug. But I'm not sure.

https://github.com/rathena/rathena/blob/master/db/re/skill_db.txt#L1197

 

 

 

Edited by anacondaq
  • Love 1

Share this post


Link to post
Share on other sites
4 hours ago, NoNama said:

Hello, I have a question. I have searched for 3 hours but still no solution.
When i set <langtype> to 15 in sclientinfo.xml, the login background always black. How to fix it?

I do not know how to fix it. And I'm not able to reproduce this.

Share this post


Link to post
Share on other sites
Quote

 And turn off your hexed exe packet obf.

how can i do that? sorry pretty much noob for the latest clients 🙂

TIA

Share this post


Link to post
Share on other sites
On 4/9/2019 at 8:39 PM, AinsLord said:

how can i do that? sorry pretty much noob for the latest clients 🙂

NEMO, all inside the package. And inside the NEMO folder you can find applied_patches.log file which can be used by NEMO to apply all patches what I did applied to the exe.

  • Upvote 1

Share this post


Link to post
Share on other sites
5 hours ago, anacondaq said:

NEMO, all inside the package. And inside the NEMO folder you can find applied_patches.log file which can be used by NEMO to apply all patches what I did applied to the exe.

thnx for support 😄

btw just notice the client used iteminfo_true_v5.lua am i correct?

Share this post


Link to post
Share on other sites

Thanks for your support anacondaq

I wanted to ask you the following: I have the emulator running on my local machine and I can run the client without problems, everything works wonders!

But, with some friends we want to do more tests, and we bought a host (VPS) where we uploaded the emulator and made the corresponding changes to connect to it using the same client.

The problem is that sometimes the server lets you in, you can see the characters, create new ones, enter the maps, use the GM commands, etc. But most of the time, the login returns a "Failed to connect to the server" and in other opportunities, you can log in, but when you select a character, instead of loading the map, it returns "Connection Rejected"

image.png.cdbcb170379f1059ced9843b1392cd4a.png

Do you know why this could happen? I understand that if it were a configuration problem, in any case I would not be able to enter, but there are times that I can enter without doing anything different, and other times (most) will not let me enter.

I've noticed that, on some occasions, I run the server, and it returns errors related to the connection to the char-server, but if I run the server again a couple of times, it ends up connecting correctly (the connection tests I always do when the char-server manages to connect correctly, of course)

Example:

image.png.ac883121b89dca59983a08f9b88e19eb.png

And Then:

image.png.8750227af5314e3a403d5ce8fd0eb7ad.png

Will it be a configuration problem of ours? (exe - emulator)
Or will the host have a problem?
We have some way to identify it?

Again, thank you very much for your help!

Share this post


Link to post
Share on other sites
9 hours ago, AinsLord said:

btw just notice the client used iteminfo_true_v5.lua am i correct?

not sure about this, really, because even to me this is confusing thing. Yes, looks like it is v5, but I'm not sure... Need to verify and check it on the github of zacks work.

5 hours ago, gnashxalex said:

the guide you have is not working anacondaq

Hi, https://gist.github.com/anacondaq/3eae8e4afb5d3c3880d08b95b2c54b78

try this one. And also very interesting, why link died (old one). Anyway, thank you for the report.

 

Share this post


Link to post
Share on other sites
3 hours ago, cromilakis said:

Do you know why this could happen?

athena-start script bugged, I can confirm this and this command can provoke issues with several servers running at the same time (two login servers, two char servers, or even two map-servers or more). You must make sure that you running only one server at one time. Optionally, I recommend to try to follow next guide: https://gist.github.com/anacondaq/3eae8e4afb5d3c3880d08b95b2c54b78

this guide super friendly for newbies and you can visually control which servers are running and always easy to track where is the problem.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...