• 0
dma2

What's the problem eAthena(Since 2007) in Centos7.

Question

I'm trying to operate eAthena(Since 2007) on Sentos 7.

But it has a number of operational problems. Even though it was operated on Windows 10.

 

it's pretty hard, and tired..

 

So I just want to know why on the latest version of Linux cause operational problems. 

(This must have worked. Maybe at Centus 6 32 bit.)

 

What's the problem ? kernel version? Shell version? gcc version? or 64bit os?

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0
3 hours ago, dma2 said:

I'm trying to operate eAthena(Since 2007) on Sentos 7.

But it has a number of operational problems. Even though it was operated on Windows 10.

 

it's pretty hard, and tired..

 

So I just want to know why on the latest version of Linux cause operational problems. 

(This must have worked. Maybe at Centus 6 32 bit.)

 

What's the problem ? kernel version? Shell version? gcc version? or 64bit os?

Why not use rAthena then.

Share this post


Link to post
Share on other sites
  • 0
11 minutes ago, Amir Azman said:

Why not use rAthena then.

Maybe he/she wants the old style/formulas version of private server. (I'm currently working on my new server using eAthena too. Just sharing ^_^)

That's why he's asking about it here, because there is no support on eAthena today since it has been down few years ago.

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)
26 minutes ago, Amir Azman said:

Why not use rAthena then.

I don't need the latest version because it's for my personal study. 

Rather, using the latest version makes it harder for me to convert what I've been developing. 🙂

Edited by dma2

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, dma2 said:

I don't need the latest version because it's for my personal study. 

Rather, using the latest version makes it harder for me to convert what I've been developing. 🙂

use centos 6, been using it in my hosting and it work fine

Share this post


Link to post
Share on other sites
  • 0

then u can use older version of centos as supported in eAthena before.

Share this post


Link to post
Share on other sites
  • 0
8 hours ago, dma2 said:

I'm trying to operate eAthena(Since 2007) on Sentos 7.

But it has a number of operational problems. Even though it was operated on Windows 10.

 

it's pretty hard, and tired..

 

So I just want to know why on the latest version of Linux cause operational problems. 

(This must have worked. Maybe at Centus 6 32 bit.)

 

What's the problem ? kernel version? Shell version? gcc version? or 64bit os?

You literally have given us no information in order for us to accurately answer your question about why you're having issues.

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)
14 hours ago, Akkarin said:

You literally have given us no information in order for us to accurately answer your question about why you're having issues.

Ok i see. My case causes SIGSEGV in various cases.
 

For Ex.

When to call Func in script, received signal SIGSEGV.

'run_script_main (st=0x7fffe2e7254c) at script.c'
line : enum c_op c = get_com(st->script->script_buf,&st->pos);

i guess st->bk_st's pointer has been lost when through db(in db.c *not use DBmap).

But this line is a original code. So I think the cause in what I mentioned, also it's a comprehensive reason that is not specific.

 

18 hours ago, Vy Low said:

use centos 6, been using it in my hosting and it work fine

use x86?

Edited by dma2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.