Jump to content
  • 0
AinsLord

Thor Patcher connection issue

Question

so here is my question i got 2 separate VPS one for the server one for the patch files

what im doing is i wanted to get the patch file on the other VPS

tried to configure already the thor patcher but it seems i cannot start the game with the patcher

so this is the config

[Config:Main]

RootURL='http://(what IP should be here)/patch/data'

RemoteConfigFile='main.ini'

TimeOut=0

StatusFile='update.dat'

DefaultGRF='test.grf'

ClientEXE='aaaa.exe'
ClientParameter='-1sak1'

//When patcher unable to connect webserver,
//should the patcher allow player start the game anyways?
FinishOnConnectionFailure=false

[Config:Window]

Style='none'

//This allows the player drag the window by background
DragHandling=true

//Background can be either jpg or bmp, in later case
//the top-left pixel is chosen as transparent color.
Background='images/bg.bmp'

FadeOnDrag=true

[Config:BGM]
File=''

Loop=true

Volume=5

Directory=

[Config:Misc]
Title='Thor Patcher'

HideProgressBarWhenFinish=true


[ProgressBar:bar1]
Width=342
Height=10

Left=23
Top=486

FrontImage=
BackImage=

Hook='ProgressChange'



[Label:Status]
AutoResize = false

Width=369
Height=

Left=15
Top=498
Alignment='center'

FontColor=$000000
FontName = ''
FontSize =

Text=''

Hook='StatusChange'

[NoticeBox:Box0]
Width=347
Height=250
Left=21
Top=217
URL='http://127.0.0.1/opatch/notice.html'



[Button:Start]
Default='images/start1.png'
OnHover='images/start2.png'
OnDown='images/start3.png'

Left=383
Top=211

//Hook is used for default buttons,
//do not use this on custom buttons!
Hook='Start'

[Button:Exit]
Default='images/Exit1.png'
OnHover='images/Exit2.png'
OnDown='images/Exit3.png'

Left=383
Top=244

Hook='Exit'

[Button:Cancel]
Default='images/Exit1.png'
OnHover='images/Exit2.png'
OnDown='images/Exit3.png'

Left=383
Top=211
Hook='Cancel'

//[Button:Extra]
//
//
//
// Mode - mode for button
// 1 = open URL
// 2 = Launch file/program
// 3 = Message box
//Mode=
// Action - depend on what you set in the Mod, this may vary
// ex. Mode = 1 , Action='http://google.com'
//Action=

here is the main which is pasted on my patch VPS IP

//Thor Patcher remote config file
[Main]
//Allow patching or not?
allow=true

//Should patcher ignore everything else and finish patch immediately?
Force_Start=false

//if not, what message should appear?
policy_msg=Server is taking a nap.

//file_url - patch files should ALL put here.
// This config entry will override the one in embed config.
// o HTTP:
//         http://domain.com/dir/
// o FTP:
//         ftp://domain.com/dir/
//     o With <Username> [Password] [Port]
//	ftp://username:[email protected]:port/dir/
//     o Note: username is required if want put password, otherwise everything is optional.
file_url=http://(what IP should be here im putting the PatchVPS IP here)/patch/data/

[Patch]
//use CheckSum tool, hash for client & patcher
// used to make sure exe is up to date
//  (leave empty to disable this feature)
ClientSum=
PatcherSum=


//This is compressed file for patcher & client update
// To make these work, ClientSum and/or PatcherSum can't be empty
// Note: these files should put same place as patch file (file_url in internal config)
//Relative address, not FULL URL!
ClientPath=
PatcherPath=

// Patch list file
PatchList=plist.txt

[Stars]
// Shining o.O (Anyways, its for start button clones)
// Since orignal client has check sum.. why not for clones? XD


//How many? (it should same as amount of start button clone, but of course it's your choice)
clients=0

// _sum - checksum, use CheckSum tool.
//client1_sum=
// _Name - Filename of exe
//client1_Name=
// _Path - Path for file [Compressed]
//client1_Path=

[Misc]
//Set a limit for fragment, when reach this limit, patcher will ask user to defrag
FragmentLimit=50

should i try to create a patch file for it to make it run?

 

Thanks in advance guys sorry its been a long time since i came back developing server 🙂

unknown.png

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

1. make sure you can access that IP/domain webserver. Try open it with your browser your file_url and also root_url.
2. try disable https or SSL (if its auto or u enable it) for the subdomain or path for thor web server data.

  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

ayt thanks a lot

Edited by AinsLord
msg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy.