Jump to content
  • 0
Rivers

[Guide] AndRO Free Version RAR

Question

Many people have been asking me how I got my server, or theirs, working online using AndRO apk.

This guide works for v260 , v288 & v323 

  • Next, take all necessary files for running a server. These are the files from a fresh kRO, or in most cases a "Lite" version of a server. (In this example I used my Lite server files.) Below is a compiled folder of the files you need. Modify the clientinfo.xml to contain your information, add your client.exe, add your patcher, & your server grf.
    https://www.mediafire.com/file/hc1h491a0v4eux7/Lite+Files.zip/file
  •  
  • Then, I zipped everything into a RAR file. Downloading that onto my mobile device, in the Downloads folder. (Create new folder for version 288 and above)
  • Using almost any RAR extractor tool from Google Play Store you can extract all the files into your Downloads folder. Once completed you will then run your AndRO application. (NOTE: This will not create a custom icon for your server. To do that you need to buy the APK version of your server from AndRO Workshop.)
    https://play.google.com/store/apps/details?id=com.rarlab.rar&hl=en_CA
     

clieninfo.xml

  • Now you might have some questions about the clientinfo.xml that you'll need to put into your main GRF. Below is an example of what mine looks like. This allows my server to read everything in plain English and not Acsii.
Quote

<?xml version="1.0" encoding="euc-kr" ?> 
<clientinfo> 
    <servicetype>america</servicetype>
    <servertype>primary</servertype>
    <connection>
    <display>[ SERVER TITLE HERE ]</display>
    <address>000.00.00.000</address>
    <port>6900</port>
    <version>55</version>
    <langtype>1</langtype>
    <packetver>20180620</packetver>
    <increase_max_hairstyles>500</increase_max_hairstyles>
    <increase_max_haircolors>600</increase_max_haircolors>
    <read_data_directory_first>true</read_data_directory_first>
    <iteminfo>itemInfo.lua</iteminfo>
    <hide_quickcashshop_button>true</hide_quickcashshop_button>
    <max_guildpositions>76</max_guildpositions>
    <registrationweb>https://www.website.net/</registrationweb>
    <aid>
    <admin>2000000</admin>
    <admin>2000001</admin>
    </aid>
    <loading>
    <image>loading00.jpg</image>
    <image>loading01.jpg</image>
    </loading>
    <patchserver>
    <type>thor</type>
    <http>http://website.net/patch/plist.txt</http>
    <ftp>http://website.net/patch/data/</ftp>
    <grf>custom.grf</grf>
    <inf>updates.dat</inf>
    </patchserver>
    </connection>
</clientinfo>

 

Common errors:

  • Unable to Find Resource values : Fixed by re-selecting the directory. If this fails, your clientinfo may not be there or it can't read your GRF; this is common with incorrectly encrypted GRFs. V260
  • Crashes after selecting server directory, with no error : Fixed by disabling Gepard. If you have Gepard and want to keep it active you will need the paid version mentioned above. V260
  • Item Descriptions not in Enlgish : Fixed by changing clientinfo.xml to read data folder first and selecting it to read itemInfo.lua files. V260
  • Application will not read Downloads folder : Fixed by giving AndRO application Storage permissions. V260
  • Fatal Error: java.net.UnknownHostException: Unable to resolve host "host.name.here.net": No Address associated with hostname. : Fixed by closing App completely, reloading app, "change" directory, reselect Downloads folder and reopening the directory. sounds annoying, because it is, but it works! V260
  • data/sprite/인간족/머리통/여/2073_여.spr : Fixed by adjusting your Packet version in the packet line of clientinfo.xml. V260
  • data/sprite/인간족/머리통/남/33_남.spr : Fixed by reseting look to default. Many pallets and hairstyles are not working. V260
  • File format error. Try to delete your client folder "/directory/". Failed to Parse LUA file: /data/user/0/com.rowork-shop.androlocalclientfiles/tmp.lub:30000 (or any other combination of numbers) unexpected symbol near 'symbol/text_error'Fixed by scrolling to the specified line of your LUA/LUB and adjusting the improper values. V260
  • Failed to connect to resource serverFixed by adding the patch directory to the clientinfo.xml / If your GRF is encrypted you will need to decrypt it. V260
  • Patch list error 1 at line 1Fixed by removing Patch and Website lines from your GRF. This is for those who don't use websites for their server. V260
  • Failed to connect to map server : Fixed by double checking the patch directory on the clientinfo.xml. It is important to have both patch directory lines in it to receive connections. V260
  • Fatal error Failed to load map: * : Fixed by either reselecting the Path in Settings and changing it, even if it's identical to what you have now; or by reinstalling the AndRO Freeware. V260
  • Failed to parse LUA: Only supporting v5.0, sorry : May have an older version that is not compatible with the latest AndRO. V260
  • Game crash without error/AndRO apk has stopped working : This can be because you are in @hide. Unhide to be able to load the game again. This can also be an issue with the version, I downloaded v288 and this issue resolved itself. V260
  • Attempt to invoke virtual method 'void . . 3.. (int, int)' on a null object reference : This error is still being investigated. It is believed to be the same error as the Game Crash/AndRO apk has stopped working. V288

 

More will be added and polished as I learn more. Thanks for reading thus far. If you need assistance compiling your mobile server let me know and I'll try my best to help.

Edited by Rivers
  • Upvote 3
  • Love 2
  • MVP 2
Link to comment
Share on other sites

51 answers to this question

Recommended Posts

  • 0

@Rivers I succesfully installed it on my server, but no NPC's and Skill Tree.   I decrypted already my grf. Any tips how it work the npc's show up

Link to comment
Share on other sites

  • 0
On 1/3/2021 at 7:49 PM, simplexjay2 said:

May i add you in fb and can i ask if how will i edit the Application name

You can add me, as for changing application name that's up to the developer.
 

1 hour ago, ffernand said:

@Rivers I succesfully installed it on my server, but no NPC's and Skill Tree.   I decrypted already my grf. Any tips how it work the npc's show up

This is hard to identify. I'd recommend making sure the data.ini and set up with your custom.grf first. Also, is there any errors output by the apk?

Link to comment
Share on other sites

  • 0
On 1/26/2021 at 9:46 AM, Rivers said:

You can add me, as for changing application name that's up to the developer.
 

This is hard to identify. I'd recommend making sure the data.ini and set up with your custom.grf first. Also, is there any errors output by the apk?

Hello River,

Good day!

Encountered error Inside I can't see any player in game and NPC. when ANDRO client saw a Player error pop-up "Length=3; index=104;" then andro client closed . do you know how to resolve this?

im using 20180919 client. thanks!

Edited by G-RO
Link to comment
Share on other sites

  • 0

Try to check your config files and that the packet versions are accurate in them. It might be an issue with packetever misconfiguration. If you want to PM me your server details I can run it when I get time this weekend.

Link to comment
Share on other sites

  • 0

hello i sir. I have the plist error. below are the clientinfo details.

<?xml version="1.0" encoding="euc-kr" ?> 
<clientinfo> 
    <servicetype>america</servicetype>
    <servertype>primary</servertype>
    <connection>
    <display>wewe Ragnarok Online</display>
    <address>xxx.xx.xx.xx</address>
    <port>6900</port>
    <version>55</version>
    <langtype>1</langtype>
    <packetver>20180620</packetver>
    <increase_max_hairstyles>500</increase_max_hairstyles>
    <increase_max_haircolors>600</increase_max_haircolors>
    <read_data_directory_first>true</read_data_directory_first>
    <iteminfo>itemInfo.lua</iteminfo>
    <hide_quickcashshop_button>true</hide_quickcashshop_button>
    <max_guildpositions>76</max_guildpositions>
    <registrationweb>http://mhragnarok.com/</registrationweb>
    <aid>
    <admin>2000000</admin>
    </aid>
    <loading>
    <image>loading00.jpg</image>
    <image>loading01.jpg</image>
    </loading>
    </connection>
</clientinfo>

 

Edited by Mael
Use codebox
Link to comment
Share on other sites

  • 0

You're missing the following in your ClientInfo.xml:
 

	<patchserver>
	<type>thor</type>
	<http>http://website.com/patcher/plist.txt</http>
	<ftp>http://website.com/patcher/data/</ftp>
	<grf>custom.grf</grf>
	<inf>updates.dat</inf>

 

Link to comment
Share on other sites

  • 0

Hello! how can i fix Disconnected from server. : Failed to connect map-server when login after character select

Link to comment
Share on other sites

  • 0

It sounds like you may not have the Packetever added in correctly. Double check the version you are using in your emulator and make sure it's the same in the clientinfo.xml's.

Link to comment
Share on other sites

  • 0
On 3/7/2021 at 8:03 AM, Rivers said:

You're missing the following in your ClientInfo.xml:
 

	<patchserver>
	<type>thor</type>
	<http>http://website.com/patcher/plist.txt</http>
	<ftp>http://website.com/patcher/data/</ftp>
	<grf>custom.grf</grf>
	<inf>updates.dat</inf>

 

Sir is this thing are required?..?
Since my test ro not using thor but i think im using neoncube instead.
And for the data.grf and rdata.grf which come together with the KRO, are those need to be inserted together into the main file?

Edited by Checkmate
Link to comment
Share on other sites

  • 0
On 4/26/2021 at 2:44 PM, Checkmate said:

Sir is this thing are required?..?
Since my test ro not using thor but i think im using neoncube instead.
And for the data.grf and rdata.grf which come together with the KRO, are those need to be inserted together into the main file?

The patchserver info is required to connect to the server for updates, without it you can't update the GRF files.

As for ensuring the client is reading the correct GRF files, you'll need to make the changes inside the data.ini file to allow both GRFs.

Link to comment
Share on other sites

  • 0

Hello i just want to ask a help cause ai already download the Kro fullclient which is 4gb and i dont know how to get a apk and intall it, guys please help me on this matter. Thank you and Godbless. 

Link to comment
Share on other sites

  • 0
Posted (edited)

Hi @Rivers

Edit: Fixed the previous error by updating plist.

Now i'm getting this error:

MmO269Y.png

 

Edited by Snaehild
Link to comment
Share on other sites

  • 0
On 5/17/2021 at 1:22 PM, Snaehild said:

Hi @Rivers

Edit: Fixed the previous error by updating plist.

Now i'm getting this error:

MmO269Y.png

 

It looks like something isn't installed/reading correctly. Also make sure your data.ini has the proper data.grf in order. 0=Custom.grf, 1=pallete.grf, 2=radata.grf, 3=data.grf.

  

On 5/16/2021 at 8:47 AM, chronoscrowler said:

No description available.

how do i fix this pls? PC Version works fine

Try checking your Packetever settings. Make sure the numbers are exactly as your server states in the packets.h


Anyone having issues that can't get a response right away from here can feel free to message me on Discord. 🙂

Link to comment
Share on other sites

  • 0
1 hour ago, Rivers said:

It looks like something isn't installed/reading correctly. Also make sure your data.ini has the proper data.grf in order. 0=Custom.grf, 1=pallete.grf, 2=radata.grf, 3=data.grf.

  

Try checking your Packetever settings. Make sure the numbers are exactly as your server states in the packets.h


Anyone having issues that can't get a response right away from here can feel free to message me on Discord. 🙂

Thanks the packets.h version worked correctly 🙂

 

Link to comment
Share on other sites

  • 0

I cannot connect to char-server it says disconnected even the packetver is correct. I'm using 20200304 both client and server using ./configure --enable-packetver=20200304

Am I missing something?

Link to comment
Share on other sites

  • 0
Posted (edited)
On 7/4/2021 at 12:05 AM, Meister said:

I cannot connect to char-server it says disconnected even the packetver is correct. I'm using 20200304 both client and server using ./configure --enable-packetver=20200304

Am I missing something?

Working on this, it will take some testing.

EDIT: Needed line in clientinfos.
 

<enforce_login_address_on_char_and_map>true</enforce_login_address_on_char_and_map>

Credits to: Meister

Edited by Rivers
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy.