Jump to content

lekkereten

Members
  • Posts

    148
  • Joined

  • Days Won

    1

Everything posted by lekkereten

  1. Implemented in r17029.
  2. Well if you now how to use WPE you can see which packet is being sent upon friend addition.
  3. It is intended. The previous reading "method" was only reading from pre-re. This was added by Ind I think because he was unsure about the actual re values.
  4. Agree with Emistry, the code wasn't really working properly (with > 20 player ingame it would pop up two next buttons, and so on each 10 players O.o)
  5. lekkereten

    Playertalk

    Well TBH I don't see any improvement in it. It is not the most easy way to do what OP propose but still does the job.
  6. No need for that. Hmm Did you change #define PACKETVER 20120410 in mmo.h? (dumb question but still you can forget..) Also do you care to send me per PM your hexed and data so I can test here as well? I'm using 2012-04-10.
  7. You can try and use these packets: 0x0078,55 0x007c,44 0x00aa,9 0x00f3,-1,globalmessage,2:4 0x0193,2,closekafra,0 0x01a2,37 0x01fd,15,repairitem,2 0x0202,5,changedir,2:4 0x022c,65 0x022d,19,wanttoconnection,2:6:10:14:18 0x0281,-1,convertitem,2:4:8:12 0x0288,-1,npcpointshopbuy,2:4:8:10 0x0289,12 0x029b,80 0x035f,6,ticksend,2 0x0360,6,clickbuyingstorereq,2 0x0361,5,hommenu,4 0x0362,6,dropitem,2:4 0x0364,8,movefromkafra,2:4 0x0368,6,solvecharname,2 0x0369,7,actionrequest,2:6 0x0437,5,walktoxy,2 0x0438,10,useskilltopos,2:4:6:8 0x0439,8,useitem,2:4 0x07d9,268 0x07e4,6,takeitem,2 0x07ec,8,movetokafra,2:4 0x0802,26,partyinvite2,2 0x0815,-1,reqopenbuyingstore,2:4:8:9:89 0x0817,2,reqclosebuyingstore,0 0x083c,10,useskilltoid,2:4:6 0x0856,26,friendaddrequest,2 0x0940,-1,reqsellbuyingstore,2:4:8:12 0x096a,6,getcharnamerequest,2 Provided here by gilbertobitt.
  8. I'm FOR doing this. We replace with the source from r16967, which was actually last-modified in r16966 (doesn't matter much). Then we could do this: • Either every one recommit their own commit, so blame will be properly placed which will take more time (depends on that dev's activity) which I strongly recommend we do this, regardless of revision number, at least we'd have blame righty (partially, source-related would be different but still blame the same person). Also I'd go for keep commit AS IS even if they would be reverted or follow up'd after, for the sake of blame. • Otherwise we take a single person to recommit everything and even though we'd have less "useless" revisions (or follow ups), blame would be broken. (which I don't like) And since this code style thing is giving so much trouble (which I thought it wouldn't), personally I don't want this kind of headache anymore, so leave it be. List of commits envolving source modifications and its authors: http://trac.rathena.org/changeset/16988/rathena - malufett http://trac.rathena.org/changeset/16987/rathena - ligtha http://trac.rathena.org/changeset/16986/rathena - mkbu95 http://trac.rathena.org/changeset/16985/rathena - mkbu95 http://trac.rathena.org/changeset/16984/rathena - markzd http://trac.rathena.org/changeset/16981/rathena - malufett http://trac.rathena.org/changeset/16980/rathena - markzd http://trac.rathena.org/changeset/16979/rathena - markzd http://trac.rathena.org/changeset/16977/rathena - akkarin http://trac.rathena.org/changeset/16974/rathena - mkbu95 http://trac.rathena.org/changeset/16973/rathena - mkbu95 http://trac.rathena.org/changeset/16971/rathena - mkbu95 http://trac.rathena.org/changeset/16969/rathena - lighta
  9. What could be implemented was done in r16933
  10. Refresh my mind as to the reasons why spaces over tabs.
  11. Do you mean the spaces instead of tabs? You should ask GreenBox.
  12. If wasn't for the start menu I wouldn't had upgraded x)
  13. ACMD_FUNC(cleanmap) { map_foreachinarea(atcommand_cleanmap_sub, sd->bl.m, sd->bl.x-AREA_SIZE*2, sd->bl.y-AREA_SIZE*2, sd->bl.x+AREA_SIZE*2, sd->bl.y+AREA_SIZE*2, BL_ITEM); clif_displaymessage(fd, msg_txt(1221)); // All dropped items have been cleaned up. return 0; } Now knowing that by default AREA_SIZE equals 14, and assuming x=50 and y=68, this is the area (the inside the red rectangle) that would be cleaned: It doesnt clean everything on the map like it says it does. So I suggest we create a new command @cleanarea to do what @cleanmap is doing right now and change @clean to actually clean the entire map. Feel free to discuss. @edit Implemented in r16971.
  14. Could do something like this: Index: map-server_sql.vcxproj =================================================================== --- map-server_sql.vcxproj (revision 16962) +++ map-server_sql.vcxproj (working copy) @@ -271,4 +271,15 @@ <Import Project="$(VCTargetsPath)\Microsoft.Cpp.targets" /> <ImportGroup Label="ExtensionTargets"> </ImportGroup> + <Target Name="AfterBuild"> + <Copy SourceFiles="..\conf\import-tmpl\battle_conf.txt" DestinationFolder="..\conf\import\" ContinueOnError="true" /> + <Copy SourceFiles="..\conf\import-tmpl\char_conf.txt" DestinationFolder="..\conf\import\" ContinueOnError="true" /> + <Copy SourceFiles="..\conf\import-tmpl\inter_conf.txt" DestinationFolder="..\conf\import\" ContinueOnError="true" /> + <Copy SourceFiles="..\conf\import-tmpl\log_conf.txt" DestinationFolder="..\conf\import\" ContinueOnError="true" /> + <Copy SourceFiles="..\conf\import-tmpl\login_conf.txt" DestinationFolder="..\conf\import\" ContinueOnError="true" /> + <Copy SourceFiles="..\conf\import-tmpl\map_conf.txt" DestinationFolder="..\conf\import\" ContinueOnError="true" /> + <Copy SourceFiles="..\conf\import-tmpl\msg_conf.txt" DestinationFolder="..\conf\import\" ContinueOnError="true" /> + <Copy SourceFiles="..\conf\import-tmpl\packet_conf.txt" DestinationFolder="..\conf\import\" ContinueOnError="true" /> + <Copy SourceFiles="..\conf\import-tmpl\script_conf.txt" DestinationFolder="..\conf\import\" ContinueOnError="true" /> + </Target> </Project> \ No newline at end of file
  15. You have a strong point. But let this roll and see what people think about.
  16. It is clear that all these messages are annoying: [Error]: File not found: conf/import/packet_conf.txt [Error]: Configuration file (conf/import/inter_conf.txt) not found. [Error]: Configuration file (conf/import/login_conf.txt) not found. So I thought in two ways to avoid it: - Doesn't display the import files reading if they're missing (which they are by default ->import-tmpl); - Rename import-tmpl to import and let the emulator read it even if the files have no content. Please discuss if you feel like so.
  17. Holy this inventory GUI looks amazing, beautiful work, well done.
  18. My parameter list: --style=kr --align-pointer=name --align-reference=name --mode=c --lineend=linux --convert-tabs --keep-one-line-statements --min-conditional-indent=0 --pad-header --unpad-paren --indent-col1-comments --indent-preprocessor --indent-labels --indent-cases --indent-switches --indent=spaces=4 --suffix=none --max-instatement-indent=80 --recursive @edit It is reducing the file size better thant I thought it would. Also, a diff for atcommand.c so you can see how it would look like: atcommand.c.patch went from 283kb to 275kb @edit2 I uploaded the files already on astyle to a github repo so you can see for yourselves. https://github.com/mkbu95/rathena_src_astyle
  19. I use Allman but I think K&R is more beautiful.
  20. It is good for me but what about the @reloadmotd thingy? When you do @reloadmotd the motd is displayed again i think.
  21. Indeed, thanks for that. Done in r16939.
  22. Jupeto is a true artist, these are amazing login screens
  23. 9 (MAX_CHARS) is the number of slots that will be avaiable. chars_per_account is the number of characters that you can create within MAX_CHARS slots. Although I found that you can use any value on chars_per_account, even surpass MAX_CHARS, which is not a good practice. Fixed that in r16937.
  24. Well indeed Arcenciel has a point, that was the fallback #3 or #4, permutate thru all the letters (Prontera, pRontera, PRontera, ...) --but if there is a goddamn fast permutation algorithm we could try to see the impact x) Jokes aside, I haven't seen anyone creating a map My_Map, but what I'm thinking is: - It's really difficult to have a map with uppercase; - Even if it has, the chances that the player will type e.g. my_Map instead of My_Map are really low IMO; - Doing the first check, we would cover these both cases. I know that it would'nt cover everything (Arcenciel's post), but I think it would cover most cases.
×
×
  • Create New...