Jump to content
  • 0
ScriptingPhailure

Trying to get offline server to online

Question

I can't seem to get it off the ground and I'm not quite sure what I missed but here:

 

my char_athena

 

// Login Server IP
// The character server connects to the login server using this IP address.
// NOTE: This is useful when you are running behind a firewall or are on
// a machine with multiple interfaces.
login_ip: 192.x.x.x

// The character server listens on the interface with this IP address.
// NOTE: This allows you to run multiple servers on multiple interfaces
// while using the same ports for each server.
bind_ip: 192.x.x.x

// Login Server Port
login_port: 6900

// Character Server IP
// The IP address which clients will use to connect.
// Set this to what your server's public IP address is.
char_ip: 66.108.x.x

// Character Server Port
char_port: 6121

 

my login_athena:

 

// The login server listens on the interface with this IP address.
// NOTE: This allows you to run multiple servers on multiple interfaces
// while using the same ports for each server.
bind_ip: 192.x.x.x
 
// Login Server Port
login_port: 6900

 

my map_athena:

 

// Character Server IP
// The map server connects to the character server using this IP address.
// NOTE: This is useful when you are running behind a firewall or are on
// a machine with multiple interfaces.
char_ip: 192.168.1.4

// The map server listens on the interface with this IP address.
// NOTE: This allows you to run multiple servers on multiple interfaces
// while using the same ports for each server.
bind_ip: 192.168.1.4

// Character Server Port
char_port: 6121

// Map Server IP
// The IP address which clients will use to connect.
// Set this to what your server's public IP address is.
map_ip: 66.108.x.x

// Map Server Port
map_port: 5121

 

my subnet_athena:

 

subnet: 255.0.0.0:192.x.x.x:192.x.x.x

 

my client.info:

 

 

<?xml version="1.0" encoding="euc-kr" ?>
<clientinfo>
    <servicetype>korea</servicetype>
    <servertype>sakray</servertype>
    <hideaccountlist /><extendedslot /><readfolder />
    <connection>
        <display>Sakray Client</display>
        <desc>Sakray Client</desc>
        <address>66.108.x.x</address>
        <port>6900</port>
        <version>28</version>
        <langtype>1</langtype>
        <balloon>Sakray Client</balloon>
        <aid>
            <admin></admin>
        </aid>
    </connection>
</clientinfo>

 

Also I forwarded all my ports. login: 6900, char: 6121, map: 5121

Edited by ScriptingPhailure
Link to comment
Share on other sites

8 answers to this question

Recommended Posts

Hello, this is the most suitable configuration (completely the same as mine, working for both connecting from the same computer and other computer)

 

char_athena:

 

login_ip: 127.0.0.1

//bind_ip: 127.0.0.1

char_ip: 66.108.242.58

 

login_athena:

 

//bind_ip: 127.0.0.1


map_athena:

 

char_ip: 127.0.0.1

//bind_ip: 127.0.0.1

map_ip: 66.108.242.58


subnet_athena:

 

subnet: 255.0.0.0:127.0.0.1:127.0.0.1

(subnet: set to default)

 

simply ask your client from the same computer to connect to 127.0.0.1 (localhost) and others from your computer to your static WAN IP (66.108.242.58)

 

If problem still happens and you are sure you have correctly forwarded your ports, you can, first, check whether your ports are open using http://www.canyouseeme.org/ 

 

If you're not public to the Internet, then you will need to call your ISP and ask them to open those ports for you.

 

 

Hope this helps

Edited by Winz
Link to comment
Share on other sites

Change Char ip and Login ip to : 66.108.242.58 then recompile

Edited by Plank
Link to comment
Share on other sites

Is there a debug on the console that says why you can't connect? or what problems there are ?

Link to comment
Share on other sites

there are no errors on the connect, it just simply isn't connecting on the client. The console itself doesn't even seem to sense anything attempting to connect.

 

Does the bind have to be on? When the bind IP is on I can't connect to the server from the same computer. Setting the ip's to be the same doesn't seem to affect anything.

Edited by ScriptingPhailure
Link to comment
Share on other sites

What happens when you try this.

 

// Login Server IP
// The character server connects to the login server using this IP address.
// NOTE: This is useful when you are running behind a firewall or are on
// a machine with multiple interfaces.
login_ip: 192.168.1.4

// The character server listens on the interface with this IP address.
// NOTE: This allows you to run multiple servers on multiple interfaces
// while using the same ports for each server.
//bind_ip: 192.168.1.4

// Login Server Port
login_port: 6900

// Character Server IP
// The IP address which clients will use to connect.
// Set this to what your server's public IP address is.
//char_ip: 66.108.242.58

// Character Server Port
char_port: 6121

And by the way, is your server running at the moment? IP seems to be dead.

Link to comment
Share on other sites

It says they my isp is not blocking the port, but this is my question now. If I'm using a router do I still have to call my ISP?

 

Edit: So it turns out there was nothing wrong the conf after all. It was all client side. The client was reading the grf first rather than the data folder so the client.info in the grf had to be edited. Sorry for the silly mistake. Also, thank you for all your help. If possible could you edit out my ip?

Edited by ScriptingPhailure
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy.