• 0

Question

I load the Ro and it keeps coming up with Korean words and when I log it it says NO MSG, and I'm using a 2012-04-15 Ro . Help Please .

 

 

 

 

post-15362-0-49951300-1361722918_thumb.jpg

post-15362-0-10044600-1361722921_thumb.jpg

Edited by ace88kfor

Share this post


Link to post
Share on other sites

18 answers to this question

Recommended Posts

looks like it's not reading your data folder.

 

What's your data.ini like?

 

it should be

 

0= YourRO.grf

1=data.grf

2=rdata.grf

 

and make sure your grf is in a folder called data

 

nothing else, that's the mistake i made last time which caused this problem xD.

 

lemme know if it helps !

Share this post


Link to post
Share on other sites

Thanks it worked but now I can't log into char . Like it says it lost connection and then it got connected later on

 . . .



When I log in the acc . The cmd log says "Closed connection from '127.0.0.1'."

Share this post


Link to post
Share on other sites

hmm, first off it's actually the wrong section lol, but what's your IP currently like in your clientinfo.xml?

 

make sure that's local for you and public for everyone else. Because you can't connect back to your own public address while other people can.

Share this post


Link to post
Share on other sites

make sure you have updated msgstringtable

Share this post


Link to post
Share on other sites

Im using the 127.0.0.1 Ip ... and where do i put the msgstringtable I couldnt find it ...



Nvm about the msgstringtable it's updated . Now the only problem is the Login .

Share this post


Link to post
Share on other sites

okay why not try this, make sure all your configurations on your map_athena login_athena the ip are set to local IP.

 

then make sure your subnet does have your local ip as well and then clientxml to your local ip and try entering then.

Share this post


Link to post
Share on other sites
// Login Server IP
// The character server connects to the login server using this IP address.
// NOTE: This is useful when you are running behind a firewall or are on
// a machine with multiple interfaces.
login_ip: 127.0.0.1
 
 
On that ^ . When I run the server it gave me an error "[Error] make_connection: connectionfailed"


Like if I keep it on 127.0.0.1 it won't make an error but if I put the other Ip it'll get an error

Share this post


Link to post
Share on other sites

Hmmm, okay then, i'll give you my configurations and perhaps it could help.

 

My knowledge is still very low here compared to others lol

 

// a machine with multiple interfaces.
login_ip: 192.168.0.100 <------ must be Local IP address
 
// The character server listens on the interface with this IP address.
// NOTE: This allows you to run multiple servers on multiple interfaces
// while using the same ports for each server.
//bind_ip: 127.0.0.1

// Login Server Port
login_port: 6900 <---- make sure port has been forwarded from your router.

// Character Server IP
// The IP address which clients will use to connect.
// Set this to what your server's public IP address is.
char_ip: 12.23.4.5 <---- place public ip address here

 

map_athena.conf

// Character Server IP
// The map server connects to the character server using this IP address.
// NOTE: This is useful when you are running behind a firewall or are on
// a machine with multiple interfaces.
char_ip: 192.168.0.100 <--- Again local IP Address

// The map server listens on the interface with this IP address.
// NOTE: This allows you to run multiple servers on multiple interfaces
// while using the same ports for each server.
//bind_ip: 127.0.0.1

 

subnet.conf

subnet: 255.255.255.0:public IP:public IP

 

The 1.23.4.5 is just an example of public ip address

Share this post


Link to post
Share on other sites

I did that but my Error is saying that  "the target machine actively refused it" .

Edited by ace88kfor

Share this post


Link to post
Share on other sites

What client version are you using? Do you have the right packets and did you diff your client with the skip obscure something?

Using my mobile right now so I can't give you the links.

And make sure your mmo.h is set to your client date you're using as well

Share this post


Link to post
Share on other sites

Im using the 2012-04-10 client



And the mmo is the same as the client



The RO folder has 2012-04-15 and I can't find that client ...

Share this post


Link to post
Share on other sites

I got the Shin's Diff and I dont see it ...

Share this post


Link to post
Share on other sites

https://subversion.assembla.com/svn/weetools/trunk/ShinsDiffPatcher/plugins/WeeDiffGen/

 

 

you can get it from here then paste it inside the folder. once you've paste it in you should see the new diff option coming out

 

under the folder of WeeDiffGen

 

*Credits does not go to me for this file at all.

Edited by ToiletMaster

Share this post


Link to post
Share on other sites

well this is as far as my knowledge of troubleshooting knows >_>

 

I have no other ideas what might be causing the problem right now.

 

Sorry if i couldn't solve your problem.

Share this post


Link to post
Share on other sites

Well the Error stop and When I runserver it works, but I can't log in ...

Share this post


Link to post
Share on other sites

Hi L-Jam,

 

If you are running a local server, please use your LAN IP and not "127.0.0.1"/"localhost". If you are running a public server, please use your WAN IP.

 

You can find your LAN IP by going to the Windows cmd and typing 'ipconfig'. You can find your WAN IP by visiting this website: http://www.whatismyip.com/

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...