Jump to content
  • 0
ale.lelo

Problem with custom item (see apple) and cliente read txt files

Question

Hi people, first, sorry for my basic english.

I have a little problem, that i think that it's a problem with the txt files

First, i see all my custom item with an apple, in the picture you see this... but in the files i configure all...

3.jpg

My think is that the client don't read the txt files... for example, i modifiqued or delete the idnum2itemdesctable.txt but in the game (later a restart) the basic items have the description... can any person help me?

Item_db2:

20020,Wing_adaazul,Wing_adaazul,5,1000,500,100,,0,,4,0xFFFFFFFF,7,2,1,,0,1,1000,{ bonus bAllStats,5; bonus bAtkRange,3; bonus bMaxHP,5; bonus bMaxSP,5; bonus2 bSubEle,0,5; bonus2 bSubEle,1,5; bonus2 bSubEle,2,5; bonus2 bSubEle,3,5; bonus2 bSubEle,4,5; bonus2 bSubEle,5,5; bonus2 bSubEle,6,5; bonus2 bSubEle,7,5; bonus2 bSubEle,8,5; bonus2 bSubEle,9,5; bonus bAtkRate,10; bonus bMatkRate,10; },{},{}

idnum2itemdesctable.txt:

[color=#EEEEEE]20020#[/color]

[color=#EEEEEE]Alas de Nivel 4 que segun cuentan dan a su poseedor + 5 en todos los estados mas Bonus. Evolucionan de 5 formas distintas![/color]

[color=#EEEEEE]Clase :^777777 Alas^000000[/color]

[color=#EEEEEE]Se equipadan en :^777777 Espalda^000000[/color]

[color=#EEEEEE]Usadas por: ^777777 Todos^000000[/color]

[color=#EEEEEE]#[/color]

idnum2itemdisplaynametable.txt:

[color=#EEEEEE]20020#Alas de Ada Azul Nivel 4#[/color]

idnum2itemresnametable.txt:

[color=#EEEEEE]20020#Wing_adaazul#[/color]

accessoryid.lua

[color=#EEEEEE]ACCESSORY_WING_ADAAZUL = 1000,[/color]

accname.lua

[color=#EEEEEE][ACCESSORY_IDs.ACCESSORY_WING_ADAAZUL] = "_Wing_adaazul",[/color]

and i try rewrite itemInfo.lua and itemInfo.lub:

[color=#EEEEEE][20020] = {[/color]

[color=#EEEEEE]unidentifiedDisplayName = "Wing adaazul",[/color]

[color=#EEEEEE]unidentifiedResourceName = "Wing_adaazul",[/color]

[color=#EEEEEE]unidentifiedDescriptionName = {[/color]

[color=#EEEEEE]"Alas de Nivel 5 que segun cuentan dan a su poseedor + 5 en todos los estados, rango de ataque + 3, 5% mas de HP y SP, 5% de resistencia a todos los elementos y 10% mas de ataque fisico y magico.",[/color]

[color=#EEEEEE]"Clase :^777777 Alas^000000",[/color]

[color=#EEEEEE]"Se equipadan en :^777777 Espalda^000000",[/color]

[color=#EEEEEE]"Usadas por: ^777777 Todos^000000",[/color]

[color=#EEEEEE]},[/color]

[color=#EEEEEE]identifiedDisplayName = "Alas de Ada Azul Nivel 5",[/color]

[color=#EEEEEE]identifiedResourceName = "Wing_adaazul",[/color]

[color=#EEEEEE]identifiedDescriptionName = {[/color]

[color=#EEEEEE]"Alas de Nivel 5 que segun cuentan dan a su poseedor + 5 en todos los estados, rango de ataque + 3, 5% mas de HP y SP, 5% de resistencia a todos los elementos y 10% mas de ataque fisico y magico.",[/color]

[color=#EEEEEE]"Clase :^777777 Alas^000000",[/color]

[color=#EEEEEE]"Se equipadan en :^777777 Espalda^000000",[/color]

[color=#EEEEEE]"Usadas por: ^777777 Todos^000000",[/color]

[color=#EEEEEE]},[/color]

[color=#EEEEEE]slotCount = 4,[/color]

[color=#EEEEEE]ClassNum = 0[/color]

Link to comment
Share on other sites

6 answers to this question

Recommended Posts

dude, your data.ini is messed up.. it should look like this:

[DATA]

0=(name of the GRF that you are using).grf

1=data.grf

2=sdata.grf

3=etcetc.

and also, when you make your patch, you need to disable "read data folder 1st".

also try to uncheck "read lua files before lub".

  • Upvote 1
Link to comment
Share on other sites

yes, and try a lot time this, but nothing... i can see the sprite (in the picture you see...) but not the name or the little item, etc

Link to comment
Share on other sites

Could also be related to iteminfo.lua, had this problem when upgrading to a newer client. Use this tool, remember to put your item_db in your data folder as well before using it: http://rathena.org/b...-itemconverter/ and remember iteminfo.lua goes in RO/System. You might also have to rename it to iteminfo.lub, I have not been able to compile it into a lub. Oh and if you get any errors about a problem on a certain line, that is probably because of the slashes \\ and quotes ", you have to remove them both and any line that has them, so remove them and move on to the next line it errors on...

Edited by Wolfeh
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy.