Jump to content
  • 0
Krypt

Max Player Connection

Question

I've set the max player connection to 3,000 and the server is still stuck on 1024. When the server got 1024 online players then the other players cant login anymore.

./configure --with-maxconn=300 as per below

https://github.com/rathena/rathena/pull/3799

unknown.png?width=349&height=229

Share this post


Link to post
Share on other sites

12 answers to this question

Recommended Posts

  • 0
3 hours ago, Krypt said:

I've set the max player connection to 3,000 and the server is still stuck on 1024. When the server got 1024 online players then the other players cant login anymore.

./configure --with-maxconn=300 as per below

https://github.com/rathena/rathena/pull/3799

unknown.png?width=349&height=229

try

./configure --with-maxconn=4096

 

Share this post


Link to post
Share on other sites
  • 0

Hi, have you fixed this problem? I'm having the same problem too 😢

Share this post


Link to post
Share on other sites
  • 0

Nope. Haven't fixed this problem yet.

Share this post


Link to post
Share on other sites
  • 0

Same problem here with debian.


Any good soul that can help us? In this moments a lot of people in quarantine wanna play RO and this is limiting the servers 😕

Share this post


Link to post
Share on other sites
  • 0

Still no solution. Even rAthena devs can't answer it D

Share this post


Link to post
Share on other sites
  • 0
15 hours ago, Krypt said:

Still no solution. Even rAthena devs can't answer it D

The PR you referenced tells you what you need to change. Google "ulimit".

Share this post


Link to post
Share on other sites
  • 0
9 hours ago, Akkarin said:

The PR you referenced tells you what you need to change. Google "ulimit".

As you can see in the image I provided. The ulimit is already changed. Both hard limit and soft limit based on the ulimit -a command given in the image.

Share this post


Link to post
Share on other sites
  • 0
5 minutes ago, Krypt said:

As you can see in the image I provided.

Is that globally or for specified user? There are a few things you need - it's not a one-step command.

 

On 4/9/2020 at 3:17 PM, Krypt said:

Still no solution. Even rAthena devs can't answer it D

Also, I don't want to see ridiculous remarks like this from anyone. Nobody has to help you. Since it's not a limitation with our software we're not even obliged to entertain the idea or providing support for your OS. They also rarely use the forum.

Share this post


Link to post
Share on other sites
  • 0

I've tried setting it for both root and the user that is using rAthena. Even changing the limits.conf and other things needed to change in the open file limits.

Share this post


Link to post
Share on other sites
  • 0

Did you put your new file descriptor limit in /etc/sysctl.conf so it persists after a reboot? You need these too.

Share this post


Link to post
Share on other sites
  • 0

Yes I've added this one.
 

fs.file-max = 4096
net.ipv4.ip_local_port_range = 1024 65000

and in my limits.conf

* soft     nproc          65535    
* hard     nproc          65535   
* soft     nofile         65535   
* hard     nofile         65535
root soft     nproc          65535    
root hard     nproc          65535   
root soft     nofile         65535   
root hard     nofile         65535


 

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)
On 4/10/2020 at 11:33 PM, Krypt said:

Yes I've added this one.
 

fs.file-max = 4096
net.ipv4.ip_local_port_range = 1024 65000

and in my limits.conf

* soft     nproc          65535    
* hard     nproc          65535   
* soft     nofile         65535   
* hard     nofile         65535
root soft     nproc          65535    
root hard     nproc          65535   
root soft     nofile         65535   
root hard     nofile         65535


 

Dont forget to 

./configure --with-maxconn=4096 

then 

make clean server

also

chmod a+x login-server && chmod a+x char-server && chmod a+x map-server && chmod a+x athena-start

Goodluck! ❤️

 

On 4/1/2020 at 11:17 PM, Vector said:

Same problem here with debian.


Any good soul that can help us? In this moments a lot of people in quarantine wanna play RO and this is limiting the servers 😕

 

I'm using Debian 9


Be sure rathena is not running 

./athena-start stop 

First

nano /etc/sysctl.conf 

then add this below

fs.file-max = 360000
net.ipv4.ip_local_port_range = 1024 65000


Second

nano /etc/security/limits.conf

add this file below # End of file

*       hard    nofile  65535
*       soft    nofile  65535
root    hard    nofile  65535
root    soft    nofile  65535

Third

./configure --with-maxconn=4096

Fourth

make clean server

Fifth

chmod a+x login-server && chmod a+x char-server && chmod a+x map-server && chmod a+x athena-start

Last

./athena-start start

 

Good luck

Edited by VivoXYZ

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy.