Jump to content
  • 0
Kami675

s aid=1 has an incorect version=0 in clientinfo. Server compiled for 45

Question

Hello everyone, I seem to have run into a bit of trouble with my server. As the title says, I am currently having issues logging into the server itself. I get an error on the "charserv.bat" that states, "s aid=1 has an incorect version=0 in clientinfo. Server compiled for 45". This confuses me because my clientinfo.xml says "<version>45</version>" and mmo.h states "#define PACKETVER 20130807" I will post pictures of the server command promp and the clientinfo/mmo.h, if you need pictures or have questions about anything else please don't hesitate to ask. Also, the client date is 2013-08-07a, which according to packet_db the ver number should be "45".

 

thanks in advance,

- Kris

 

Photos: http://imgur.com/a/HtZPm

 

P.S. This is a offline private server being used to test and look at custom items

Edited by Kami675
Link to comment
Share on other sites

7 answers to this question

Recommended Posts

  • 0

You can't sign in with aid 0. Either create a new account or add a new row in your login table with id 250000 or something like that

I made a new accounts with the id of 2000001 and it still says the same thing just id of "2000001" instead of "0"...

 

Photo: http://imgur.com/a/nZelX

Link to comment
Share on other sites

  • 0

Check if you have the account set to a gender S, that must be the account used to Login, Map and Char servers to connect.

 

Yupp it is, in the picture I posted above it has a pic of mysql workbench with my login info(with my password edited out ofc)

 

Photo: http://imgur.com/a/nZelX

Link to comment
Share on other sites

  • 0

when changing the content of mmo.h, did you recompile?

 

and dont use 'S' as gender for player accounts.

 

also check your clientinfo, make sure it matches the version in the server and it is being read (first).

 

btw, are you using the server credentials to login via client? ( looks like you do )
if it is, create a new account to login via client, dont use the server credentials to login from client.

although im not sure if its possible to login in client using server credntials,
but thats how it looks based on your images.

Edited by benching
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy.