Jump to content
Sign in to follow this  
caliptogarcia

Mover lugar de los PJ donde inician

Recommended Posts

Buenas tardes, hace años atras, levante un server de ragnarok, el tema es que ahora despues de mucho tiempo lo vuelvo a hacer y no recuerdo donde se modificaba o que se modificaba para poder hacer que cuando un usuario nuevo entra al foro, aparezca por ejemplo en prontera o en alguna isla de novatos o algo asi, alguien podria darme una ayuda con eso? no logro recordar como modificar eso. me gustaria que los novices aparezcan en prontera directamente, eso por un lado y por otro lado bueno tengo muchas otras dudas quer descartar pero arranquemos por ahi.

Share this post


Link to post
Share on other sites
6 minutes ago, Frost-Eduardo said:

conf/char_athena.conf 


// Starting point for new characters
// Format: <map_name>,<x>,<y>{:<map_name>,<x>,<y>...}
// Max number of start points is MAX_STARTPOINT in char.hpp (default 5)
// Location is randomly picked on character creation.
// NOTE: For Doram, this requires client 20151001 or newer.
start_point: iz_int,18,26:iz_int01,18,26:iz_int02,18,26:iz_int03,18,26:iz_int04,18,26
start_point_pre: new_1-1,53,111:new_2-1,53,111:new_3-1,53,111:new_4-1,53,111:new_5-1,53,111
start_point_doram: lasa_fild01,48,297

// Starting items for new characters
// Max number of items is MAX_STARTITEM in char.cpp (default 32)
// Format: <id>,<amount>,<position>{:<id>,<amount>,<position>...}
// To auto-equip an item, include the position where it will be equipped; otherwise, use zero.
// NOTE: For Doram, this requires client 20151001 or newer.
start_items: 1201,1,2:2301,1,16
start_items_doram: 1681,1,2:2301,1,16


 

MUCHISIMAS GRACIAS !!!!!!!!!!!!!!!!!!!!!!

Share this post


Link to post
Share on other sites

hola, disculpen... yo hice un servidor pero a la hora de crear un char y empezar con ese char... me manda a una pantalla en negro despues de cargar... como puedo solucionar eso? sera que me puedan ayudar por fa?

Share this post


Link to post
Share on other sites
Posted (edited)
7 hours ago, edno82mx said:

hola, disculpen... yo hice un servidor pero a la hora de crear un char y empezar con ese char... me manda a una pantalla en negro despues de cargar... como puedo solucionar eso? sera que me puedan ayudar por fa?

Has configurado packets?

Edited by Mael
Typo error

Share this post


Link to post
Share on other sites
4 hours ago, Mael said:

Has configurado packets?

packets.hpp lo tengo asi:

#ifndef PACKETVER
	/// Do NOT edit this line! To set your client version, please do this instead:
	/// In Windows: Add this line in your src\custom\defines_pre.hpp file: #define PACKETVER YYYYMMDD
	/// In Linux: The same as above or run the following command: ./configure --enable-packetver=YYYYMMDD
	#define PACKETVER 20200409
#endif

la version 202004090 es la de este cliente --> kRO Full Client - 2021-04-06 - Includes BGM & RSU que subio Akkarin

Ya hice un char humano y un char gato y cuando cargo al char se escucha de fondo la musica ...  le baje el paquete renewal de este post --> https://rathena.org/board/topic/124801-guía-crear-un-servidor-profesional-de-ragnarok/ y use el paquete que subio de renewal -> 

Si tu servidor va a ser RENEWAL con la descripcion de items, y mapas renewal deberas bajar este rar de mi unidad Drive:

https://drive.google.com/file/d/18Pn4Zw0q_-yBTkE9n30JN8hGLGmL6iyo/view?usp=sharing

El servidor que compile esta en linux ubuntu. Y el cliente lo corro en windows 10 64 bits con tarjeta Nvidia. 

No se que mas datos poner para ver si es de ayuda para resolver el problema 😄 Gracias de ante mano.

Share this post


Link to post
Share on other sites
Posted (edited)
On 4/7/2021 at 12:44 PM, edno82mx said:

packets.hpp lo tengo asi:

#ifndef PACKETVER
	/// Do NOT edit this line! To set your client version, please do this instead:
	/// In Windows: Add this line in your src\custom\defines_pre.hpp file: #define PACKETVER YYYYMMDD
	/// In Linux: The same as above or run the following command: ./configure --enable-packetver=YYYYMMDD
	#define PACKETVER 20200409
#endif

la version 202004090 es la de este cliente --> kRO Full Client - 2021-04-06 - Includes BGM & RSU que subio Akkarin

Ya hice un char humano y un char gato y cuando cargo al char se escucha de fondo la musica ...  le baje el paquete renewal de este post --> https://rathena.org/board/topic/124801-guía-crear-un-servidor-profesional-de-ragnarok/ y use el paquete que subio de renewal -> 

Si tu servidor va a ser RENEWAL con la descripcion de items, y mapas renewal deberas bajar este rar de mi unidad Drive:

https://drive.google.com/file/d/18Pn4Zw0q_-yBTkE9n30JN8hGLGmL6iyo/view?usp=sharing

El servidor que compile esta en linux ubuntu. Y el cliente lo corro en windows 10 64 bits con tarjeta Nvidia. 

No se que mas datos poner para ver si es de ayuda para resolver el problema 😄 Gracias de ante mano.

Prueba usando este packet: 20200401

Solo con el cliente 20200902 he visto que es necesario cambiar packets "Si alguno tiene info de algún otro comentar por favor, esa info sirve".

Y porqué usas ese cliente? qué de bueno tiene? Porque nunca he escuchado a alguien recomendar ese cliente 😅

Algunas veces he visto que no es necesario cambiarlo. Confiando que haz configurado apropiadamente tu server, con eso debería solucionarse tu problema. 

Mas bien para una siguiente, crea otro post, los temas son diferentes.

Edited by Mael
Actualización de Información

Share this post


Link to post
Share on other sites
On 4/9/2021 at 8:26 AM, Mael said:

Prueba usando este packet: 20200401

Solo con el cliente 20200902 he visto que es necesario cambiar packets "Si alguno tiene info de algún otro comentar por favor, esa info sirve".

Y porqué usas ese cliente? qué de bueno tiene? Porque nunca he escuchado a alguien recomendar ese cliente 😅

Algunas veces he visto que no es necesario cambiarlo. Confiando que haz configurado apropiadamente tu server, con eso debería solucionarse tu problema. 

Mas bien para una siguiente, crea otro post, los temas son diferentes.

Gracias, voy a intentarlo.. de hecho tiene años que no volvi a montar un cliente y servidor..  Pense que el problema era lo del lugar donde iniciabas por que lo lei por ahi en un comentario por eso fue que pregunte aqui pero tiene usted razon hare un tema aparte cuando vuelva a suceder algo asi 😄 El cliente lo use por que era el que decia el tutorial que estaba leyendo jejeje pero ahi voy aprendiendo actualizandome a prueba y error jejeje. Gracias en serio por la ayuda.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy.