• 0
Ichigo

Error compilation refine renewal

Question

Hi.
I am implementing the ui refinement system.
I know it consists of two parts.
The first has been added successfully, but the second has not.
When compiling it gives me this error, but I don't see how to fix it.
Can anybody help me?
Thank you.

 

clif.cpp:20546:28: error: field bs_bless has incomplete type refine_bs_blessing
  struct refine_bs_blessing bs_bless;
                            ^~~~~~~~
clif.cpp:20546:9: note: forward declaration of struct refine_bs_blessing
  struct refine_bs_blessing bs_bless;
         ^~~~~~~~~~~~~~~~~~
clif.cpp: In function uint8 clif_refineui_materials(item*, item_data*, refine_materials*)’:
clif.cpp:20620:2: error: status_get_refine_blacksmithBlessing was not declared in this scope
  status_get_refine_blacksmithBlessing(&materials[REFINEUI_MAT_BS_BLESS].bs_bless, (enum refine_type)id->wlv, item->refine);
  ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
clif.cpp:20620:2: note: suggested alternative: status_get_refine_cost
  status_get_refine_blacksmithBlessing(&materials[REFINEUI_MAT_BS_BLESS].bs_bless, (enum refine_type)id->wlv, item->refine);
  ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
  status_get_refine_cost
make[1]: *** [Makefile:84: obj/clif.o] Error 1

 

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Nothing, the same mistake.

In case it can be helpful, use this information to implement it.

Quote

Hi guys, I found the problem in the commit https://github.com/rathena/rathena/pull/2494  the code to refine with the item Blessing was not added...   I could also see that they solved ( https://github.com/rathena/rathena/pull/2499  )  the problem but they did it in a 2017 emulator and when I want to add that solution I get a error in small fraction of the code....  And this happens because I'm using an emulator this year 2019.

some charitable soul could help me solve this problem please: https://github.com/rathena/rathena/pull/2499#issuecomment-464862431

 

Share this post


Link to post
Share on other sites
  • 0

I'm using the one I passed you, and it has no errors. It is the most stable.

Share this post


Link to post
Share on other sites
  • 0
10 hours ago, KeyMaster said:

I'm using the one I passed you, and it has no errors. It is the most stable.

Thank you.
Start over, with the one you told me, and if it works perfectly.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...