Jump to content

Slim

Members
  • Content Count

    6
  • Avg. Content Per Day

    0
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Slim

  • Rank
    New Member
  • Birthday February 3

Profile Information

  • Gender
    Male
  • Location
    Portugal
  • Github
    daniloleemes

Contact Methods

  • Discord
    Danilov3s#8008

Recent Profile Visitors

350 profile views
  1. Slim

    Avoid MATK Overflow

    Thank you for your suggestion, but I got it working already... I've changed the data types from both min and max to unsigned int, and changed every place that modify these values to cast it to int instead of short, and changed the caps from SHRT_MAX to USHRT_MAX. Also did some improvements in some formulas, like instead of using matk_max = matx_max + something, just matk_max += something; And last I changed the piece of code that calls clif to do a check whether the initial matk is 0 and reduce the max matk by 1.
  2. Slim

    Avoid MATK Overflow

    Doesn't work, tried setting the status->matk_max before the formula but it still "overflow". I don't even know if the correct name is overflow
  3. Hey all! Greetings, Recently I've been trying to avoid the MATK infamous overflow when it reaches the maximum, but no success at all. I tried protecting the values from getting bigger than SHRT_MAX (32727) but still nothing changed I tried poking aroud in the status.cpp, and found that when it executes this piece of code at line 5239 if (bl->type&BL_PC && sd->matk_rate != 100) { status->matk_max = status->matk_max * sd->matk_rate/100; status->matk_min = status->matk_min * sd->matk_rate/100; } And the matk_max is greater than 30097, the result is 87 (I'm not 100% sure about these values, but they're approximated) I've also tried changing the matk_min and matk_max to int, but I'm not sure if I did it right.. This is what I mean by "overflow" (the values just go negative) Thank you!
  4. Dude, this saved me! Is this code yours? I'd like to thank the owner if not. Thank you, again!
  5. Hi! i got it working by using another NEMO version.. Thank you anyways! I've used the one anacondaqq links on a tutorial in hercules
  6. Hi! I was using the 2014.10.22bRagexe together with a data from brAthena and was able to connect normally. After upgrading the client to 2018-06-21aRagexeRE I'm not able to connect anymore, I've updated the data to RoenglishRE together with its System folder and kRO dlls and stuff. The server version is the most recent from rAthena git. This is my client folder with everything inside, including my data and patched client Everything opens normally but after typing any password I just get the message "Disconnected from server" and there's nothing on the login-server logs, which got me thinking it could be somewhat related to the clientinfo.xml, so I've diffed (using NEMO) the option to select a custom clientinfo.xml and put the sclientinfo.xml. I'm not able to select Always Call SelectKoreaClientInfo() which checking the nemo wiki, I can see that my client won't support it. So I have nowhere to go now... I'm using this sclientinfo.xml <?xml version="1.0" encoding="euc-kr" ?> <clientinfo> <desc>Ragnarok Client Information</desc> <servicetype>korea</servicetype> <servertype>primary</servertype> <connection> <display>Local</display> <address>127.0.0.1</address> <port>6900</port> <version>55</version> <langtype>1</langtype> <registrationweb>www.ragnarok.com</registrationweb> <loading> <image>loading00.jpg</image> <image>loading01.jpg</image> <image>loading02.jpg</image> <image>loading03.jpg</image> <image>loading04.jpg</image> <image>loading05.jpg</image> <image>loading06.jpg</image> </loading> </connection> </clientinfo> I might be wrong but does the absence of a <aid> makes no difference unless I specify on NEMO to ignore GM clothes? PS: I can see the sclientinfo.xml file is being read by the client because if I change the <servertype> to Sakray or the <langtype> to anything but 0/1 the client won't open with a bunch of errors. Thanks!
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy.