• Announcements

    • Emistry

      Rules and Regulations - General/Script/Database/Source Support   11/16/2016

      In all sub-forums of this section , you are still bound to follow the rAthena Board Rules. Topic Author: Do not release scripts that are not of your own creation unless you can provide evidence of explicit permission from the original author to do so. Attempt to post your script in the proper section. If you're not certain as to where to post it, feel free to ask one of the Moderators. Do provide an informative title.  Do provide at the very least a 3-4 sentences description or summary that clearly states what your script does. Attempt to have multiple hosts for your scripts as to prevent dead links. 3 or more links are ideal. Links to your issue should directly provide the relevant items without the need for registration.  Make use of BBCode for respective contents.  Mark the reply as "Best Answer" in case it solved your issue. You may as well consider give them a reputation for the help. Vote Up relevant replies, and Vote Down for irrelevant replies. You're not allowed to bump your topics if you're not providing any new updates prior to your previous post.   Member: You're not allowed to bump your topics if you're not providing any new updates prior to your previous post. Do not post anything irrelevant contents in the topic. Vote Up relevant replies, and Vote Down for irrelevant replies. You may only post into this area if you are willing to either write new or make changes to scripting code yourself.  Do not criticize others reply being too general or without concrete scripting code.    Everyone: Violate these rules may result in immediate deletion of the topic/post, warning increase, and restriction of posting abilities for a certain period of time. On future offenses, member is to receive an increase in the warn level and have their posting abilities restricted for a certain period of time to be determined by the Moderators handling the case.
      * rAthena Staff reserves the right to add to and change the rules at any time. It is your duty to keep up with any changes and follow them to the best of your ability.   Your cooperation in this regard will be highly appreciated. Thank you.
  • 0
Sign in to follow this  

where do i go from here...?


can someone point me at a new ish tutorial? i felt like i had to mix up 2 different guides and i hit an error i dont quite understand, im gonna take a 5 min breather but i figured id ask and see before the inevitable struggle

i get through the steps of getting rathena through gitbash and then open it up in visual express and build it (whatever the order is, i just forget as im writing this) , then i think im making a mistake here: im on windows 10 and they say i should be editting through my imports file... so first i try editing from directly in the conf folders (not imports) like he shows in the tutorial 

// Character Server IP
 // The map server connects to the character server using this IP address.
 // NOTE: This is useful when you are running behind a firewall or are on
 // a machine with multiple interfaces.
 char_ip: 192.xxx.x.x < LAN IP
 // The map server listens on the interface with this IP address.
 // NOTE: This allows you to run multiple servers on multiple interfaces
 // while using the same ports for each server.
 // Character Server Port
 char_port: 6121
 // Map Server IP
 // The IP address which clients will use to connect.
 // Set this to what your server's public IP address is.
 map_ip: 69.xxx.x.x < WAN IP

so i tried that, and in the end i got this


so i tried making edits in the imports folder/files : 


I got the same problem, so i thought maybe this wasnt my mistake.

So i continued the tutorial and got into the sql server stuff ( i made sure to completely erase all data folders and stuff between every attempt)

installer sql server word by word here : https://github.com/rathena/rathena/wiki/SQL_Installation

Installed workbench 5.2 because it was the same as the one he used in tutorials.. but had errors executing some things, i believe it was outdated crap so i switched to 6.0(it carried all my stuff conveniently, so this could be the issue... but then i have trouble with the newer client of workbench being different layout completely ;_; ) so after i execute i jump back over to my 5.2... add new schemas for 'ragnarok", then heres another unspecif thing where he says we had to set ragnarok as default before adding our sql files for "main.sql" from our athena folder.... OK DONE NOW REPEAT FOR LOG... so i set it as main so all edits are directed there? then chose log.sql and then continue

and now its time for security privileges.... still using this site and nearing the end https://github.com/rathena/rathena/wiki/SQL_Installation

dont think my problem lies here. 

 Next step is "additional configurations", i plan on playing with items and mobs so i go ahead and copy all the non REnewal stuff in the workspace set ragnarok to default and paste, then execute for both.... i think im fine here as well....


so to my understanding, i think i should be at the step where i should be able to log into the game with my admin account under a server hosted from my PC? i dont really know or see any instructions regarding rAthena >to> kRO client stuff . . . . and when i try launching my 3 servers i get the errors above...


thanks if you can point out any obvious errors or a up to date guide or whatever you can offer. 

until then i will just keep restarting trying new guides until it works.... gg all have a good Christmas 



Share this post

Link to post
Share on other sites

1 answer to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this