Jump to content
  • 0
Valcars

Thor Patcher Problem.

Question

Hello everyone, I have a problem with Thor-Patcher in practice, sometimes it happens that does not load correctly all the progress bar, and not the Game Start button appears. To solve this problem I must close and reopen again the patcher, and wrapped the files are corrupt .... please help me, I do not know how to solve, I'm thinking about changing patcher because it is annoying this problem, but instead here first to see if there are solutions.
If there are no solutions you could recommend a good and stable Patcher.
Thank you and sorry for the trouble.

Link to comment
Share on other sites

8 answers to this question

Recommended Posts

  • 0

Here is my config file:

[Config:Main]

RootURL='http://leoragnarok.esy.es/patch/'

RemoteConfigFile='main.ini'

TimeOut=0

StatusFile='leoro.dat'

DefaultGRF='leo.grf'

ClientEXE='LeoRO.exe'
ClientParameter='-1sak1'

//When patcher unable to connect webserver,
//should the patcher allow player start the game anyways?
FinishOnConnectionFailure=false

[Config:Window]

Style='none'

//This allows the player drag the window by background
DragHandling=true

//Background can be either jpg or bmp, in later case
//the top-left pixel is chosen as transparent color.
Background='images/bg.bmp'

FadeOnDrag=false

[Config:BGM]
File='Parade.mp3'

Loop=true

Volume=5

Directory=

[Config:Misc]
Title='LeoRO Patcher'

HideProgressBarWhenFinish=false


[ProgressBar:bar1]
Width=400
Height=10

Left=23
Top=450

FrontImage=
BackImage=

Hook='ProgressChange'



[Label:Status]
AutoResize = true

Width=400
Height=10

Left=23
Top=480
Alignment='center'

FontColor=$FFFFFF
FontName = ''
FontSize = ''

Text=''

Hook='StatusChange'

[NoticeBox:Box0]
Width=405
Height=265
Left=20
Top=150
URL='notice.html'



[Button:Start]
Default='images/start1.png'
OnHover='images/start2.png'
OnDown='images/start3.png'

Left=450
Top=150

//Hook is used for default buttons,
//do not use this on custom buttons!
Hook='Start'

[Button:Exit]
Default='images/Exit1.png'
OnHover='images/Exit2.png'
OnDown='images/Exit3.png'

Left=450
Top=183

Hook='Exit'

[Button:Cancel]
Default='images/Exit1.png'
OnHover='images/Exit2.png'
OnDown='images/Exit3.png'

Left=383
Top=211
Hook='Cancel'

//[Button:Extra]
//
//
//
// Mode - mode for button
// 1 = open URL
// 2 = Launch file/program
// 3 = Message box
//Mode=
// Action - depend on what you set in the Mod, this may vary
// ex. Mode = 1 , Action='http://google.com'
//Action=
 

I download Thor patcher here

 

 

https://rathena.org/board/files/file/2259-thor-patcher/

 

I use Windows 10. I think that the players use either Windows 10, or Windows 8 .... some players have had this problem

Edited by Emistry
codebox
Link to comment
Share on other sites

  • 0

I dont see a problem with config, but i still dont fully understand your problem. Missing progress bar? Also, try the latest version.

Link to comment
Share on other sites

  • 0

the control bar works, the only problem is that sometimes it does not download the whole bar, and do not see the Start button.

Please provide screenshot.

Also, you are using free hosting. It is likely against their TOS and causing network issues.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy.