Jump to content
kiova

Error Clientes 2012

Recommended Posts

Hola a todos. Haber si me pueden ayudar, ahora mismo uso el cliente :

// 20111025 - 2011-10-25aRagexeRE+ - 0x6b, 0x6d <---------- Este es el unico que me funciona.

// 20120307 - 2012-03-07aRagexeRE+ - 0x970

#ifndef PACKETVER

#define PACKETVER 20111025

//#define PACKETVER 20111116

Solo ese exe es el unico que me funciona, ningun exe del 2012 me funciona por mucho que aga, he intentando de todo y no ahy manera. Mi version de rathnea es:rAthena 16758 trunk.

PD Siempre que me bajo un exe cambio el mmo.h y el packet_db.txt y aun asi no ahy manera de hacerlo funcionar cuando entro en el servidor y creo un personaje no ahy problema, el problema es acceder al juego que la pantalla del map serv me tira error packet_db y no ahy manera de soluciorlo, por cierto uso los ultimos lua que existen osea que estoy a full actualizado. Alguna idea??

Link to comment
Share on other sites

En primer lugar, debes activar la opción de "Load Custom DLL" y ponerle la DLL que podrás encontrar en los repos de Exes "WDGSkipPacketHeaderObfuscation.dll"

Para continuar, en el 2012-04-10 y posteriores (creo) tienes la opción de "Skip Packet Header Obfuscation", con todo eso se quita el error ese.

Además, estoy casi seguro te da un "Denied Access (3)" al intentar entrar al map server y te da un error de packet incorrecto.

Haciendo todo esto tendrás ya puesto el packetver 30 y podrás acceder.

Saludos

Link to comment
Share on other sites

ok gracias lo probare y te cuento

Nada no ahy manera de hacerlo funcionar, mira asi lo he hecho:

[info]: clif_parse: Disconnecting session #3 with unknown packet version (p:0x0e

d3,l:19).

exe usado: 2012-06-12aRagexeRE.exe en el diff le he puesto la opcion que tu me dices y le e puesto WDGSkipPacketHeaderObfuscation.dll este archivo lo tengo en la carpeta plugins.

Luego he configurado el mmo.h:

// 20111025 - 2011-10-25aRagexeRE+ - 0x6b, 0x6d

// 20120307 - 2012-03-07aRagexeRE+ - 0x970

#ifndef PACKETVER

#define PACKETVER 20120612

//#define PACKETVER 20111116

#endif

Despues he añadido en el packet_db.txt esto:

//2012-06-12aRagexeRE

0x01FD,15,repairitem,2

0x023B,26,friendslistadd,2

0x0361,5,hommenu,2:4

0x0954,36,storagepassword,0

0x0288,-1,cashshopbuy,4:8

0x0802,26,partyinvite2,2

0x022D,19,wanttoconnection,2:6:10:14:18

0x0369,7,actionrequest,2:6

0x083C,10,useskilltoid,2:4:6

0x0439,8,useitem,2:4

0x0281,-1,itemlistwindowselected,2:4:8

0x0815,-1,reqopenbuyingstore,2:4:8:9:89

0x0817,2,reqclosebuyingstore,0

0x0360,6,reqclickbuyingstore,2

0x0811,-1,reqtradebuyingstore,2:4:8:12

0x0819,-1,searchstoreinfo,2:4:5:9:13:14:15

0x0835,2,searchstoreinfonextpage,0

0x0838,12,searchstoreinfolistitemclick,2:6:10

0x0437,5,walktoxy,2

0x035F,6,ticksend,2

0x0202,5,changedir,2:4

0x07E4,6,takeitem,2

0x0362,6,dropitem,2:4

0x07EC,8,movetokafra,2:4

0x0364,8,movefromkafra,2:4

0x0438,10,useskilltopos,2:4:6:8

0x0366,90,useskilltoposinfo,2:4:6:8:10

0x096A,6,getcharnamerequest,2

0x0368,6,solvecharname,2

0x08E5,41,bookingregreq,2:4 //Added to prevent disconnections

0x08E6,4

0x08E7,10,bookingsearchreq,2

0x08E8,-1

0x08E9,2,bookingdelreq,2

0x08EA,4

0x08EB,39,bookingupdatereq,2

0x08EC,73

0x08ED,43

0x08EE,6

0x08EF,6,bookingignorereq,2

0x08F0,6

0x08F1,6,bookingjoinpartyreq,2

0x08F2,36

0x08F3,-1

0x08F4,6

0x08F5,-1,bookingsummonmember,2:4

0x08F6,22

0x08F7,3

0x08F8,7

0x08F9,6

0x08FA,6

0x08FB,6,bookingcanceljoinparty,2

0x0907,5,moveitem,2:4

0x0908,5

0x08D7,28,battlegroundreg,2:4 //Added to prevent disconnections

La verdad no se que hacer mas ya que lo estoy haciendo todo como se deve y aun asi no me deja entrar T_T Alguna solucion?

Ya he conseguido hacer que me funcionen XD solo tenia k cambiar el dll y poner otro por que el que te descargas con el ShinsDiffPatcher.exe no esta bien. El problema que tengo ahora es que todos los items, skills y demas me salen en coreano cuando con el exe 2011 los veia en ingles, por cierto ya le puse al diff la opcion de traducir al ingles pero no me lo hace. Alguna solucion?

Creo que por algun motivo no me lee los archivos .lua, y le pose la opcion...

Link to comment
Share on other sites

Me pasa lo mismo, lo tengo funcionando perfecto pero todas las skills y sus descripciones me aparecen en koreano... tambien me parece que no lee los lubs ni los luas...

Link to comment
Share on other sites

Nido la Solucion es: Vuelve a difear el exe y quitale la opcion que lea los lua antes que los lub. Y cambia los archivos de tu data de .lua a .lub. Segun judas: los exes apartir del 2012 no leen archivos .lua, solo lee los .lub por eso ahy que quitar esa opcion a la hora de difearlo.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy.