Jump to content
  • 0
ragnabuilder

Login client-side rAthena with Token

Question

I'm trying to use the token login.

So far what I've done is set web_auth_token_enabled to 1 on login table, and defining a web_auth_token to be use.
Looks like rAthena generates the token itself, didn't understood how it works yet.

I'm using kRO client 2021-11-17_Ragexe_1637052357 and patching it with NEMO.
Also, I'm using the following command line to execute the client and it always gives me an "Unregistered ID" message.

2021-11-17_Ragexe_1637052357_patched.exe 1rag1 -t:92ab7cac528c7c0f angelotinti G Ragnarok /account:clientinfo.xml

Below is the log on login server, first its a tentative with token and after that I logged normally with my GM account.

What should I do to make token login work? Is it still supported?

image.png.744913aa31d2d54dc725232926a98b17.png

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Problem solved!

"95 Use SSO Login Packet" and "232 Restore old login packet (Recommended)" shouldn't be used together.

Disabling Restore old login solved the problem.

Also, the correct parameters to use in the command line are as follows:

client.exe -t:password username -1rag1

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy.