• 0
Sign in to follow this  
gugiserman

Mount palette bug (using official dyes)

Question

Posted (edited)

Hello there,

We were doing some tests with the Halter Lead item and everything was working just fine. We seem to have all sprites for all mounts of all classes, but there are two or three specific cloth dyes that don't work well with the mounts. I checked everything I could and searched the whole forum and google and couldn't find anything like this, so I decided to finally ask for help here.

I'm attaching screenshots of what's happening with the Knight job class and its mount.

Besides the two or three cloth dyes that have this black messed up thing, there are a couple more mounts with very very small details in flat black color that I suspect are bugged as well but it's so tiny it doesn't really matter much, for example our purple Llama used by priests and acolytes is working well but at certain angles you can see some small black dots where I suppose would be fine details of the design.

We don't use custom palettes, we are relying on 3 sets of dyes (Default + Option 1 + Option 2) from iRO.
All dyes are perfectly working if the character is not mounted, for all classes, including Extended and 3rd.

I tried diffing the client with and without the "Use official dyes" option. With the option selected, we get the color sets that we want, but with the buggy mounts palettes. Without the option we get the color sets that we don't want, still with the buggy mounts when using anything other than the Default cloth dye. Our client is from 2013-05-22. Our grf is composed with up-to-date resources from kRO and iRO and works just fine when running on top of kRO, iRO or bRO official installations.

Thanks in advance.

---

Update: I could only find one single thread that describes the exact same problem, but no replies other than a suggestion to use custom palette. I even tried using the suggested pack but nothing changed besides messing up with all my hair colours.

 

Screen Shot 2019-01-07 at 01.45.06.png

Screen Shot 2019-01-07 at 01.45.36.png

Screen Shot 2019-01-07 at 01.45.54.png

Screen Shot 2019-01-07 at 01.46.00.png

Screen Shot 2019-01-07 at 01.46.14.png

Screen Shot 2019-01-07 at 01.46.21.png

Edited by gugiserman
wording, similar thread link

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Update: We fixed all the palettes manually using ROSS but now I have the strangest bug:

LK changes dye color when riding @mount2, but only for other players, not for the player who is playing as the LK. @refresh changes the dye back to what was supposed to be in the first place. We've already checked all files, I can't see a reason why this happens.

---

Update: We moved from 2013 to a 2015 client and the LK ride dye bug is gone.

Edited by gugiserman

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this