• 0
Sign in to follow this  
croxinuz

Move Flux to Webhosting Error

Question

Posted (edited)

hi, i got this error when install new flux on my webhosting

Error: PDOException

Message: SQLSTATE[HY000] [2003] Can't connect to MySQL server on '202.83.122.72' (111)

File: /home/ropk8475/public_html/lib/Flux/Connection.php:81

File	Line	Function/Method
/home/ropk8475/public_html/lib/Flux/Connection.php	81	PDO::__construct()
/home/ropk8475/public_html/lib/Flux/Connection.php	94	Flux_Connection::connect()
/home/ropk8475/public_html/lib/Flux/Connection.php	159	Flux_Connection::getConnection()
/home/ropk8475/public_html/modules/install/index.php	17	Flux_Connection::getStatement()
/home/ropk8475/public_html/lib/Flux/Template.php	375	include()
/home/ropk8475/public_html/lib/Flux/Dispatcher.php	170	Flux_Template::render()
/home/ropk8475/public_html/index.php	169	Flux_Dispatcher::dispatch()
Exception Trace As String
#0 /home/ropk8475/public_html/lib/Flux/Connection.php(81): PDO->__construct(*hidden*)
#1 /home/ropk8475/public_html/lib/Flux/Connection.php(94): Flux_Connection->connect(Object(Flux_Config))
#2 /home/ropk8475/public_html/lib/Flux/Connection.php(159): Flux_Connection->getConnection()
#3 /home/ropk8475/public_html/modules/install/index.php(17): Flux_Connection->getStatement('SELECT VERSION(...')
#4 /home/ropk8475/public_html/lib/Flux/Template.php(375): include('/home/ropk8475/...')
#5 /home/ropk8475/public_html/lib/Flux/Dispatcher.php(170): Flux_Template->render()
#6 /home/ropk8475/public_html/index.php(169): Flux_Dispatcher->dispatch(Array)
#7 {main}

i have do setsebool -P httpd_can_network_connect=1 and firewall-cmd --zone=public --add-port=3306/tcp --permanent; firewall-cmd --reload
 on my server VPS but nothing change.

someone can help me ?

Edited by croxinuz

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

solved, i'm request my webhosting enable remote mysql to my VPS IP.

Share this post


Link to post
Share on other sites
  • 0

Your port is open. Check the account information in servers.php make sure it is correct.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this