Jump to content
  • 0
oscar171

(rathena-master-12251) not support packet_ver 2014-03-05

Question

packet_ver 2014-03-05

WHAT I have to do for the most current rathena supports packet 05/03/2014

already compiled the emulator for the 20140305 package, the package added in the db

/ / 2014-03-05bRagexe - themon

//2014-03-05bRagexe - Themon
packet_ver: 47
0x0369,7,actionrequest,2:6
0x083C,10,useskilltoid,2:4:6
0x0437,5,walktoxy,2
0x035F,6,ticksend,2
0x0815,5,changedir,2:4
0x0202,6,takeitem,2
0x0362,6,dropitem,2:4
0x07EC,8,movetokafra,2:4
0x0364,8,movefromkafra,2:4
0x0436,10,useskilltopos,2:4:6:8
0x0366,90,useskilltoposinfo,2:4:6:8:10
0x096A,6,getcharnamerequest,2
0x0368,6,solvecharname,2
0x0838,12,searchstoreinfolistitemclick,2:6:10
0x0835,2,searchstoreinfonextpage,0
0x0819,-1,searchstoreinfo,2:4:5:9:13:14:15
0x0811,-1,reqtradebuyingstore,2:4:8:12
0x0360,6,reqclickbuyingstore,2
0x09D4,2,reqclosebuyingstore,0
0x0361,-1,reqopenbuyingstore,2:4:8:9:89
0x0365,18,bookingregreq,2:4:6
// 0x0363,8 CZ_JOIN_BATTLE_FIELD
0x0281,-1, itemlistwindowselected,2:4:8:12
0x0438,19,wanttoconnection,2:6:10:14:18
0x0802,26,partyinvite2,2
// 0x0878,4 CZ_GANGSI_RANK
0x07E4,26,friendslistadd,2
0x0934,5,hommenu,2:4
0x095e,36,storagepassword,2:4:20
0x09df,7
 
 

When I turn on the emulator complains that the following problem

u5qo.jpg

Edited by oscar171

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

like he said you need to increase the "MAX_PACKET_VER"  to 47 in clif.h.

NB : Tell us if they're is new field or wich client guy you consider better for 2014, as we might integrate it to svn.

  • Upvote 1

Share this post


Link to post
Share on other sites

I did everything as requested

emulator does not accuse but no error, the patch Perfect this because I used the latest patch and nemo 2014-03-05bRagexe provided by themon

 

themon

if that step still don't work

try this much simple one

first download fresh rathena https://github.com/rathena/rathena

then edit mmo.h http://upaste.me/a73a1241981b2d981

then edit packet_db.txt http://upaste.me/f28212420d540de4d

compile your rathena server

and update your data folder or grf https://github.com/R.../commits/master

download 2014 client https://github.com/T...4-Ragexe-Client

patch with nemo patcher https://github.com/MStr3am/NEMO

here my nemo patch log

 

Now when I log in I received the following problem
ifny.jpg
I thought it was md5 I wore but I redid the database without the md5 and have disabled it in login.athena but remains so

28/06/2014
my rathena master 12257\trunk\db\packet_db
 
// 2014-03-05bRagexe - Themon
packet_ver: 45
0x0369,7,actionrequest,2:6
0x083C,10,useskilltoid,2:4:6
0x0437,5,walktoxy,2
0x035F,6,ticksend,2
0x0815,5,changedir,2:4
0x0202,6,takeitem,2
0x0362,6,dropitem,2:4
0x07EC,8,movetokafra,2:4
0x0364,8,movefromkafra,2:4
0x0436,10,useskilltopos,2:4:6:8
0x0366,90,useskilltoposinfo,2:4:6:8:10
0x096A,6,getcharnamerequest,2
0x0368,6,solvecharname,2
0x0838,12,searchstoreinfolistitemclick,2:6:10
0x0835,2,searchstoreinfonextpage,0
0x0819,-1,searchstoreinfo,2:4:5:9:13:14:15
0x0811,-1,reqtradebuyingstore,2:4:8:12
0x0360,6,reqclickbuyingstore,2
0x09D4,2,reqclosebuyingstore,0
0x0361,-1,reqopenbuyingstore,2:4:8:9:89
0x0365,18,bookingregreq,2:4:6
// 0x0363,8 CZ_JOIN_BATTLE_FIELD
0x0281,-1, itemlistwindowselected,2:4:8:12
0x0438,19,wanttoconnection,2:6:10:14:18
0x0802,26,partyinvite2,2
// 0x0878,4 CZ_GANGSI_RANK
0x07E4,26,friendslistadd,2
0x0934,5,hommenu,2:4
0x095e,36,storagepassword,2:4:20
0x09df,7
 
my \rathena master 12257\trunk\src\common\mmo
 
#ifndef PACKETVER
#define PACKETVER 20140305
//#define PACKETVER 20120410
#endif
 
 
 
Edited by oscar171

Share this post


Link to post
Share on other sites

check utils.c

 

find 

	else if(date < 20131223) return 45;
	else if(date >= 20131223) return 46;

	else return 30; //default
}

add to

	else if(date < 20131223) return 45;
	else if(date < 20131223) return 46;
	else if(date >= 20140305) return 47;

	else return 30; //default
}

and recompile


and check clif.h

find

enum { // packet DB
	MAX_PACKET_DB  = 0xf00,
	MAX_PACKET_VER = 46,
	MAX_PACKET_POS = 20,
};

edit to

enum { // packet DB
	MAX_PACKET_DB  = 0xf00,
	MAX_PACKET_VER = 47,
	MAX_PACKET_POS = 20,
};

check login_athena.conf

// What version is allowed to connect? (if the option above is enabled)
client_version_to_connect: 20

edit to : 47

 

check clientinfo.xml

		<version>30</version>

edit to 47

  • Upvote 2

Share this post


Link to post
Share on other sites

problem solved with help of themon, Napster and also 15peaces and Lighta

This topic serves as a guide for members who are trying to use the most current package 03/05/2014 with rathena 

Edited by oscar171

Share this post


Link to post
Share on other sites

Ye only thing Napster didn't mention is the md5_checksum hash for you client wich look like it was the 2nd error, but I guess he was checking wrong version.

  • Upvote 1

Share this post


Link to post
Share on other sites

Now it working

Edited by jumpjung

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy.