helvetica

Officially supported client versions

Recommended Posts

 

Can you support 2013-12-23c now? And its updates for example the new npc?

If 'you' means is me, I can't.

 

Wait other dev/someone who want add/support everything about client stuffs

 

 

okie okie. thanks!

Share this post


Link to post
Share on other sites

Ye we could give it a try, I'm kinda interest of removing all the very old version definition too

Share this post


Link to post
Share on other sites

Hello. Im not sure but here goes. I know we are moving towards the 2013 clients and you guys have gone so far on the progress(big thanks to that). However, I want to ask if that would also mean that there will be less to no more support for pre renewal concerns sooner or later or is it something that the pre renewal right now is already stable as it could get.

Share this post


Link to post
Share on other sites

Do you mean pre-re client like below version 23 or just the emulater in general ?

If it's about the client well it's already the case most of support are for newer client and I don't really see a reason why you would like to keep an old one. (unless you have done some modification in it). Even in a pre-re serv a renewal client will act fine.

Now about the emu the pre-re will continue to be maintain but it's not our main priority, we mostly dev with the RENEWAL enable and try to not alter PRE-RE the other way arround is quite rare.

Share this post


Link to post
Share on other sites

Ye we could give it a try, I'm kinda interest of removing all the very old version definition too

 

This is good news cause the new client has new updates such as NPC. It was a great update.

Share this post


Link to post
Share on other sites

I understand that new clients want to use when they bring new features.....

but with the delay in zones episode we see that it should not be a priority.
I think setting the ATK and damage should be priority............................................................................

Share this post


Link to post
Share on other sites

I need help with the rathena - Revision 17702 Trunk build I'm looking for help making a client or acquiring a working one. if possible I would like to reverse the scroll wheal from back to zoom out and forward to zoom in? And is it also possible to use the w a s d or arrow keys to move?

 

Everything’s changed so much I'm lost totally lost.

Share this post


Link to post
Share on other sites

is rathena still compatible with 2009 clients? I want the old interface in it

Share this post


Link to post
Share on other sites

I think it's still supported, but just to be sure please check for your client date on mmo.h to see if it's supported or not.

I'd suggest you to use newer client though.

Share this post


Link to post
Share on other sites

We don't make any effort at breaking older clients that were already supported, but at the same time we won't be doing any regression testing to make sure they still work after any client-affecting code update (minus the 3 listed as supported).

Share this post


Link to post
Share on other sites

nanakiwurtz, how to do that? After some search I couldn't understant ur sentence =p

Share this post


Link to post
Share on other sites

I wanna use this:

 

Pre-Renewal:

2010-07-30aRagexeRE

 

Here are some of my questions:

 

1. Can I use Alexandria's data folder version 2.0 (pre-renewal) found here  http://rathena.org/board/topic/66962-basic-complete-renewal-data-english-folder/ ?

2. I tried looking for 2010-07-30a lua but only found that there's no exact lua for it according to this  http://rathena.org/board/topic/69566-lua-files-for-older-version-that-you-need-2011-12-14-below/

Since its in between two version dates, which will I use, 2010-07-14 lua or 2010-08-11 lua ?

 

Pls help..THX /??

Edited by miczster

Share this post


Link to post
Share on other sites

I wanna use this:

 

Pre-Renewal:

2010-07-30aRagexeRE

 

Here are some of my questions:

 

1. Can I use Alexandria's data folder version 2.0 (pre-renewal) found here  http://rathena.org/board/topic/66962-basic-complete-renewal-data-english-folder/ ?

2. I tried looking for 2010-07-30a lua but only found that there's no exact lua for it according to this  http://rathena.org/board/topic/69566-lua-files-for-older-version-that-you-need-2011-12-14-below/

Since its in between two version dates, which will I use, 2010-07-14 lua or 2010-08-11 lua ?

 

Pls help..THX /??

 

1. Absolutely YES

2. Use 2010-08-11

Share this post


Link to post
Share on other sites

 

I wanna use this:

 

Pre-Renewal:

2010-07-30aRagexeRE

 

Here are some of my questions:

 

1. Can I use Alexandria's data folder version 2.0 (pre-renewal) found here  http://rathena.org/board/topic/66962-basic-complete-renewal-data-english-folder/ ?

2. I tried looking for 2010-07-30a lua but only found that there's no exact lua for it according to this  http://rathena.org/board/topic/69566-lua-files-for-older-version-that-you-need-2011-12-14-below/

Since its in between two version dates, which will I use, 2010-07-14 lua or 2010-08-11 lua ?

 

Pls help..THX /??

 

1. Absolutely YES

2. Use 2010-08-11

 

thx for the answer....May I ask if it is okay to use the latest github files for rathena with these??? last time I remembered using the last svn files with alexandria's data

Share this post


Link to post
Share on other sites

 

 

I wanna use this:

 

Pre-Renewal:

2010-07-30aRagexeRE

 

Here are some of my questions:

 

1. Can I use Alexandria's data folder version 2.0 (pre-renewal) found here  http://rathena.org/board/topic/66962-basic-complete-renewal-data-english-folder/ ?

2. I tried looking for 2010-07-30a lua but only found that there's no exact lua for it according to this  http://rathena.org/board/topic/69566-lua-files-for-older-version-that-you-need-2011-12-14-below/

Since its in between two version dates, which will I use, 2010-07-14 lua or 2010-08-11 lua ?

 

Pls help..THX /??

 

1. Absolutely YES

2. Use 2010-08-11

 

thx for the answer....May I ask if it is okay to use the latest github files for rathena with these??? last time I remembered using the last svn files with alexandria's data

 

 

Its okay, there should be no problems.

Share this post


Link to post
Share on other sites

PRE-RENEWAL Client: 2010-07-30aRagexeRE

 

 

Can't work to buy items in cash shop. When you buy some items in cash shop, almost nothing happens and stuck anytime.

 

I'm completely work compile in this mmo.h,packet_ver in server and client_version in client.

 

 

What client for recommend this pre-renewal client?

Share this post


Link to post
Share on other sites

hello, can you help me fix my problem. I am not able to make it work at all. my clients are now failing. I am using 2013 rathera server but haven't made my client work at all.

Share this post


Link to post
Share on other sites

Any supported 2014+ clients? (To be used for a live/production server which is in Pre-renewal) Thanks

Share this post


Link to post
Share on other sites
Quote

Pre-Renewal:
2010-07-30aRagexeRE
 
Renewal 2012:
2012-04-10aRagexeRE
 
Renewal 2013:
2013-08-07aRagexe
2013-12-23aRagexe
 
Renewal 2014:
2014-10-22aRagexe

 

Renewal 2015:
2015-05-03aRagexe

2015-11-04aRagexe

so this mean new rathena dont support 20120410 pre-re??

or supported?

Share this post


Link to post
Share on other sites

We now support all the clients listed in the packet files. Since there's so many it doesn't make sense to have them all individually listed anymore.

Locking this thread as it no longer serves any purpose.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.