Shakto

2013 Ragexe and Diff (Up to date 2013-08-07)

Recommended Posts

- Does it have to be sclientinfo.xml? or does the old clientinfo.xml work? [i'll test that later] part

 

- Can't seem to find the "Restore Login Window - Disable rag1&sak1 - Skip Service Select" Part on the diff, and Rocred keeps launching the Ragnarok Setup file for some reason. Setup just keeps looping when closed.

 

- Tested with all 3 clients...

Edited by Leehalt

Share this post


Link to post
Share on other sites

@Leehalt it have to be clientinfo.xml, sorry for my mistake

 

For RoCred, you have to open rocred.ini ang change this line

 

; Client to start when clicking login.
ExeName = Nameofyourexe.exe
 
@kangfredy, I added the packets for each version of the client
Edited by Shakto

Share this post


Link to post
Share on other sites

- Yeah I did that line along with other settings, the process tree includes the client itself but there aren't any windows popping out. Plus the setup keeps reloading itself.

 

- These are the current RoCred settings.

[ROCred]
; Whether or not user name is remembered (0 = No, 1 = Yes).
CheckSave =1

; Remembered user name.
UserName =Serin

; Client to start when clicking login.
ExeName = Ragnarok.exe

; Argument to pass to the client.
ExeType = 1rag1
Edited by Leehalt

Share this post


Link to post
Share on other sites

Try with a 2011 or 2012 client ?

It shouldn't open, maybe your graphic card isn't recognize ?

Share this post


Link to post
Share on other sites

You've an error or something  ???



- Yeah I did that line along with other settings, the process tree includes the client itself but there aren't any windows popping out. Plus the setup keeps reloading itself.

 

- These are the current RoCred settings.

[ROCred]
; Whether or not user name is remembered (0 = No, 1 = Yes).
CheckSave =1

; Remembered user name.
UserName =Serin

; Client to start when clicking login.
ExeName = Ragnarok.exe

; Argument to pass to the client.
ExeType = 1rag1

It shoudn't be Ragnarok.exe but Ragexe.exe °°

Share this post


Link to post
Share on other sites

When i try rocred

I get the following errors

 

The required operation needs elevation.

 

Here is my ini file settings.

[ROCred]
; Whether or not user name is remembered (0 = No, 1 = Yes).
CheckSave =1

; Remembered user name.
UserName =MyUsername

; Client to start when clicking login.
ExeName = Ragnarok.exe

; Argument to pass to the client.
ExeType = 1rag1

Share this post


Link to post
Share on other sites

@paranoid Like i said in the post : Launch it as administrator !!!

 

@latso : yes, there is not login windows anymore

Edited by Shakto

Share this post


Link to post
Share on other sites

shakto can you make tutorial with video?how to setting this?heheheh :) i want to use this client.

Share this post


Link to post
Share on other sites

got error at char server

 

[Info]: request connect - account_id:2000003/login_id1:972500964/login_id2:98284
4974
[Info]: Loading Char Data (2000003)
[Info]: Loading Char Data (2000003)
[Info]: request connect - account_id:2000000/login_id1:1786523254/login_id2:2255
50650
[Info]: Loading Char Data (2000000)
[Info]: Loading Char Data (2000000)
[Info]: We are here in 9a1
[Info]: request connect - account_id:2000000/login_id1:1680562602/login_id2:1397
284081
[Info]: Loading Char Data (2000000)
[Info]: Loading Char Data (2000000)
[Info]: We are here in 9a1
[Info]: request connect - account_id:2000000/login_id1:1059638202/login_id2:1775
439675
[Info]: Loading Char Data (2000000)
[Info]: Loading Char Data (2000000)
[Info]: We are here in 9a1

using 2013-05-22 and got pop up error at lua files\datainfo\shadowtable.lua

after that client crash.

Edited by hendra814
  • Upvote 1

Share this post


Link to post
Share on other sites

@hendra814 For your char server, it's a problem with char.c, i recommend you to post it in the bug tracker please

For your shadowtable.lua, please delete this file and update your kro installation.

 

@kanfredy, where do you have trouble ?

Share this post


Link to post
Share on other sites

p1kkHEO.png

I using 2013-05-22 diff "Disable Packet Encryption" got error(see picture above),but not diff "Disable Packet Encryption" 2013-05-22 is Crash

(sorry,My English so bad........)

  • Upvote 1

Share this post


Link to post
Share on other sites

You have to configure your packet_db.txt with the packets
Change your packet ver in mmo.h AND in your clientinfo.xml

 

packet 0x0e3c hasn't the diff disable packet encryption check...

Edited by Shakto

Share this post


Link to post
Share on other sites

You have to configure your packet_db.txt with the packets

Change your packet ver in mmo.h AND in your clientinfo.xml

packet_db.txt has 2013-05-22 packets

mmo.h

#ifndef PACKETVER
	//#define PACKETVER 20120410
	#define PACKETVER 20130522
	//#define PACKETVER 20111116
#endif

clientinfo.xml

<?xml version="1.0" encoding="euc-kr" ?>
<clientinfo>
<servicetype>korea</servicetype>
<servertype>primary</servertype>
   <connection>
      <display>myserver</display>
      <balloon>the balloon</balloon>
      <desc></desc>
      <address>127.0.0.1</address>
      <port>6900</port>
      <version>35</version>
      <langtype>0</langtype>
      <registrationweb></registrationweb>
        <aid>
            <admin></admin>
			<admin></admin>
			<admin></admin>
        </aid>
        <loading>
            <image></image>
        </loading>
   </connection>
</clientinfo>

Share this post


Link to post
Share on other sites

clientinfo.xml

<version>35</version>
to
<version>36</version>

 

Because :

//2013-05-22 Ragexe (Yommy)
packet_ver: 36
Edited by Shakto
  • Upvote 1

Share this post


Link to post
Share on other sites

You have to configure your packet_db.txt with the packets

Change your packet ver in mmo.h AND in your clientinfo.xml

 

packet 0x0e3c hasn't the diff disable packet encryption check...

umm...so I need diff "Disable Packet Encryption" or not ?

 

clientinfo.xml

<version>35</version>
to
<version>36</version>

 

Because :

 

//2013-05-22 Ragexe (Yommy)
packet_ver: 36

I changed version 35 to 36,but some error

Share this post


Link to post
Share on other sites

Yes you need the diff

What error do you have now ?

Share this post


Link to post
Share on other sites

Yes you need the diff

What error do you have now ?

Now not have error,but 2013-05-22 crash

Edited by XDXDMAN

Share this post


Link to post
Share on other sites

Let me check wich patch is bugging

 

Edit : Ok don't check the remove houlry annonce patch for now, there is a problem with it, i'll check that :)

Edited by Shakto

Share this post


Link to post
Share on other sites

Let me check wich patch is bugging

 

Edit : Ok don't check the remove houlry annonce patch for now, there is a problem with it, i'll check that :)

ok,thx you help~

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...