Sign in to follow this  
Gepard

r15572: New GM, Commands & Permissions system

Recommended Posts

Question, is group.conf being reloaded too when I use @reloadatcommand?

Share this post


Link to post
Share on other sites

yes

Share this post


Link to post
Share on other sites

I don't know how to edit this, Still Player Level can use # command. How to remove that to them? Can you give me one of your work guys =/

Share this post


Link to post
Share on other sites

Where can you see atcommands list now since atcommands.conf is just for aliases and other configurations. Halp.

Im transferring now from eAthena to rAthena xD.

Share this post


Link to post
Share on other sites

atcommands are still in that file, the alias thing is a plus

Share this post


Link to post
Share on other sites

How to fix #command? I wanted that ONLY GMs can use it, no one replies in my recent posts, I don't understand how they explain it =/ any good way? My players can use # command ... I only want to make it available for GMs. Anyone?

Share this post


Link to post
Share on other sites

I found it, it is in the doc folder lol

docatcommands.txt

Share this post


Link to post
Share on other sites

What Paulinds pointed out is true. The old command system lets you disable charcommands or set the minimum level.

With the new system, we are unable to do the same. I suggest implementation of this feature.

All in all, I'm starting to like this new command system, easy to setup but due to what I mentioned above it restrains me

to fully like the system.

  • Upvote 2

Share this post


Link to post
Share on other sites

What Paulinds pointed out is true. The old command system lets you disable charcommands or set the minimum level.

With the new system, we are unable to do the same. I suggest implementation of this feature.

All in all, I'm starting to like this new command system, easy to setup but due to what I mentioned above it restrains me

to fully like the system.

agreed, that way no accidents can happen.

Edited by sizenine

Share this post


Link to post
Share on other sites

you can disable a char command of a specific command by making the value of a command to [true,false]

ex:

go: [true,false]

  • Upvote 1

Share this post


Link to post
Share on other sites

you can disable a char command of a specific command by making the value of a command to [true,false]

ex:

go: [true,false]

True, you can disable specific commands and as we know there are two (2) types of commands, atcommand (@) and charcommand (#).

I was referring to charcommands such as #go or #warp.

  • Upvote 1

Share this post


Link to post
Share on other sites

I suggest the addition of setgroupid() command, so we don't need to relay on sql queries at script side

Share this post


Link to post
Share on other sites

Since I noticed the Removed of @adjcmdlvl command,

I wonder is it possible to add a command @adjcomdgroup

which temporarily adjust the specified group can use.

e.g.

During woe I want to disable some commands from normal player.

Share this post


Link to post
Share on other sites

Since I noticed the Removed of @adjcmdlvl command,

I wonder is it possible to add a command @adjcomdgroup

which temporarily adjust the specified group can use.

e.g.

During woe I want to disable some commands from normal player.

It's a little old topic, but you can use: @adjgroup

Share this post


Link to post
Share on other sites

nice job,well as Matheus said

I loved the new structure of config files. Congratulations.

Share this post


Link to post
Share on other sites

Are there any converters out there? I personally dislike the new GM system..I dont want to spend an entire afternoon on this...again.

Edit: Nevermind! Got it going.

Share this post


Link to post
Share on other sites

So is there any way to enable # for GMs?

Share this post


Link to post
Share on other sites

So is there any way to enable # for GMs?

post#62

  • Upvote 1

Share this post


Link to post
Share on other sites

Nevermind. I think that I understand now. Thanks anyway.

Edited by Decimal

Share this post


Link to post
Share on other sites

you can disable a char command of a specific command by making the value of a command to [true,false]

ex:

go: [true,false]

True, you can disable specific commands and as we know there are two (2) types of commands, atcommand (@) and charcommand (#).

I was referring to charcommands such as #go or #warp.

you can disable a char command of a specific command by making the value of a command to [true,false]

ex:

go: [true,false]

True, you can disable specific commands and as we know there are two (2) types of commands, atcommand (@) and charcommand (#).

I was referring to charcommands such as #go or #warp.

Same examination here.

The charcommand is working, all I need to do was type the player's name while using the command. But where can we set the permissions though?

Edited by Valiente

Share this post


Link to post
Share on other sites
But where can we set the permissions though?

permissions - you mean which GM level(s) can use the command?

That's the whole idea of groups instead of levels.

Within the group config, you set which commands they can use in the commands: { } block.

trunk/conf/groups.conf

Share this post


Link to post
Share on other sites

Someone please Help Me to GM command to Normal Player I've edited in group.conf but it does not work what are other examples?

groups: (
{
   id: 0 /* group 0 is the default group for every new account */
   name: "Player"
   level: 0
   inherit: ( /*empty list*/ )
   commands: {
       /* no commands by default */
       commands: true
       mobinfo: true
       iteminfo: true
       whodrops: true
       whereis: true
       jailtime: true
       autoloot: true
       alootid: true
       autotrade: true
       go: true
   }
   permissions: {
       /* without this basic permissions regular players could not
       trade or party */
       can_trade: true
       can_party: true
   }
},

Is there any other Config should change except in grup.conf?

Share this post


Link to post
Share on other sites

Help! i have an error after i edit the group.conf , even changing back to original still shows the same problem

[Warning]: pc_group_pc_load: (AID:2000000) logged in with unknown group id (99)! kicking...

it cant identify my group id already. same for 0 groups - 99.

groups.conf

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this