Jump to content
NicoAFV1212

ITEM CUSTOM SPRITE

Recommended Posts

Hola, les comento mi problema. He seguido dos guias de agregar items custom y las dos me llevan al mismo resultado "Unknow item". Probe con los dos GRF. EL nuevo y el antiguo y ambos me da problema. Tome capturas con el nuevo cliente, alguien me  dice que esta mal? , Probablemente sea el EXE? es version 2018-06-20eRagexeRE_patched. Porfavor necesito su ayuda, no puedo agregar items customs e intentado muchas guias y todas sin exito

Captura2.PNG.40bcb4c40942fba4f64afb7add041a3b.PNG

Captura.PNG.b3af4480632f64704926fe94b9a97aff.PNG

Captura1.PNG.ce1d5caf9f95f818dcef89afc0707efa.PNG

Captura6.PNG.c6f4f61b3177c3dd97475683751900f7.PNG

7.PNG.89f6f1e32309bd320b1c6681177952a3.PNG

Captura3.PNG.a8749495b14e58d555b4c5902161a504.PNG

Captura4.PNG.62b62efd1807c3e9d9f76a7862ffa813.PNG

Captura5.PNG.33204b3f41da46c69ebc5d6f2d4c31d2.PNG

Captura7.PNG

Link to comment
Share on other sites

Le saque el _ como mencionaste tanto en Collection y en Item y aun asi tengo el mismo error de que no se ve la imagen y dice unknow item

image.png.4e7162ff0da5fd5410191f4f3d5dd379.pngimage.png.0267ee3668c09b120f8ca22fc22691ca.png

Edited by NicoAFV1212
Link to comment
Share on other sites

48 minutes ago, NicoAFV1212 said:

Le saque el _ como mencionaste tanto en Collection y en Item y aun asi tengo el mismo error de que no se ve la imagen y dice unknow item

image.png.4e7162ff0da5fd5410191f4f3d5dd379.pngimage.png.0267ee3668c09b120f8ca22fc22691ca.png

iteminfo ? drop sprite?

Link to comment
Share on other sites

13 minutes ago, sader1992 said:

iteminfo ? drop sprite?

Nose a que te refieres pero tengo 3 iteminfo, el normal y iteminfo_V3 y iteminfo_V5. Lo tengo agregado solo en el "iteminfo"

modifique los _Scraf a Scarf en:
GRF\data\texture\À¯ÀúÀÎÅÍÆäÀ̽º\collection\scarf
GRF\data\texture\À¯ÀúÀÎÅÍÆäÀ̽º\texture\scarf

despues de eso no modifique nada en iteminfo, esta asi:

	[8000] = {
		unidentifiedDisplayName = "Scarf",
		unidentifiedResourceName = "_Scarf",
		unidentifiedDescriptionName = { "..." },
		identifiedDisplayName = "Scarf",
		identifiedResourceName = "_Scarf",
		identifiedDescriptionName = {
			"Item Custom Nidhoggur.",
			"Class:^6666CC Costume^000000",
			"Location:^6666CC Lower headgear^000000",
			"Weight:^006600 100^000000",
			"Level Requirement:^006600 1^000000",
			"Jobs:^6666CC All^000000"
		},
		slotCount = 1,
		ClassNum = 1882
	},

 

Link to comment
Share on other sites

	[8000] = {
		unidentifiedDisplayName = "Scarf",
		unidentifiedResourceName = "Scarf",
		unidentifiedDescriptionName = { "..." },
		identifiedDisplayName = "Scarf",
		identifiedResourceName = "Scarf",
		identifiedDescriptionName = {
			"Item Custom Nidhoggur.",
			"Class:^6666CC Costume^000000",
			"Location:^6666CC Lower headgear^000000",
			"Weight:^006600 100^000000",
			"Level Requirement:^006600 1^000000",
			"Jobs:^6666CC All^000000"
		},
		slotCount = 1,
		ClassNum = 1882
	},

 

Link to comment
Share on other sites

On 9/20/2020 at 9:23 AM, sader1992 said:
	[8000] = {
		unidentifiedDisplayName = "Scarf",
		unidentifiedResourceName = "Scarf",
		unidentifiedDescriptionName = { "..." },
		identifiedDisplayName = "Scarf",
		identifiedResourceName = "Scarf",
		identifiedDescriptionName = {
			"Item Custom Nidhoggur.",
			"Class:^6666CC Costume^000000",
			"Location:^6666CC Lower headgear^000000",
			"Weight:^006600 100^000000",
			"Level Requirement:^006600 1^000000",
			"Jobs:^6666CC All^000000"
		},
		slotCount = 1,
		ClassNum = 1882
	},

 

Cambie los nombres de la iteminfo igual y no sirvio. Me tiene re complicado este tema, he probado con todo y nada me resulta. Antiguamente me funcionaba como en el 2011 pero ahora no

image.thumb.png.8a20984e91b6ad75813c5a26ca0b24dd.png

 

necesito editar esto igual sin el _?
image.png.dfc5ed34bad1c68ba6f9ebe439a59106.png

 

alguien sabe que pasa? por que no puedo agregar item customs =/

Edited by NicoAFV1212
Link to comment
Share on other sites

2 hours ago, NicoAFV1212 said:

alguien sabe que pasa? por que no puedo agregar item customs =/

Son dos cosas:

1. Tu cliente no está leyendo el iteminfo.lua donde estás colocando tu custom.

2. En el item_db.txt no has colocado el classnum.

Link to comment
Share on other sites

Descubri que es el EXE. donde yo no lo diffie esta conf con otros parametros, ahora mi problema es difear el exe, me tira un error cuando coloco las configuraciones recomendadas.

2018-06-20eRagexe 

257 Use Default Web Browser for <URL>
1 Use Tilde for Matk
258 Enable Shortcut All Item
3 Chat Flood Remove Limit
8 Custom Window Title
9 Disable 1rag1 type parameters (Recommended)
16 Disable Swear Filter
19 Enable Title Bar Menu
20 Extend Chat Box
277 Change RecommendedQuestInfoList*.lub path
21 Extend Chat Room Box
22 Extend PM Box
279 Fix item description bug
23 Enable /who command (Recommended)
24 Fix Camera Angles (Recommended)
28 Increase Headgear ViewID
286 Hide zero date (1969-01-01) in guild members window
287 Change character display deletion time from actual date to relative date
31 Increase Zoom Out 75%
289 Fix Homunculus attack AI
290 Hide build info in client (Recommended)
291 Hide packets from peek (Recommended)
36 Read msgstringtable.txt (Recommended)
293 Increase hair style limit for human only in game (old)
38 Remove Gravity Ads (Recommended)
39 Remove Gravity Logo (Recommended)
40 Restore Login Window (Recommended)
43 Always Use Email for Char Deletion
44 Translate Client (Recommended)
46 Use Normal Guild Brackets (Recommended)
47 Use Ragnarok Icon
48 Use Plain Text Descriptions (Recommended)
49 Enable Multiple GRFs (Recommended)
50 Skip License Screen
53 Use Ascii on All LangTypes (Recommended)
63 Use Official Cloth Palettes
64 @ Bug Fix (Recommended)
65 Load Custom lua file instead of iteminfo*.lub (Recommended)
69 Extend Npc Dialog Box
73 Remove Hourly Announce (Recommended)
76 Enforce Official Login Background
84 Remove Serial Display (Recommended)
86 Only First Login Background
88 Allow space in guild name
90 Enable DNS Support (Recommended)
115 Enable Effect for all Maps [Experimental]
205 Enable Monster Tables
212 Restore Roulette
213 Disable Help Message on Login (Recommended)
219 Always Show Resurrection Button
222 Show Replay Button
225 Show Register Button
229 Enable Emblem hover for BG
230 Always load Korea ExternalSettings lua file
239 Ignore /account: command line argument
241 Always Load Client Plugins [Experimental]
247 Change new char name field height
248 Remove wrong chars from cash shop
251 Allow close cutin by pressing esc key
253 Skip some hidden menu icon buttons
256 Use Default Web Browser In Cashshop

image.thumb.png.d68095efeda1f1de29f01ebe96cb5925.png

image.thumb.png.63d8d0cf24ab10891f8cbf7444f2e53e.png

Solo me da este error, que ocurre?
image.png.265c8d6d54f0bdeae707998b19ec0e1d.png
 

Por que veo doble sprite?
image.png.2a6e71b71fac72a19d50b2fd828e1c38.png

Link to comment
Share on other sites

On 9/20/2020 at 3:50 PM, NicoAFV1212 said:

Descubri que es el EXE. donde yo no lo diffie esta conf con otros parametros, ahora mi problema es difear el exe, me tira un error cuando coloco las configuraciones recomendadas.

2018-06-20eRagexe 

257 Use Default Web Browser for <URL>
1 Use Tilde for Matk
258 Enable Shortcut All Item
3 Chat Flood Remove Limit
8 Custom Window Title
9 Disable 1rag1 type parameters (Recommended)
16 Disable Swear Filter
19 Enable Title Bar Menu
20 Extend Chat Box
277 Change RecommendedQuestInfoList*.lub path
21 Extend Chat Room Box
22 Extend PM Box
279 Fix item description bug
23 Enable /who command (Recommended)
24 Fix Camera Angles (Recommended)
28 Increase Headgear ViewID
286 Hide zero date (1969-01-01) in guild members window
287 Change character display deletion time from actual date to relative date
31 Increase Zoom Out 75%
289 Fix Homunculus attack AI
290 Hide build info in client (Recommended)
291 Hide packets from peek (Recommended)
36 Read msgstringtable.txt (Recommended)
293 Increase hair style limit for human only in game (old)
38 Remove Gravity Ads (Recommended)
39 Remove Gravity Logo (Recommended)
40 Restore Login Window (Recommended)
43 Always Use Email for Char Deletion
44 Translate Client (Recommended)
46 Use Normal Guild Brackets (Recommended)
47 Use Ragnarok Icon
48 Use Plain Text Descriptions (Recommended)
49 Enable Multiple GRFs (Recommended)
50 Skip License Screen
53 Use Ascii on All LangTypes (Recommended)
63 Use Official Cloth Palettes
64 @ Bug Fix (Recommended)
65 Load Custom lua file instead of iteminfo*.lub (Recommended)
69 Extend Npc Dialog Box
73 Remove Hourly Announce (Recommended)
76 Enforce Official Login Background
84 Remove Serial Display (Recommended)
86 Only First Login Background
88 Allow space in guild name
90 Enable DNS Support (Recommended)
115 Enable Effect for all Maps [Experimental]
205 Enable Monster Tables
212 Restore Roulette
213 Disable Help Message on Login (Recommended)
219 Always Show Resurrection Button
222 Show Replay Button
225 Show Register Button
229 Enable Emblem hover for BG
230 Always load Korea ExternalSettings lua file
239 Ignore /account: command line argument
241 Always Load Client Plugins [Experimental]
247 Change new char name field height
248 Remove wrong chars from cash shop
251 Allow close cutin by pressing esc key
253 Skip some hidden menu icon buttons
256 Use Default Web Browser In Cashshop

image.thumb.png.d68095efeda1f1de29f01ebe96cb5925.png

image.thumb.png.63d8d0cf24ab10891f8cbf7444f2e53e.png

Solo me da este error, que ocurre?
image.png.265c8d6d54f0bdeae707998b19ec0e1d.png
 

 

Estas tratando de parchar un exe con Gepard? No, cierto?

6 hours ago, NicoAFV1212 said:

Por que veo doble sprite?
image.png.2a6e71b71fac72a19d50b2fd828e1c38.png

Deberías organizar mejor tus archivos, al parecer has colocar el sprite del item, en vez de unos de los equipables...

Link to comment
Share on other sites

1 hour ago, Mael said:

Deberías organizar mejor tus archivos, al parecer has colocar el sprite del item, en vez de unos de los equipables...

No entiendo, yo puse los sprites de cada item. El del drop ¾ÆÀÌÅÛ , female y male (¾Ç¼¼»ç¸®).  A que te refieres con  "al parecer has colocar el sprite del item, en vez de unos de los equipables..." ( Que puse de forma equivocada los sprites donde deberian ir?)

Edited by NicoAFV1212
Link to comment
Share on other sites

14 minutes ago, NicoAFV1212 said:

No entiendo, yo puse los sprites de cada item. El del drop ¾ÆÀÌÅÛ , female y male (¾Ç¼¼»ç¸®).  A que te refieres con  "al parecer has colocar el sprite del item, en vez de unos de los equipables..." ( Que puse de forma equivocada los sprites donde deberian ir?)

Da la impresión...

Coloca porfa en un comentario el custom que quieres agregar y tus archivos lua. Lo implementaré por ti para que ubiques en qué te equivocaste.

Edited by Mael
Link to comment
Share on other sites

5 minutes ago, NicoAFV1212 said:

Agrega tu itemInfo_true_V5.lua

Link to comment
Share on other sites

@NicoAFV1212 Revisa cuidadosamente las últimas líneas de cada archivo y verás cómo se agregan.

accessoryid.lub

accname.lub

itemInfo_true_V5.lua

También agrega esto a tu item_db.txt

50000,Red_Scarf,Santa Scarf,4,20,,100,,0,,1,0xFFFFFFFE,7,2,1,,0,0,9000,{},{},{}

Al parecer no agregaste bien también el item drop, puedes conseguir los customs con sus todos archivos de aquí.

Te dejo la data organizada para que puedas ver cuál va y qué carpeta va.

data.zip

Link to comment
Share on other sites

1 minute ago, NicoAFV1212 said:

me funciono, pero no entiendo solo cambiaste la ID y ViewID, ademas de cambiar el nombre del sprite. Cual era mi error?

Los archivos que utilizabas no eran los adecuados, no estoy seguro si el id e idview, también lo era.

Por otro lado no sé si estabas utilizando iteminfo.lua, pero con clientes del 2018 en adelante se utiliza itemInfo_true_V5.lua

De todas formas creo que con eso ya logras ubicar cómo agregar items personalizados. Como recomendación utiliza ids altos, para que no malogres algún item ya existente.

Link to comment
Share on other sites

Lamento volver con malas noticias pero Cambie los sprites por que me di cuenta que los que yo tenia eran los malos. Puse los nuevos sprites de la pagina que neviaste y me anda todo bien menos a la hora de usar el item, me lo equipo y explota el juego jajajaja. Almenos ya se que todo se trata de sprites, muchas gracias por la ayuda
 

Link to comment
Share on other sites

I have followed all the steps and it has worked well for me, I only have a small problem, the items are not displayed in the character, does it have to do with the exe?

Please someone help me !

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy.