Jump to content
  • 0
CyberDevil

New Warlock Spell Books like an apple

Question

This is a strange problem because it is not about missing sprites, in fact I have no errors, but simply all the new Warlock books that you see in this link, are displayed as a simple apple with a description of the apple (not like an "Unknown Item") and by double clicking on it, it also appears the effect of the apple but obviously without any HP recharge and without disappearing, also the message "Can't read a Magic Book anymore." appears in the chat, which you also see in the attached screenshot. The tree apple that you see are the spell books with ID 100065, 100070 and 100074.
I'm not sure it could be a client problem (updated to the latest version from the git repository at https://github.com/llchrisll/ROenglishRE)... can anyone give me an explanation?

p.s.: my diffed ragexe is 2018-06-21aRagexeRE and my server is update at last git updates.

screenINFINITY068.jpg

Edited by CyberDevil

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0
2 hours ago, CyberDevil said:

This is a strange problem because it is not about missing sprites, in fact I have no errors, but simply all the new Warlock books that you see in this link, are displayed as a simple apple with a description of the apple (not like an "Unknown Item") and by double clicking on it, it also appears the effect of the apple but obviously without any HP recharge and without disappearing, also the message "Can't read a Magic Book anymore." appears in the chat, which you also see in the attached screenshot. The tree apple that you see are the spell books with ID 100065, 100070 and 100074.
I'm not sure it could be a client problem (updated to the latest version from the git repository at https://github.com/llchrisll/ROenglishRE)... can anyone give me an explanation?

p.s.: my diffed ragexe is 2018-06-21aRagexeRE and my server is update at last git updates.

2018-06-21 don`t support high item id, you need exe ragexe 2018-11-21 or ragexere 20180704

Edited by Balfear
  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Thanks @Balfear for the explanation but unfortunately I have serious problems with any version of ragexe higher than 2018-06-21, with Nemo (also updated) I cannot set the 3 encryption keys (see screenshots) that I have always used on my server, as well as other errors for others monor diffs but not important like these 3 keys.
Is there a version of Nemo that can allow me to add keys to a ragexe compatible with ultra high IDs?

1.png

Share this post


Link to post
Share on other sites
  • 0
3 hours ago, CyberDevil said:

Thanks @Balfear for the explanation but unfortunately I have serious problems with any version of ragexe higher than 2018-06-21, with Nemo (also updated) I cannot set the 3 encryption keys (see screenshots) that I have always used on my server, as well as other errors for others monor diffs but not important like these 3 keys.
Is there a version of Nemo that can allow me to add keys to a ragexe compatible with ultra high IDs?

Idk about encryption keys in new clients, try to ask about it  @4144, maybe he can help you.

Edited by Balfear

Share this post


Link to post
Share on other sites
  • 0
On 9/14/2020 at 7:28 PM, CyberDevil said:

Thanks @Balfear for the explanation but unfortunately I have serious problems with any version of ragexe higher than 2018-06-21, with Nemo (also updated) I cannot set the 3 encryption keys (see screenshots) that I have always used on my server, as well as other errors for others monor diffs but not important like these 3 keys.
Is there a version of Nemo that can allow me to add keys to a ragexe compatible with ultra high IDs?

1.png

Coz that client didn't use Packet Encrypt anymore

Share this post


Link to post
Share on other sites
  • 0

ok thanks for the information guys... in fact I have decided to not use the "packets obfuscation" system anymore but now I have a strage problem after the diff of any version of ragexe (late 2018, 2019 and 2020)... when I select the character, the client closes without errors but I think that the problem is in this file: https://github.com/llchrisll/ROenglishRE/blob/master/Ragnarok/System/mapInfo_true_EN.lub

If I exclude it from Nemo's options, I obviously get the error that it does not find the original file (mapInfo_true.lub) but anyway the game starts... I think the problem is the @llchrisll's file that maybe it was compiled wrong... @llchrisll can you help me?

Share this post


Link to post
Share on other sites
  • 0

UPDATE: the client closes only if I enter the towns and only if the "Dispay Map Name" option (that you see in the attached screenshot) is flagged... I guess the problem is due to the effect title with the name of the map (town) that should appear in the foreground when you enter but I don't know why it makes me close the client even if I have all the textures (rdata.grf and kRO data.grf updated), this is an example LINK.
Any idea to solve this?

screenTest-Server003.jpg

Edited by CyberDevil

Share this post


Link to post
Share on other sites
  • 0

Well I don't have any issue with that file at all:
Try to check your NEMO patch regarding MapInfo, and be sure to follow the guide on my wiki, especially the part with NEMO profiles.
If you really use my translation project that name of that file is mapInfo_True_EN.lub.
image.png.614ffd17656767a0dcec69435a904180.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy.