Jump to content
  • 0
LotusRO

2020 Client, Issues and questions

Question

So as our server is going further into development we've reached the point where we are trying to swap into the 2020 client and its been quite a road of obstacles so far to say the least.

1. Hotkeys are not saved for some reason? it says that it should save it Server side and there is an SQL table for this purpose but it appears to not get used?

2. they seem to have altered the tables in the lua/lub files in the grf, meaning you have to manually put in any change you've made to hte older client files

3. Trying to exit the game normally results in a disconnected from server?

4. It seems diffing the client is very limited, i realise its new and its not easy to make these things but it really limits usage a lot

 

So bottom line, anyone else experiecing these issues and / or know how to solve them? we would greatly appreciate input and help

Thank you in advance / Lotus RO

Share this post


Link to post
Share on other sites

18 answers to this question

Recommended Posts

  • 0
54 minutes ago, LotusRO said:

So as our server is going further into development we've reached the point where we are trying to swap into the 2020 client and its been quite a road of obstacles so far to say the least.

1. Hotkeys are not saved for some reason? it says that it should save it Server side and there is an SQL table for this purpose but it appears to not get used?

2. they seem to have altered the tables in the lua/lub files in the grf, meaning you have to manually put in any change you've made to hte older client files

3. Trying to exit the game normally results in a disconnected from server?

4. It seems diffing the client is very limited, i realise its new and its not easy to make these things but it really limits usage a lot

 

So bottom line, anyone else experiecing these issues and / or know how to solve them? we would greatly appreciate input and help

Thank you in advance / Lotus RO

 

Were you able to correct the problem of adding an emblem to the guild?

Share this post


Link to post
Share on other sites
  • 0

I have not experienced any of the other issues you have listed, but as far as the client lubs are concerned most of what they changed was just adding new functions, you can simply copy the functions from their lubs and put them into your lubs without need to manually paste your changes into a new file. You'd need to tell me what lubs you're trying to work with before I can help any further.

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

I'm using the 2020-04-01 client and I've just the issue part 3.
After using Exit to Windows, Disconnected from Server appears.
Unbenannt2.PNG.ab36f6dd1ff4b2776354cef8488439f0.PNGUnbenannt.PNG.2040f0703d5d7239180e79c4522e9403.PNG

Edited by WhiteEagle

Share this post


Link to post
Share on other sites
  • 0
12 hours ago, Panic said:

I have not experienced any of the other issues you have listed, but as far as the client lubs are concerned most of what they changed was just adding new functions, you can simply copy the functions from their lubs and put them into your lubs without need to manually paste your changes into a new file. You'd need to tell me what lubs you're trying to work with before I can help any further.

We have some custom pets and costumes that we want transfered over so its like the npcidentity and accessoryid and spriterobename etc, nothing super fancy but we still couldnt manage to get it to work without spewing out errors sadly

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, LotusRO said:

We have some custom pets and costumes that we want transfered over so its like the npcidentity and accessoryid and spriterobename etc, nothing super fancy but we still couldnt manage to get it to work without spewing out errors sadly

You'd have to show me a specific error, because neither one of those files was largely changed with the 2020 client.

 

You can reach out to me on Discord if you want me to help without needing to wait for forum replies. Panic#1463

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, Panic said:

You'd have to show me a specific error, because neither one of those files was largely changed with the 2020 client.

 

You can reach out to me on Discord if you want me to help without needing to wait for forum replies. Panic#1463

Hi Panic

In 2020 client, when disconnected, how to connect again without restarting the game?

Share this post


Link to post
Share on other sites
  • 0
On 8/3/2020 at 6:22 PM, LotusRO said:

So as our server is going further into development we've reached the point where we are trying to swap into the 2020 client and its been quite a road of obstacles so far to say the least.

1. Hotkeys are not saved for some reason? it says that it should save it Server side and there is an SQL table for this purpose but it appears to not get used?

2. they seem to have altered the tables in the lua/lub files in the grf, meaning you have to manually put in any change you've made to hte older client files

3. Trying to exit the game normally results in a disconnected from server?

4. It seems diffing the client is very limited, i realise its new and its not easy to make these things but it really limits usage a lot

 

So bottom line, anyone else experiecing these issues and / or know how to solve them? we would greatly appreciate input and help

Thank you in advance / Lotus RO


 

1. Hotkeys are not saved for some reason? it says that it should save it Server side and there is an SQL table for this purpose but it appears to not get used?

2. they seem to have altered the tables in the lua/lub files in the grf, meaning you have to manually put in any change you've made to hte older client files
Use clean Unpacked client so you can setup it on your own

3. Trying to exit the game normally results in a disconnected from server?
This is not a problem if you use a unpacked client "Clean Client" . Because you are the one that select which or what features of client do you want.

4. It seems diffing the client is very limited, i realise its new and its not easy to make these things but it really limits usage a lot
Use 4441 nemo-master client . 

Share this post


Link to post
Share on other sites
  • 0
17 hours ago, Poring King said:


 

1. Hotkeys are not saved for some reason? it says that it should save it Server side and there is an SQL table for this purpose but it appears to not get used?

2. they seem to have altered the tables in the lua/lub files in the grf, meaning you have to manually put in any change you've made to hte older client files
Use clean Unpacked client so you can setup it on your own

3. Trying to exit the game normally results in a disconnected from server?
This is not a problem if you use a unpacked client "Clean Client" . Because you are the one that select which or what features of client do you want.

4. It seems diffing the client is very limited, i realise its new and its not easy to make these things but it really limits usage a lot
Use 4441 nemo-master client . 

Thank you for your response but all issues has been resolved already 🙂

 

Share this post


Link to post
Share on other sites
  • 0

I try to test 2020-04-01bRagexe with last rathena
Why can not connect to map server? Disconnect after select character.
But 2020-03-04 working it sam driff.

 

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

Does anyone have problem with skill tab? Mine got crashed, but everything else seems fine.

Edit: I don't know why many people are having the login error bcs I am not. If your client has the similar problem like mine with Skill Tab, I posted this : 

https://rathena.org/board/topic/125755-solved-how-i-run-the-20200603-client/

Cheers

 

Edited by eduardoxmenezes
  • Like 1

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)
19 hours ago, eduardoxmenezes said:

Does anyone have problem with skill tab? Mine got crashed, but everything else seems fine.

Edit: I don't know why many people having the login error bcs I am not. If your client has the similar problem like mine with Skill Tab, I posted this : 

https://rathena.org/board/topic/125755-solved-how-i-run-the-20200603-client/

Cheers

 

You need to update your skillinfoz in your main grf you can use our search engine to find

Here @eduardoxmenezes
 


 

Edited by Poring King
  • Upvote 1

Share this post


Link to post
Share on other sites
  • 0

Why using 20200401 all npc, warp point and monster not appear.

Spoiler

screenrAthena044.thumb.jpg.330cd823b14582b64e13041ed0d88c31.jpg

here my diff option

Spoiler
Quote

2 Chat Flood Allow
6 Force Send Client Hash Packet
8 Custom Window Title
9 Disable 1rag1 type parameters (Recommended)
268 Restore chat focus
270 Change AchievementList*.lub path
271 Change MonsterSizeEffect*.lub path
272 Change Towninfo*.lub path
16 Disable Swear Filter
273 Change PetEvolutionCln*.lub path
274 Change Tipbox*.lub path
275 Change CheckAttendance*.lub path
19 Enable Title Bar Menu
276 Change OngoingQuestInfoList*.lub path
277 Change RecommendedQuestInfoList*.lub path
278 Change PrivateAirplane*.lub path
23 Enable /who command (Recommended)
24 Fix Camera Angles (Recommended)
28 Increase Headgear ViewID
290 Hide build info in client (Recommended)
34 Enable /showname (Recommended)
291 Hide packets from peek (Recommended)
35 Read Data Folder First
36 Read msgstringtable.txt (Recommended)
38 Remove Gravity Ads (Recommended)
39 Remove Gravity Logo (Recommended)
41 Disable Nagle Algorithm (Recommended)
43 Always Use Email for Char Deletion
44 Translate Client (Recommended)
46 Use Normal Guild Brackets (Recommended)
47 Use Ragnarok Icon
48 Use Plain Text Descriptions (Recommended)
49 Enable Multiple GRFs (Recommended)
51 Always Show License Screen
53 Use Ascii on All LangTypes (Recommended)
317 Ignore Quest Errors
64 @ Bug Fix (Recommended)
65 Load Custom lua file instead of iteminfo*.lub (Recommended)
71 Ignore Resource Errors
72 Ignore Missing Palette Error
73 Remove Hourly Announce (Recommended)
76 Enforce Official Login Background
84 Remove Serial Display (Recommended)
86 Only First Login Background
88 Allow space in guild name
90 Enable DNS Support (Recommended)
91 Disconnect to Login Window
101 Skip Friend list Cheat Check
102 Skip Guild Member Cheat Check
115 Enable Effect for all Maps [Experimental]
212 Restore Roulette
213 Disable Help Message on Login (Recommended)
214 Restore Model Culling
215 Increase Map Quality
230 Always load Korea ExternalSettings lua file
231 Remove hardcoded address/port (Recommended)
232 Restore old login packet (Recommended)
234 Ignore Lua Errors
244 Disable Cheat Defender Game Guard (Recommended)
246 Increase hair style limit in game
248 Remove wrong chars from cash shop
249 Change minimal screen resolution limit
256 Use Default Web Browser In Cashshop
 

 

Is this problem related to translation client files?

because i'm still using zack translation files. But my KRO using lastest update.

Is there any new translation project support for 2020 client?

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)
5 hours ago, Poring King said:

You need to update your skillinfoz in your main grf you can use our search engine to find

Here @eduardoxmenezes
 


 

Thank you, Yes, it's solved now. I also managed by combining files from grf & Translation Project. I found that for example Feint Bomb is maxed to 10 levels, although still listed as max 3 level on Translation. Have fun!

@hendra814, check my post: 

 

Edited by eduardoxmenezes

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)
3 hours ago, eduardoxmenezes said:

Thank you, Yes, it's solved now. I also managed by combining files from grf & Translation Project. I found that for example Feint Bomb is maxed to 10 levels, although still listed as max 3 level on Translation. Have fun!

@hendra814, check my post: 

 

what did you do in step 4 and 6 ?

could you detail it?

i'm still using zack translation files, because i'm not found any translation files for 2020 client and newer.

is client suppose to use read grf instead of read data folder first?

Edited by hendra814

Share this post


Link to post
Share on other sites
  • 0

@hendra814

I use chris' translation, meaning that I put  llchrisll Translation Project Ragnarok folder's contents to my own folder. I don't know if this works too with Zack's Translation folder.

Well, in grf, we'll see Korean language version of all things. That's why to override this, we intercept with "Read data folder first" from chris.

Share this post


Link to post
Share on other sites
  • 0
4 hours ago, eduardoxmenezes said:

@hendra814

I use chris' translation, meaning that I put  llchrisll Translation Project Ragnarok folder's contents to my own folder. I don't know if this works too with Zack's Translation folder.

Well, in grf, we'll see Korean language version of all things. That's why to override this, we intercept with "Read data folder first" from chris.

could you share the link for ||chris|| Traslation Project Ragnarok,

and btw i'm use you nemo option

But i can't enter the game, always failed after entering password.

could you please recheck your nemo option too?

Share this post


Link to post
Share on other sites
  • 0

@hendra814,

https://github.com/llchrisll/ROenglishRE

Like i've said earlier, I completely have no idea about login failure. However, as far as I remember, I also upgraded the SQL database (execute/import sql upgrade files on sql-files folder from the github). Some SQLs are failed too (or execute nothing).

5 Enable Proxy Support
9 Disable 1rag1 type parameters (Recommended)
13 Disable Ragexe Filename Check (Recommended)
24 Fix Camera Angles (Recommended)
290 Hide build info in client (Recommended)
34 Enable /showname (Recommended)
291 Hide packets from peek (Recommended)
35 Read Data Folder First
36 Read msgstringtable.txt (Recommended)
38 Remove Gravity Ads (Recommended)
39 Remove Gravity Logo (Recommended)
41 Disable Nagle Algorithm (Recommended)
44 Translate Client (Recommended)
46 Use Normal Guild Brackets (Recommended)
48 Use Plain Text Descriptions (Recommended)
49 Enable Multiple GRFs (Recommended)
50 Skip License Screen
53 Use Ascii on All LangTypes (Recommended)
313 Change MapInfo*.lub path
317 Ignore Quest Errors
320 Ignore Towninfo*.lub Reading
64 @ Bug Fix (Recommended)
65 Load Custom lua file instead of iteminfo*.lub (Recommended)
71 Ignore Resource Errors
72 Ignore Missing Palette Error
73 Remove Hourly Announce (Recommended)
84 Remove Serial Display (Recommended)
90 Enable DNS Support (Recommended)
231 Remove hardcoded address/port (Recommended)
232 Restore old login packet (Recommended)
234 Ignore Lua Errors
239 Ignore /account: command line argument

 

I think, the reason why some ppl have different errors on NEMO, it's caused by different NEMO and/or different client exe file. It might be there's several ways to pass through, until we can play the client on our own PC.

Edited by eduardoxmenezes

Share this post


Link to post
Share on other sites
  • 0
On 9/1/2020 at 8:46 AM, eduardoxmenezes said:

@hendra814,

https://github.com/llchrisll/ROenglishRE

Like i've said earlier, I completely have no idea about login failure. However, as far as I remember, I also upgraded the SQL database (execute/import sql upgrade files on sql-files folder from the github). Some SQLs are failed too (or execute nothing).

5 Enable Proxy Support
9 Disable 1rag1 type parameters (Recommended)
13 Disable Ragexe Filename Check (Recommended)
24 Fix Camera Angles (Recommended)
290 Hide build info in client (Recommended)
34 Enable /showname (Recommended)
291 Hide packets from peek (Recommended)
35 Read Data Folder First
36 Read msgstringtable.txt (Recommended)
38 Remove Gravity Ads (Recommended)
39 Remove Gravity Logo (Recommended)
41 Disable Nagle Algorithm (Recommended)
44 Translate Client (Recommended)
46 Use Normal Guild Brackets (Recommended)
48 Use Plain Text Descriptions (Recommended)
49 Enable Multiple GRFs (Recommended)
50 Skip License Screen
53 Use Ascii on All LangTypes (Recommended)
313 Change MapInfo*.lub path
317 Ignore Quest Errors
320 Ignore Towninfo*.lub Reading
64 @ Bug Fix (Recommended)
65 Load Custom lua file instead of iteminfo*.lub (Recommended)
71 Ignore Resource Errors
72 Ignore Missing Palette Error
73 Remove Hourly Announce (Recommended)
84 Remove Serial Display (Recommended)
90 Enable DNS Support (Recommended)
231 Remove hardcoded address/port (Recommended)
232 Restore old login packet (Recommended)
234 Ignore Lua Errors
239 Ignore /account: command line argument

 

I think, the reason why some ppl have different errors on NEMO, it's caused by different NEMO and/or different client exe file. It might be there's several ways to pass through, until we can play the client on our own PC.

Using Chris translation files, it's make me can't entering map server

2020-09-03_075030.gif.f2ad7d305711d7ba0fac1c374bdc3100.gif

still confuse with this client setting.

 

Note: all work normal now, already found the problem.

Edited by hendra814
already fix the problem
  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy.