• 0
Skyzone

Flux Donation to Paypal

Question

Hello rADevs

I have problem on my Donation Payment.

I configure application.php already
'PayPalIpnUrl'                => 'www.paypal.com',
and already set my IPN on paypal.

Notification URL https://myro.com/donate/notify

I receive the payment on paypal but the player don't receive there credits.
is there enything to configured?

Im using latest Flux. 

Edited by Skyzone

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0
3 hours ago, Hnomkeng said:

player can refund everytime ?

the Credit? yes I make NPC to redeem the Credit inside the server

Share this post


Link to post
Share on other sites
  • 0
On 8/14/2019 at 6:22 AM, Skyzone said:

FIXED

Can you tell me how to fix it?thanks

Share this post


Link to post
Share on other sites
  • 0

It would be very thoughtful to take other users facing the same issue into consideration, so please when a problem has been resolved, kindly include how you fixed it instead of just a simple 'FIXED'. That doesn't help anyone else. 😕

@Chadev - Since I ran into this a while ago, these are the steps I took to resolve it:

  1. Ensure your IPN is enabled for your donation receiving e-mail, by taking the following steps: https://www.jotform.com/help/276-How-to-Enable-IPN-on-your-Paypal-Account
  2. Double check in application.php if you're using www.paypal.com instead of PayPal sandbox.
  3. Confirm that your PayPal account has been verified through e-mail and make the necessary edits in your profile to set it to business account instead of personal.
  4. In application.php, include your other accounts. In my case... :
        'PayPalBusinessEmail'        => '[email protected]',       <- This is my primary/business email.
        'PayPalReceiverEmails'        => array(                   
            '[email protected]',     <- This is another accounts/login connected to my PayPal. Add them all.

Step 4 was the culprit for me.

Good luck!

  • Upvote 1
  • Love 2

Share this post


Link to post
Share on other sites
  • 0
On 12/14/2019 at 10:30 AM, Najara said:

It would be very thoughtful to take other users facing the same issue into consideration, so please when a problem has been resolved, kindly include how you fixed it instead of just a simple 'FIXED'. That doesn't help anyone else. 😕

@Chadev - Since I ran into this a while ago, these are the steps I took to resolve it:

  1. Ensure your IPN is enabled for your donation receiving e-mail, by taking the following steps: https://www.jotform.com/help/276-How-to-Enable-IPN-on-your-Paypal-Account
  2. Double check in application.php if you're using www.paypal.com instead of PayPal sandbox.
  3. Confirm that your PayPal account has been verified through e-mail and make the necessary edits in your profile to set it to business account instead of personal.
  4. In application.php, include your other accounts. In my case... :
        'PayPalBusinessEmail'        => '[email protected]',       <- This is my primary/business email.
        'PayPalReceiverEmails'        => array(                   
            '[email protected]',     <- This is another accounts/login connected to my PayPal. Add them all.

Step 4 was the culprit for me.

Good luck!

Hi

I am having trouble receiving points with PayPal. With the production method I can make the payment and return me to the site, but I do not receive the points.

With the sandbox method I get to a part where PayPal sends a 505 Internal Server Error

I have followed the steps you have recommended

I have no idea what I am doing wrong, or if it is a CP error. I didn't want to open a ticket on GitHub because I want to make sure that more people have the same problem.

Best regards.

Share this post


Link to post
Share on other sites
  • 0
On 8/13/2019 at 7:22 PM, Skyzone said:

FIXED.
It was just HTTP'S problem and to make sure to fixed all error logs on your data/logs Folder. after your fixed all in logs login your gm account on your site and find the Re Install.

 
 

What do you mean with HTTPS? I removed everything and reinstalled FluxCP from scratch, I disabled Cloudflare and left Let's Encrypt activated instead. Now the accounts receive the credits and a log is stored. The problem is that I still receive Server Internal Error from PayPal.

In the paypal log I receive the following error:


[2020-01-19 06:04:10] Updating account credit balance from 10 to 27
[2020-01-19 06:04:11] Deposited credits.
[2020-01-19 06:04:11] Saving transaction details to PayPal transactions table ...
[2020-01-19 06:04:11] Stored information in PayPal transactions table for server ServerRO
[2020-01-19 06:04:11] Saving transaction details for 4YS22613E7748662K ...
[2020-01-19 06:04:11] Failed to save transaction details for 4YS22613E7748662K to file.
[2020-01-19 06:04:11] Done processing 4YS22613E7748662K.

 




I changed .htaccess to:

RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule !\.(js|ico|gif|jpg|png|css|pdf|swf|flv)$ index.php [QSA]


I changed the IPN in the sandbox business account to:
https://fluxcp.com/donate/notify


In config / application.php, I use:
'UseCleanUrls' => true, // Set to true if you're running Apache and it supports mod_rewrite and .htaccess files.
'PayPalIpnUrl' => 'ipnpb.sandbox.paypal.com', // The ipnpb.paypal.com and ipnpb.sandbox.paypal.com endpoints only accept HTTPS connections. If you currently use www.paypal.com, you should move to ipnpb.paypal.com when you update your code to use HTTPS.
'PayPalBusinessEmail' => '[email protected]', // Enter the e-mail under which you have registered your business account.

I don't know what I could be doing wrong, I tried everything. When I occupy Sandbox I get:
 
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Apache Server at www.sandbox.paypal.com Port 443

 

 

 

 

Regards

 

 

Edited by Dark Lunacy

Share this post


Link to post
Share on other sites
  • -1
I do not recommend using paypal, there is a lot of cashback and as "cash" is a non tangible product, it is 100% win for the player.

I recommend using pagseguro or any other online company.

Share this post


Link to post
Share on other sites
  • -3

FIXED.
It was just HTTP'S problem and to make sure to fixed all error logs on your data/logs Folder. after your fixed all in logs login your gm account on your site and find the Re Install.

Edited by Skyzone

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...