• 0
thunginamue

client crash or poring after adding custom mobs? here try this

Question

I don't know where to put this so i put it here, i'm new here tho and i'm new to creating server and new to scripting and everything but i'm making my own server and fixing it my own etc so here it is.

1. after adding your custom mobs your client crash.

2. it shows poring.

fix:

1.find this both NPCIdentity.lub, jobname.lub at data/luafiles514/lua files/datainfo

2.find this both npcidentity.lub, jobname.lub at data/luafiles514/lua files/datainfo

3.they are located in different GRF, just like mine.(maybe client crash because you put you custom mob in the  other but you didnt put in the other, maybe this applies to old client mine is 2015)

look for that 4 files separate them in each folder for they overwrite each other. because they dont have the same content on it, it will break ur server if you overwrite those, so be careful on adding them, just add ur custom mob in those 4 files accordingly, they have different types of encoding so follow that in every file..

then ur good to go :3

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Your should just only edit your custom grf. No need to edit the others for a custom mob. :)) since your own custom grf is always first priority.

 

Share this post


Link to post
Share on other sites
  • 0

as for my client it detects all i tried puting only at my custom.grf already client crashes, i tried just putting in data.grf still crashes client or poring, then when i put all 4 of it, it fixes everything, all 4 of them have different encoding only jobname.lua is same but NPCIdentity.lub and npcidentity.lub is different, but even tho jobname.lub is same if i dont put the mob in the other client still crashes..
so thats why i posted it , maybe someone is having a client like mine, and a problem like mine..

Share this post


Link to post
Share on other sites
  • 0

In some reasons the new lua functions causes errors. I just replaced the npcidentify_f.lub and jobname_f.lub with an old 2013 lua function file and everything is working.

 

Rynbef~

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now