• 0
Sign in to follow this  
Sumi

PlayBGMAll Question... (Updated)

Question

Can the PlayBGMAll command only play the default 01.mp3 - 997.mp3 files on the BGM folder? Because I tried adding my own mp3 music to the BGM folder, renamed it then wrote its name on the script. It doesn't seem to play it.

 

Is there a required bitrate or tag on the mp3 somewhere or can PlayBGMAll really only play the default files that was already on the BGM folder?

Also it can't be the script because I tried changing it to 01.mp3 (the intro bgm) and it worked, it just doesn't work with the custom ones I've added.

 

(was kinda planning on making a DJ player NPC where I'll just push the custom mp3 files as a patch every time)

 

UPDATE: Nevermind, doesn't work. I tried with 128kbps/44.1khz, 128kbps/22.05khz, 96kbps/44.1khz and 96kbps/22.05khz.

I tried 96kbps since I also found some BGM MP3's on the folder at that bitrate, and some at 22.05khz as well.

Welp, I'm out of ideas.

Edited by Sumi

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

I tested custom BGM and seems works fine. Maybe you put the song name with the extension, playBGMall "bio5.mp3"; and should be playBGMall "bio5";

Share this post


Link to post
Share on other sites
  • 0

I lurked all around here and got to the part where you don't have to put the extension, although I didn't find any posts that it required 128kbps.

 

(since I was going to put many songs on a patch, I went with as low as a bitrate as possible. didn't know it required 128kbps, how arbitrary.)

 

this should work, thanks. I'll test it later.

 

UPDATE: Nevermind, doesn't work. I tried with 128kbps/44.1khz, 128kbps/22.05khz, 96kbps/44.1khz and 96kbps/22.05khz.

I tried 96kbps since I also found some BGM MP3's on the folder at that bitrate, and some at 22.05khz as well.

Welp, I'm out of ideas.

Edited by Sumi

Share this post


Link to post
Share on other sites
  • 0

to make sure what the problem you have

copy and rename an official music from the client , and play it with the new name in the command

if it work (it will) than something wrong with the file you are trying to add

if it didn't work, tell us here

Edited by sader1992

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this