MathReaper

[PACKETVER 20180620] Client Release 2018-06-20eRagexeRE

Recommended Posts

The rAthena have changed the default PACKETVER to 20180620 because we support all required features or have them on some pull requests in the Git repository and because of that I'm releasing this client. That's all.

Important Note: This client uses sclientinfo.xml instead of clientinfo.xml.

 

Download link: 2018-06-20eRagexeRE.exe (MediaFire).

Edited by MathReaper
  • Upvote 3
  • MVP 1

Share this post


Link to post
Share on other sites

Hi, i don't know if someone have this same issue, but when i diff a 2018 client (i'm using 4144 nemo) with the default recommend patches, my client always close when it's enter to the character selector.

I tested using a diffed client that someone put here in the forum, and works fine.

Share this post


Link to post
Share on other sites

Works fine to me.

Spoiler

dd63Acc.png

9iIgWBu.png

My NEMO's profile:

Spoiler

3 Chat Flood Remove Limit
6 Force Send Client Hash Packet
8 Custom Window Title
9 Disable 1rag1 type parameters (Recommended)
13 Disable Ragexe Filename Check (Recommended)
16 Disable Swear Filter
17 Enable Official Custom Fonts
18 Skip Service Selection Screen
20 Extend Chat Box
21 Extend Chat Room Box
22 Extend PM Box
23 Enable /who command (Recommended)
24 Fix Camera Angles (Recommended)
32 Increase Zoom Out Max
33 Always Call SelectKoreaClientInfo() (Recommended)
34 Enable /showname (Recommended)
36 Read msgstringtable.txt (Recommended)
38 Remove Gravity Ads (Recommended)
39 Remove Gravity Logo (Recommended)
40 Restore Login Window (Recommended)
41 Disable Nagle Algorithm (Recommended)
43 Always Use Email for Char Deletion
44 Translate Client (Recommended)
46 Use Normal Guild Brackets (Recommended)
303 Use Default Web Browser In Cashshop
47 Use Ragnarok Icon
304 Use Default Web Browser for <URL>
48 Use Plain Text Descriptions (Recommended)
305 Enable Shortcut All Item
49 Enable Multiple GRFs (Recommended)
50 Skip License Screen
53 Use Ascii on All LangTypes (Recommended)
61 Disable Packet Encryption
64 @ Bug Fix (Recommended)
65 Load Custom lua file instead of iteminfo*.lub (Recommended)
69 Extend Npc Dialog Box
71 Ignore Resource Errors
72 Ignore Missing Palette Error
73 Remove Hourly Announce (Recommended)
74 Increase Screenshot Quality
76 Enforce Official Login Background
84 Remove Serial Display (Recommended)
86 Only First Login Background
88 Allow space in guild name
90 Enable DNS Support (Recommended)
91 Disconnect to Login Window
97 Cancel to Login Window (Recommended)
103 Disable Auto follow
208 Restore Cash Shop Icon
213 Disable Help Message on Login (Recommended)
229 Enable Emblem hover for BG
239 Ignore /account: command line argument
246 Increase hair style limit in game
248 Remove wrong chars from cash shop
251 Allow close cutin by pressing esc key
 

 

Edited by MathReaper

Share this post


Link to post
Share on other sites

Maybe it's a problem with my current nemo patcher, because i used your current patchlog, and the problem persist.

i'll try to redownload it

btw, can you provide me your diffed client?

Edited by fictionx

Share this post


Link to post
Share on other sites

Make sure you're using all correct DLL and SYS files from kRO and have the latest updates in your rdata.grf.

If this happens only in the Character Selection, probably your GRF is outdated or you are using a different LangType than 0 and aren't updating the "service_(langtype)" in your luafiles.

Try enabling the patch "Always load Korea ExternalSettings lua file" in your client.

Edited by MathReaper

Share this post


Link to post
Share on other sites

i'm using 2018 client version of ragnarok (i'm using this one). Other client that isn't manually patched by me, worked fine. The problem exist, when i diff by my self using nemo.

10 minutes ago, MathReaper said:

Make sure you're using all correct DLL and SYS files from kRO and have the latest updates in your rdata.grf.

If this happens only in the Character Selection, probably your GRF is outdated or you are using a different LangType than 0 and aren't updating the "service_(langtype)" in your luafiles.

Try enabling the patch "Always load Korea ExternalSettings lua file" in your client.

I didn't change the current LangType, and try using your recommended patch, but didn't work. The client auto close when i enter to the character selector.

Edited by fictionx

Share this post


Link to post
Share on other sites

I've patched one for you using 4144 Nemo's fork.

All recommended patches are enabled and I've enabled the "Disable Packet Encryption" by myself, so make sure your server have packet obfuscation disabled on Config/packets.hpp.

2018-06-20eRagexeRE Patched

Edited by MathReaper

Share this post


Link to post
Share on other sites

cool. maybe ill try using it later thanks

Edited by Myth

Share this post


Link to post
Share on other sites
3 minutes ago, musica2 said:

how do we put custom ip address? i mean if i want to open a small group server.

After a few client releases from Gravity, the clients starts using sclientinfo.xml instead of clientinfo.xml. The structre of the xml is the same, just rename your clientinfo.xml to sclientinfo.xml.

Share this post


Link to post
Share on other sites
3 hours ago, MathReaper said:

I've patched one for you using 4144 Nemo's fork.

All recommended patches are enabled and I've enabled the "Disable Packet Encryption" by myself, so make sure your server have packet obfuscation disabled on Config/packets.hpp.

2018-06-20eRagexeRE Patched

that patch read data folder included?

Share this post


Link to post
Share on other sites
3 minutes ago, musica2 said:

that patch read data folder included?

Nope. I don't recommend you to use that patched client. Use the unpatched one and patch by yourself using 4144 NEMO's fork.

Share this post


Link to post
Share on other sites

so in this 2018 ragexe..

where the default sclientinfo path is? inside data/rdata.grf? or do we manually put it in and set a custom ip..?

if i put sclientinfo inside data folder, shld i enable 'load custom clientinfo' anyway?

( i'm currently using 2015 ragexe and it worked out fine with 'read data folder' with custom ip inside clientinfo.xml) - with 'custom' grf

eg below is currently still working

[Data]
0=custom.grf
1=rdata.grf
2=data.grf

but..

i cant get this 2018 ragexe working so far with preferable setting.

Thx i think some1 could explain?

 

btw i have this version working without any conflict

but still i need a customable ip for a multi client/player purposes. and of course something has to be done with its ragexe setup.

Edited by musica2

Share this post


Link to post
Share on other sites
2 minutes ago, musica2 said:

so in this 2018 ragexe..

where the default sclientinfo path is? inside data/rdata.grf? or do we manually put it in and set a custom ip..?

if i put sclientinfo inside data folder, shld i enable 'load custom clientinfo' anyway?

( i'm currently using 2015 ragexe and it worked out fine with 'read data folder' with custom ip inside clientinfo.xml) - with 'custom' grf

eg below is currently still working

[Data]
0=custom.grf
1=rdata.grf
2=data.grf

but..

i cant get this 2018 ragexe working so far with preferable setting.

Thx i think some1 could explain?

The path is inside one GRF (you don't need a specific name for it) or your data folder if you enabled Read Data Folder First patch. Just rename your clientinfo to sclientinfo and will work just as fine.

If you're already using sclientinfo.xml you don't need to enable Load Custom Clientinfo patch.

 

Just drop your clientinfo inside your data folder or one of your GRFs, whatever. Just make sure to rename it to sclientinfo. That's all.

Share this post


Link to post
Share on other sites
17 minutes ago, musica2 said:

this is what i get, cant even get into character selection =/

s.png

My sclientinfo.xml:

Spoiler

VCmSyYN.png

 

6 minutes ago, Quesooo said:

@MathReaper boss if you dont mind please upload a working full client thank you ^_^ english version

I can't. My internet is too slow to upload a file with 2,7gbs.

Share this post


Link to post
Share on other sites

@musica2 Can you send me your NEMO's patch log?

If you don't mind, send here your sclientinfo (or clientinfo) without your custom IP (change it to local host for security reasons) and your current path inside your RO files.

Share this post


Link to post
Share on other sites
38 minutes ago, MathReaper said:

@musica2 Can you send me your NEMO's patch log?

If you don't mind, send here your sclientinfo (or clientinfo) without your custom IP (change it to local host for security reasons) and your current path inside your RO files.

here, idk if its server side packetversion or clientside (grf/datafolder/ragexe setup) causing that problem.

sclientinfo.xml

Share this post


Link to post
Share on other sites
3 minutes ago, musica2 said:

here, idk if its server side packetversion or clientside (grf/datafolder/ragexe setup) causing that problem.

sclientinfo.xml

Everything ok with your sclientinfo.

Make sure that you have only that sclientinfo in all your files (GRF/DATA FOLDER) and don't enable any other NEMO's patch if isn't recommended and make a test.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now