Hurtsky

FluxCP Theme: FluxCP Theme:[FREE] [RESPONSIVE] Hurt Free Theme 2nd

Recommended Posts

FluxCP Theme:[FREE] [RESPONSIVE] Hurt Free Theme 2nd


FluxCP Responsive Theme base on Bulma.io

This fluxCP only compatible with rAthena FluxCP = https://github.com/rathena/FluxCP

DEMO LINK HERE >>> CLICK HERE <<<

[ WHEN VISITING THE LINK PLEASE CHANGE THE THEME TO = hurtFreeV2 = FOR THIS THEME ]

Quote

 

#ADDED FEATURES

- Invisible google recaptcha for infront page login

- showcase slideshow

- social network icons

 

you can login the page using this:-

admin:-

username = test
password = test

normal user:-

username = test2
password = test

Come with Easy config ./themes/hurtFreeV2/config/hurtsky_settings.php

    'yourServerName'                => 'Hurtsky',                                    //this name maybe will be use on top and footer
    'newsTitleLimit'                => 10,                                            //this will limit character/letter in title of RSS
    'newsContentLimit'              => 100,                                            //this will limit character/letter in content of RSS
    'enableSocialNetworkLink'       => true,                                        //disable this will remove the get connected section
    'enableFacebookIcon'            => true,
    'facebookLink'                  => 'https://hurtsky.com/FluxCP',
    'enableDiscordIcon'             => true,
    'discordInviteLink'             => 'https://hurtsky.com/FluxCP',
    'enableTwitterIcon'             => true,
    'twitterLink'                   => 'https://hurtsky.com/FluxCP',
    'footerCopyrightTrademarkLable' => 'All trademarks referenced herein are the properties of their respective owners',
    'footerCopyrightInitialDate'    => 2017,

How to install:

1. place the folder under ./theme/

2. open file ./config/application.php

3. change 
 

'ThemeName'                    => array('default','bootstrap'),

to 

'ThemeName'                    => array('hurtFreeV2'),

4. for WOE status, you need to import this SQL file to database = woe_status.sql 

5. also add this NPC script to your emulator = woe_status.txt

6. done

 

THIS FREE THEME PROVIDED AS IT

 NO SUPPORT COME WITH IT

 USE IT AT YOUR OWN RISK

Quote

FluxCP theme by Hurtsky ( https://github.com/hurtsky )
By downloading this file, you agree to my Terms of Service:
You are not allowed sell, resell or in any form of money or rewards using my work.
You are not allowed claim my work as yours.
I have the rights to change all the terms above without prior notice.


 

  • Upvote 1
  • Like 1

Share this post


Link to post
Share on other sites

change the green background to the image.

And fixed background

Edited by Visual

Share this post


Link to post
Share on other sites
11 minutes ago, Visual said:

change the green background to the image.

And fixed background

what you means?

Share this post


Link to post
Share on other sites
26 minutes ago, Hurtsky said:

what you means?

Background image function:    background-attachment:fixed;

and emperium time background (green) change on image

Share this post


Link to post
Share on other sites
6 minutes ago, Visual said:

Background image function:    background-attachment:fixed;

and emperium time background (green) change on image

huh, i still dont get it. you do change? or what? or that theme got error?

Share this post


Link to post
Share on other sites

send me with style.css background code

Edited by Visual

Share this post


Link to post
Share on other sites

nice! Background fix. Now change the background on images. Photoshop open and forward.

*and logo fix pos.

Безымянный.png

Edited by Visual

Share this post


Link to post
Share on other sites
.notification.is-primary {
  1. /* background-color: #00d1b2; */
  2. background: url (https://img00.deviantart.net/c919/i/2015/356/2/9/commission___ro_fan_art_by_sa_dui-d9l429d.jpg) bottom no-repeat;
  3. color: #fff;
}

Share this post


Link to post
Share on other sites
14 hours ago, Visual said:

send me with style.css background code

 

14 hours ago, Visual said:

nice! Background fix. Now change the background on images. Photoshop open and forward.

*and logo fix pos.

Безымянный.png

 

10 hours ago, Visual said:
.notification.is-primary {
  1. /* background-color: #00d1b2; */
  2. background: url (https://img00.deviantart.net/c919/i/2015/356/2/9/commission___ro_fan_art_by_sa_dui-d9l429d.jpg) bottom no-repeat;
  3. color: #fff;
}

its nothing to fix, it is intended to be like that, see the demo site. anyway thanks for the suggestion 🙂

Edited by Hurtsky

Share this post


Link to post
Share on other sites

I've recently installed the most up to date version of hurtFreeV2 -
If you browse the website, it automatically reverts to Quirks Render Mode because it renders without:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
	"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

The nav bar at the top is improperly located and loses its formatting with a background.
The nav bar for the server status eliminates <nav></nav> coding and stacks instead of spreading out.
The login php at the bottom left does not include a "Log In" button to login unless you enable recaptcha... which requires inputting a code, contrary to the design of the website update you last performed.
The images for social media are missing.

For an example of what I am talking about: select the hurtFreeV2 Theme on my server's website:
http://www.ragnarok.lunarpumpkin.com

Thanks!

Regards,
Bobby

*Edit:
I have the most up to date version of FluxCP
I've tried multiple versions of PHP all the way up to 7.0

Edited by bob9497
Additional Information

Share this post


Link to post
Share on other sites
7 hours ago, bob9497 said:

I've recently installed the most up to date version of hurtFreeV2 -
If you browse the website, it automatically reverts to Quirks Render Mode because it renders without:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
	"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

The nav bar at the top is improperly located and loses its formatting with a background.
The nav bar for the server status eliminates <nav></nav> coding and stacks instead of spreading out.
The login php at the bottom left does not include a "Log In" button to login unless you enable recaptcha... which requires inputting a code, contrary to the design of the website update you last performed.
The images for social media are missing.

For an example of what I am talking about: select the hurtFreeV2 Theme on my server's website:
http://www.ragnarok.lunarpumpkin.com

Thanks!

Regards,
Bobby

*Edit:
I have the most up to date version of FluxCP
I've tried multiple versions of PHP all the way up to 7.0

what i can only confirm is just the login button problem. the others im not sure why its happen to you.

Share this post


Link to post
Share on other sites

Hello Mr.@Hurtsky  

Thank you for this theme , 

I only have 1 missing thing ( The login button )

09902731ca004b87faddec9fe8af6fd57c8c70e4

Share this post


Link to post
Share on other sites
16 minutes ago, Diana said:

Hello Mr.@Hurtsky  

Thank you for this theme , 

I only have 1 missing thing ( The login button )

09902731ca004b87faddec9fe8af6fd57c8c70e4

 

you need to enable captcha for that.

Share this post


Link to post
Share on other sites

@Hurtsky

I don't like using captcha , Please can you tell me how to remove captcha verification

also I enabled invisible reCaptcha  when I entered sign in it won't sign in 

Share this post


Link to post
Share on other sites

Diana,

For you and others in the future ---

I was having a similar issue, but resolved it.

Did you get your keys from google and put them in your settings?
 

GO HERE:

https://developers.google.com/recaptcha/intro

1) Get your own keys by signing up for your own API key pair for your domain.

2) Adjust settings to make it invisible through google developers.

3) Put your keys into application.php on your FluxCP settings and chance settings to enable ReCaptcha:

Here is an excerpt from config/application.php from a very up to date FluxCP that I use:

    'UseLoginCaptcha'            => true,                    // Use CAPTCHA image for account logins. (Requires GD2/FreeType2)
    'EnableReCaptcha'            => true,                    // Enables the use of reCAPTCHA instead of Flux's native GD2 library (http://www.google.com/recaptcha)
    'ReCaptchaPublicKey'        => 'PUT YOUR PUBLIC KEY FROM GOOGLE RECAPTCHA HERE',                    // This is your reCAPTCHA public key [REQUIRED FOR RECAPTCHA] (sign up at http://www.google.com/recaptcha)
    'ReCaptchaPrivateKey'        => 'PUT YOUR PRIVATE KEY FROM GOOGLE RECAPTCHA HERE',                    // This is your reCAPTCHA private key [REQUIRED FOR RECAPTCHA] (sign up at http://www.google.com/recaptcha)
    'ReCaptchaTheme'            => 'light',                    // ReCaptcha theme to use (Value: dark or light) (see: https://developers.google.com/recaptcha/docs/display#render_param)

You MUST put in your keys from Google for it to work!!!

 

This all seemed to have worked for me, and the login button started to appear!  It uses invisible ReCaptcha as intended.

 

Regards,
Bobby

 

Edited by bob9497
  • Upvote 1

Share this post


Link to post
Share on other sites
2 hours ago, bob9497 said:

Diana,

For you and others in the future ---

I was having a similar issue, but resolved it.

Did you get your keys from google and put them in your settings?
 

GO HERE:

https://developers.google.com/recaptcha/intro

1) Get your own keys by signing up for your own API key pair for your domain.

2) Adjust settings to make it invisible through google developers.

3) Put your keys into application.php on your FluxCP settings and chance settings to enable ReCaptcha:

Here is an excerpt from config/application.php from a very up to date FluxCP that I use:

    'UseLoginCaptcha'            => true,                    // Use CAPTCHA image for account logins. (Requires GD2/FreeType2)
    'EnableReCaptcha'            => true,                    // Enables the use of reCAPTCHA instead of Flux's native GD2 library (http://www.google.com/recaptcha)
    'ReCaptchaPublicKey'        => 'PUT YOUR PUBLIC KEY FROM GOOGLE RECAPTCHA HERE',                    // This is your reCAPTCHA public key [REQUIRED FOR RECAPTCHA] (sign up at http://www.google.com/recaptcha)
    'ReCaptchaPrivateKey'        => 'PUT YOUR PRIVATE KEY FROM GOOGLE RECAPTCHA HERE',                    // This is your reCAPTCHA private key [REQUIRED FOR RECAPTCHA] (sign up at http://www.google.com/recaptcha)
    'ReCaptchaTheme'            => 'light',                    // ReCaptcha theme to use (Value: dark or light) (see: https://developers.google.com/recaptcha/docs/display#render_param)

You MUST put in your keys from Google for it to work!!!

 

This all seemed to have worked for me, and the login button started to appear!  It uses invisible ReCaptcha as intended.

 

Regards,
Bobby

 

I clicked Log in and the reCaptcha viewed and success but when click Log in after captcha there's no changes 

Share this post


Link to post
Share on other sites
Posted (edited)
On 9/21/2018 at 9:53 PM, Diana said:

I clicked Log in and the reCaptcha viewed and success but when click Log in after captcha there's no changes 

same with me. too much bugs 🙄 @Hurtsky

Edited by Yugosh

Share this post


Link to post
Share on other sites
13 hours ago, Hakahay said:

Where is the login button?

image.png.3678a0529639e4dbc78608dae98eef25.png

you need active your recaptcha first

Share this post


Link to post
Share on other sites
On 10/4/2018 at 4:37 PM, Yugosh said:

same with me. too much bugs 🙄 @Hurtsky

there no bugs, as demo, it just the login button need to use recaptcha, i will re upload with fix in another day 

Share this post


Link to post
Share on other sites
14 hours ago, Yugosh said:

you need active your recaptcha first

What if I do not want to use captcha?

Share this post


Link to post
Share on other sites
On 10/5/2018 at 8:34 PM, Hurtsky said:

there no bugs, as demo, it just the login button need to use recaptcha, i will re upload with fix in another day 

cant login idk how to fix it 
recaptcha alrdy enable from (google) too...

thanks i hope next update will fix it 🙂

Share this post


Link to post
Share on other sites
On 10/5/2018 at 11:40 PM, Hakahay said:

What if I do not want to use captcha?

need update from @Hurtsky 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now