Easycore

Release: Extended Battleground [eAmod BG]

Recommended Posts

BG seems to be working correctly, except it won't teleport the participantes to the maps.
After the minimum number of players used @joinbg, it says "the match will begin", fake guilds are set below the names, but there is no teleport to the maps.
Can you help me?

Share this post


Link to post
Share on other sites
When I use the Emergency Call, nothing happens.
Anyone know what they can solve?

@flea

Do the diff again, you missed somewhere you can believe.

Share this post


Link to post
Share on other sites

@mharkeke

Everything is working perfectly, but when I call Urgent Call, not after anyone.

PS: I have refaced the diff more than 4 times and analyzed correctly, everything is OK.

Is everything working there?
Did you use diff? Did you use the number 9?

Share this post


Link to post
Share on other sites

@mharkeke @Easycore

Everything is going perfectly, but the only problem is the Urgent Call, not after anyone.
 
 
I've made several changes but I still can not find the solution.

 

Share this post


Link to post
Share on other sites

I can not use potions in BG why?

Share this post


Link to post
Share on other sites
Has anyone been able to solve the Emergency Call?

Recall Solved

Share this post


Link to post
Share on other sites
6 minutes ago, loolp said:

Recall Solved

How did you solve it?

Share this post


Link to post
Share on other sites

Not working with the latest version of rAthena

Share this post


Link to post
Share on other sites
On 7/5/2019 at 3:16 AM, flea said:

BG seems to be working correctly, except it won't teleport the participantes to the maps.
After the minimum number of players used @joinbg, it says "the match will begin", fake guilds are set below the names, but there is no teleport to the maps.
Can you help me?

you need to check if you have the maps in place.

Encountered this error:
Severity    Code    Description    Project    File    Line    Suppression State
Error    C2065    'guild_index': undeclared identifier    map-server    \src\map\battleground.cpp    474    


Any thoughts what the problem is?
SOLVED > Rediffed the battleground.cpp no errors found

I just wonder how do i disable the IP check for Double Login.

Share this post


Link to post
Share on other sites

Hi, i would like to know if you guys can help me with this error :

NPCEvent 'Conquest: :OnBuildTeams' not found! (source: BG_Queue_Join)

script:bg_queue2teams: Non existant team id received 0.

NPCEvent 'Conquest: :Onready' not found! (source: BG_Queue_Join)

I get this error while trying to run conquest , but it doesn't start and i don't even get the emblem.

The way i installed the Easycore's eamod bg was literally putting every single thing in it's right place. i mean i did it manually by taking a txt like mob_avail.txt in ''import'', i did open it and then i copied from easycore's file to my file , i didn't replace anything.

Edited by Zenn Wahrheit

Share this post


Link to post
Share on other sites

Please add feature - Player Battleground Stadistics SQL

Share this post


Link to post
Share on other sites
On 7/15/2019 at 10:18 AM, dev LOOLP said:

Recall Solved

hey how did you solve the urgent call ?

Share this post


Link to post
Share on other sites
int guild_id = RFIFOL(fd,packet_db[RFIFOW(fd,0)].pos[0]),i;

Is this line a typo? I am having a problem that items added apple on the last card slot dont know if this affect it.

Share this post


Link to post
Share on other sites

How to fix this?

[Error]: quest_add: Character 114 already has quest 8600.
[Debug]: Function: setquest (1 parameter):
[Debug]: Data: number value=8600

And

[Warning]: Incorrect use of 'close' command! (source:FAKE_NPC / path:(null))

And

[Error]: buildin_delwall: wall "conq_RL00" does not exist.
[Debug]: Source (NPC): Conquest (invisible/not on a map)
[Error]: buildin_delwall: wall "conq_RL01" does not exist.
[Debug]: Source (NPC): Conquest (invisible/not on a map)
[Error]: buildin_delwall: wall "conq_RL02" does not exist.
[Debug]: Source (NPC): Conquest (invisible/not on a map)
[Error]: buildin_delwall: wall "conq_RL03" does not exist.
[Debug]: Source (NPC): Conquest (invisible/not on a map)

And bug!!!

Skill Emergency Call casting but (not call other bg members)

Edited by Grava

Share this post


Link to post
Share on other sites

I would like to run the BG from a certain time (for example between 18:00 and 20:00) how should I proceed?

I tried by replacing this OnRotate: by OnClock1800:

but how to make sure that the BG stops at 20:00 ?

 

I'm wrong about the changes to be made ...

 

Thx

Share this post


Link to post
Share on other sites
On 9/2/2019 at 11:54 PM, Grava said:

How to fix this?

[Error]: quest_add: Character 114 already has quest 8600.
[Debug]: Function: setquest (1 parameter):
[Debug]: Data: number value=8600

And

[Warning]: Incorrect use of 'close' command! (source:FAKE_NPC / path:(null))

And

[Error]: buildin_delwall: wall "conq_RL00" does not exist.
[Debug]: Source (NPC): Conquest (invisible/not on a map)
[Error]: buildin_delwall: wall "conq_RL01" does not exist.
[Debug]: Source (NPC): Conquest (invisible/not on a map)
[Error]: buildin_delwall: wall "conq_RL02" does not exist.
[Debug]: Source (NPC): Conquest (invisible/not on a map)
[Error]: buildin_delwall: wall "conq_RL03" does not exist.
[Debug]: Source (NPC): Conquest (invisible/not on a map)

And bug!!!

Skill Emergency Call casting but (not call other bg members)

I've experiencing this as well, can somebody help us? 😅

Share this post


Link to post
Share on other sites

Good Day @Easycore how can I use Gepard Unique ID to check if there is Dual Login. not the IP Address?. 

Share this post


Link to post
Share on other sites
2 hours ago, Skyzone said:

Good Day @Easycore how can I use Gepard Unique ID to check if there is Dual Login. not the IP Address?. 

battleground.cpp search:

if( session[sd->fd]->client_addr == session[pl_sd->fd]->client_addr )

and change to:

if( session[sd->fd]->gepard_info.unique_id == session[pl_sd->fd]->gepard_info.unique_id )

 

  • MVP 1

Share this post


Link to post
Share on other sites

Hi, im using ExtendedBG_rev9.diff with the recommended updated version Git Hash: c1975dall work fine.


but BG/WOE  consume for Telma don't work for me.
where's the problem?

thanks 🙂

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...