• 0
Nuckelavee

Crappy comeback (Win10 problem?)

Question

Hello again, after beign out of for a few years i have been asked to setup a few new RO servers, having done this over 50 times i know the steps very well, sadly something changed, and im unable to set up even a simple Dev Server as i keep getting Socket #2, 10060 error no matter what i do, ive tried:

- Set up port mapping for 5121,6121,6900,3306,80.(as usual)

2018-06-13_160324.thumb.png.65fd9f0a8a633232eb3d566ff864ed35.png

Then i ran into problems with VertrigoServ, since Windows 10 you require to Run As Admin or you get port problems (im fairly sure it was not necessary on Win7). So i went down the whole rabbit hole of Permissions, Alas, nothing worked down that road. 

- Also i double checked with Port Check Tool site if my ports where open, and weirdly sometimes they were, sometimes they weren't. Nothing worked even enabling/disabling DMZ, NAT, 30s Resets, Firewall, Windows Firewall, the 10060 error is still there.

- I also set up my No-Ip account and stuff it into all the necessary Conf Files. (Map and Char).

- I even loaded a previous fully functional server + its SQL databases, that was running perfectly in 2015, 10060 is still there./pif

The headache i got after 3 days of debugging this is horrible, so, im here to ask if anything as changed OS or Port wise since 2015 versions or someone ran into this same issue with Windows 10. im on the verge of going back to Win7 for my ServerPC. lol

 

Thanks in advance, its good to see this forum is still around./gawi

 

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0
Posted (edited)

Greetings Nuckelavee,

  1. Have you set up 192.168.1.64 as a static IP address for your computer on your router? This is necessary for the Port Fowarding to work, since you are redirecting incoming requests on your router to a local IP address.
  2. Your char_athena.conf should have your LAN IP on login_ip and your WAN IP/NO-IP domain on char_ip. Your map_athena.conf should have your LAN IP on char_ip and your WAN IP/NO-IP domain on map_ip.
  3. If your ISP uses NAT, it might be that your router in fact has an external IP address that is not your real (WAN) IP address. In this case, you might want to try this suggestion regarding your NO-IP configuration.
  4. You said that Port Check Tool wouldn't yield a definitive result regarding the state of your router's 5121, 6121, 6900, 3306 and 80 ports. This is indicative that either your ISP or your Router's Firewall is not redirecting incoming connections to your machine. Your router's port forwarding configuration is correct, though. Your ISP might have changed its contractual clauses between 2015 and 2018 to block any connections on non-trivial (i.e. other than 80, 443, 21, 22, etc) ports.

Summarizing

Your issue seems to come down to allowing connections on your Windows Firewall, on your Router Firewall and, perhaps, on your ISP's Firewall. It might be that other running applications are competing for the same ports used by VertrigoServ.

Please provide the contents of login_athena.conf, char_athena.conf, map_athena.conf as well as subnet_athena.conf for further support.

Sincerely,
Tyrfing

Edited by Tyrfing

Share this post


Link to post
Share on other sites
  • 0

Hey there Tyrfing,

Quote

Have you set up 192.168.1.64 as a static local IP address for your computer on your router? This is necessary for the Port Fowarding to work, since you are redirecting incoming requests on your router to a local IP address.

True, 192.168.1.64, IS a DHCP assigned Adress, but i did try assigning a Static one, 192.168.1.77, then remapping the ports, but, to no avail, the problem persisted.

Quote

If your ISP uses NAT, it might be that your router in fact has an external IP address that is not your real (WAN) IP address. In this case, you might want to try this suggestion regarding your NO-IP configuration.

Sadly, im very ignorant regarding my ISP parameters, as i never had to mess with it in an of my previous Rathena setups, but i will give the suggested NO-IP conf a try, thanks.

Quote

You said that Port Check Tool wouldn't yield a definitive result regarding the state of your router's 5121, 6121, 6900, 3306 and 80. This is indicative that either your ISP or your Router's Firewall is not redirecting incoming connections to your machine. Your router's configuration is correct, though. Your ISP might have changed its contractual clauses between 2015 and 2018 to block any connections on non-trivial (i.e. other than 80, 443, 21, 22, etc) ports.

2018-06-13_195234.jpg.466f5f009e0a672ad88f6613ba9cba5d.jpg

(In this screenshot it shows Apache/MySQL ports open, but Rathena's closed, just to clarify, it HAS shown open on ALL of em depending on what i mess with, but STILL 10060.)

Quote

 

Your issue seems to come down to allowing connections on your Windows Firewall, on your Router Firewall and, perhaps, on your ISP's Firewall. It might be that other running applications are competing for the same ports used by VertrigoServ.

Please provide the contents of login_athena.conf, char_athena.conf, map_athena.conf as well as subnet_athena.conf for further support.

 

Yes, my thoughts were that some bloatware in Windows 10, MIGHT be using some of the ports, as i had no issues whatsover on Windows 7. as for the Firewall, i believe i turned all of em OFF just to narrow down the culprits.

2018-06-13_193742.png.e2726eee99432ef3149541c5a674effb.png2018-06-13_193811.png.98ecc2d03daa61a6bcc4b5d0a2a8990e.png

2018-06-13_193829.png.fe988313a4d715abbc38858634aab705.png2018-06-13_193843.png.65edbb94ad0bf7d057c03f5db9a51eb6.png

(TBH the subnet file i've never touch previous to this problem as it wasn't required, everything in this build ran smoothly 3 years ago, Also, just to clarify, on the Login_ip, Char_Port, Char_IP fields, ive tried all the common ones, 127.0.0.1, No-IP, and LAN).

After a couple more of tests, i tried to access my server in LAN mode, by using no external ip's whatsoever, and it worked, but only until character selection, and it fails to connect, no errros or warnings given, again, this is a fully working build that worked smoothly in 2015, Client Side and Server Side.

Thanks for the fast reply, if you know anything else that might have changed, please let me know.

Share this post


Link to post
Share on other sites
  • 0

Update: i got back to good ol' Win7, the problem persist, even when All firewalls are turned off, so i believe it safe to assume this error that has something to do with the new "Generation" of routers, since im told nothing on the ISP side has changed in many years.

Also, i did notice that Rathena reads an IP from No-IP: XXX,XXX,XXX,108, and the NO-DUC program shows me something else: XXX,XXX,XXX,44, I did try the No-IP conf suggestions made by Tyrfing to no avail, im still gathering information but im inclined to believe its a problem with this specific brand of Routers: Arcadyan.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now