• 0
tedexx

ROCharGen problems

Question

got a fresh copy of ROCharGenPHP from KeyWorl, but having some problems with file loading from grf.

I'm loading the same GRF I use in the game (and even checked with GRF Editor to make sure the files were there, and it was), but ROCharGen cant load the files.

I tried with other grfs, same results. Using full updated iro grf.
Every file the script acuse to not found, I checked and exists. Same path.

/avatar/tedex - rendering avatar

Spoiler

1789dot.jpg


/monster/1002 - rendering a poring

Spoiler

YnF0AFh.png

 

Tested with multiples grfs, was able to load some files but got some other error.

Spoiler

IZpsJe5.png

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Odd....

I've tested using a clean setup of chargen with GRFs from various official servers and they all work fine. If the error says that it can't find the file, it means it's literally not there.

Have you tried with just an unmodified data.grf from kRO?

Have you also tried with default hair and palettes? 

Share this post


Link to post
Share on other sites
  • 0

Hello,

Sorry to bother, but im searching for the ROCharGenPHP files for weeks, all links seems down, can someone help me please ? :D
have a nice day !

Share this post


Link to post
Share on other sites
  • 0
6 hours ago, Akkarin said:

Odd....

I've tested using a clean setup of chargen with GRFs from various official servers and they all work fine. If the error says that it can't find the file, it means it's literally not there.

Have you tried with just an unmodified data.grf from kRO?

Have you also tried with default hair and palettes? 

Thanks for the reply! I dont know what to do anymore.
Its pretty strange. I tested with a fully updated iRO grf, the file is there but the script cant find it.
 

I did 2 tests, the first one was testing with juts one clean grf (iRO) and nothing more. The results:

EYCwuC1.png
6YmrMHA.png

 

The second test was trying with multiples grfs and it was way better, but the heads are still missing (images in the first post). Some sprites missing & Spr/Act heads failing.

And yes, all the grfs are 0x200

 

@Akkarin
Maybe is the version of ROCharGen I'm using? Can you pm-me your version? (Oficial repository is down by dmca)

Edited by tedexx

Share this post


Link to post
Share on other sites
  • 0

I manage fix the problems above. Got the newest kRO grf and worked just fine. (not sure why a fresh and fully updated iRO grf wanst working tho)

Having problem with hair palettes now, the files are found and loaded, but not applied to the hair. Any sugestions? (cloth palettes are fine)

Edited by tedexx

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...