Aleos

2014 Client Support

Recommended Posts

2014 Client Support

As of 3d9c6e7, rAthena is now able to support 2014 clients!

Roulette Feature:

Per-Character Gender Feature:
  • This feature allows individual characters to change sex.
  • The character table now stores a sex flag which can be "M" for male, "F" for female, or "U" for undefined (default). When the value is undefined the account sex takes priority.
  • Character sex can be changed from '@changecharsex <sex>' or the script command 'changecharsex <sex>'.
You can download the 2014-10-22 Client here. The client is currently patched with:
  • Disable Ahnlab
  • Disable ragexe filename check
  • Read msgstringtable
  • Read datafolder first
Thanks to Yommy for the preparation of this client!

 

These features require 20141022 or newer. Please report all bugs to the Issue Tracker!

 

NOTE: This 'support' post means rAthena added 2014-10-22 client (source and packets), not "post your issue about installation, how to get, how to make it work of 2014-10-22 client"

  • Upvote 6

Share this post


Link to post
Share on other sites

prepare for incoming issues, aleos /gg

  • Upvote 1

Share this post


Link to post
Share on other sites

prepare for incoming issues, aleos /gg

/wah /wah /wah

 

 

 

 

Let me try this Aleos :3

Share this post


Link to post
Share on other sites

Nice job! It's refreshing to see rA updating so much recently. Great work as usual Aleos and Cydh.

And of course a huge thank you to the people that coded it for Hercules as well. I'll probably hold off on merging this onto my server for a little while though. :]

Edited by Nova

Share this post


Link to post
Share on other sites

i got 2.0 and 2.4 nemo patchers and 2014-10-22bRagexe.exe but nemo is not working how to make 2014 work now that 2014 clients are now supported

Share this post


Link to post
Share on other sites

It's said that the 2014 client has already patched with some patches (which I don't know which one), so it's not a plain/clean client just like the others.

Share this post


Link to post
Share on other sites

It's said that the 2014 client has already patched with some patches (which I don't know which one), so it's not a plain/clean client just like the others.

 

Its patched with

 

..Disable HShield

..Disable ragexe filename check

..Read msgstringtable

..Read datafolder first

  • Upvote 1

Share this post


Link to post
Share on other sites

2014-10-22 use Packet Obfuscation seems no work

 

core.h

#define PACKET_OBFUSCATION

and 2014-10-22  no diff

1.Packet First Key Encryption
2.Packet Second Key Encryption
3.Packet Third Key Encryption

 

can enter the game

 

but diff ( use default key) 

1.Packet First Key Encryption
2.Packet Second Key Encryption
3.Packet Third Key Encryption

 

can't enter the game ....

 

-------------------------------------------------------------

edit

I found NEMO write it ..

Not available  yet on rathena ..

Edited by a91323

Share this post


Link to post
Share on other sites
Hi, I can connect to the char server, but each time I enter the game, i get disconnected with this msg in the map server:
 
 
[info]: clif_parse: Disconnecting session #8 with unknown packet version (p:0x5b27,l:19).
 
 
Anyone have a clue? ^^
 
 
Fixed:
It was the Disable Packet Encryption(Recommend) diff.

A question.

How does this Roulette official behavior work?

 

Example:
I have 1x Bronze Coin,

and right now in rA latest, I can use up that 1x Bonze Coin and play until the top of the pyramid....

 

Is that supposed be like this?

Edited by Lai

Share this post


Link to post
Share on other sites

I was able to use 2014-10-22 with Packet Obfuscation enabled just fine. Just don't apply the "Disable Packet Encryption" to your client. If you use "Packet First/Second/Third Key Encryption" make sure the keys you use match what you define in the packet_db.txt as well.

 

As for Roulette, you are able to continue playing with the same coin until you lose or choose to accept the item. This means you can reach the top of the pyramid with a Bronze Coin. Each coin type defines where you start on the pyramid.

Share this post


Link to post
Share on other sites

@Aleos, I see.

Thanks <3 Makes sense now.

Share this post


Link to post
Share on other sites

I was able to use 2014-10-22 with Packet Obfuscation enabled just fine. Just don't apply the "Disable Packet Encryption" to your client. If you use "Packet First/Second/Third Key Encryption" make sure the keys you use match what you define in the packet_db.txt as well.

 

As for Roulette, you are able to continue playing with the same coin until you lose or choose to accept the item. This means you can reach the top of the pyramid with a Bronze Coin. Each coin type defines where you start on the pyramid.

 

core.h

#define PACKET_OBFUSCATION

mmo.h

#define PACKETVER 20141022

no apply the "Disable Packet Encryption"

 

as long as apply

1.Packet First Key Encryption

2.Packet Second Key Encryption

3.Packet Third Key Encryption

 

client  and  packet_db same setting keys

is no work fine for me (can't enter)

....

can provided three keys ,  not default for give me test ?

---------------------------------------------------------------------

 

I tested 2013-12-23 , change keys  , it work fine .....

Share this post


Link to post
Share on other sites

You don't have to make custom keys, unless you want to. The default keys will work just fine.

 

If you prefer to use custom keys, then please use the tool nanakiwurtz made to create the keys. You can also test them on KeyWorld's webpage here.

Share this post


Link to post
Share on other sites

Where can i download the client?

Share this post


Link to post
Share on other sites

If I will change my client from 2013-12-23 to 2014-10-22.. On client side, can I just change the client itself? or do I still need to change the data files and other stuffs?

Share this post


Link to post
Share on other sites

The msgstringtable will likely need to be changed.

Share this post


Link to post
Share on other sites

The Luafiles will need to be changed too.

Share this post


Link to post
Share on other sites

As Nova and Tales stated, you'll still need to update the data files that go along with it.

 

Updated the first post with client download and other information.

Share this post


Link to post
Share on other sites

this post started become 'support' section

Share this post


Link to post
Share on other sites

this post started become 'support' section

 

everyone will post here, because its named 2014 Client Support  /gg

Share this post


Link to post
Share on other sites

this post started become 'support' section

 

everyone will post here, because its named 2014 Client Support  /gg

I'll lock this later if there's another incoming post /gg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...