• 0
Astroid

Flux CP Permission Denied

Question

I received this error after installing the flux cp. Im on CentOS 7.

 

Warning: fopen(data/tmp/ConfigServers.cache.php): failed to open stream: Permission denied in /var/www/html/flux/lib/Flux.php on line 275
Warning: fwrite() expects parameter 1 to be resource, boolean given in /var/www/html/flux/lib/Flux.php on line 276
Warning: fwrite() expects parameter 1 to be resource, boolean given in /var/www/html/flux/lib/Flux.php on line 277
Warning: fclose() expects parameter 1 to be resource, boolean given in /var/www/html/flux/lib/Flux.php on line 278
Warning: fopen(data/tmp/LangEnUs.cache.php): failed to open stream: Permission denied in /var/www/html/flux/lib/Flux.php on line 275

 

I've already tried several methods suggested in the forum including :

  1. Set the rights for data/tmp to 777
  2. Set the owner of data/tmp to apache
  3. Delete all the files inside data/tmp

I have been working on this for the whole day but still cannot get it to work.

Edited by Astroid

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0
12 hours ago, chryxt said:

up

Why necro a post and provide no information?

Share this post


Link to post
Share on other sites
  • 0

U need to give permission for directory  "/var/www/html/flux/"

Instead of give permission for data/tmp

Share this post


Link to post
Share on other sites
  • 0
On 1/7/2019 at 8:02 PM, Jsept said:

disable selinux

thx work like a charm 😎

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...